Ecobee Problems Accessing Account to Integrate

Hi All,

I recently noticed my existing Ecobee 3 thermostats and sensors stopped working so tried to get them online again. I was not able to login to the ecobee integration in the new app. I ended up removing all thermostats and sensors. Tried to re-add and get an error with some characters then ending in “invalid token”. Anyone having issues right now with Ecobee?

I have also tried removing and reinstalling the new app on my iPhone. No luck, same problem. Similar issue using the classic app as well. Any help is appreciated.


No such problem with My custom DTH called My ecobee device… I’ve just tested it w/o issues and there are many more features than the ST stock one… [RELEASE] Resilient My Ecobee Device and ecosystem V5

I am using ecobee suite and it isn’t having issues either. May want to check your account on Ecobee’s website or try one of the custom software packages. Ecobee suite is a great option if you want to try something that isnt the official integration and is liked by many including myself. It is also free.

Thanks guys. FYI I had to go into the Ecobee web interface and remove the SmartThings integration from there. Then I was able to re-add all my thermostats and sensors. I’ll take a look at this suggested DTH as well.