Ecobee and ST help please


#1

Hi all, I’ve just started using ST and while I understand some of the basics, I am absolutely lost when it comes to making it really work for me.

Right now we have an ecobee3 with 2 sensors and 2 Cree connected bulbs.

I have them all connected and can control them via ST but I’m also having some difficulty getting the routines to work properly.

1st. In my ecobee programming I have 3 comfort modes set. The 3 automatic that ecobee starts with and I made another comfort setting for an evening drop in Temp. It drops the temp, AC, down a few degrees at 6:30pm. The first issue I’m having with the ecobee and ST is; ST doesn’t show the 4 modes I have set when I try to set an evening routine. It only shows “away” “home” and “night” but not the “evening” setting I added.

2nd. I only have a few things and a few routines set up and most work perfectly but a couple I’m having issues with. For instance I have “wake up” routine that brings the temp up a few degrees from “sleep” mode, it’s set to trigger at 8:30am. The “wake up” routine works good.

I have an “away” routine set to bring them Temp up a few degrees when “everyone leaves” and it works good.

Where I’m having issues is; I have a routine set for evening Temp that drops the temp a few degrees from the home setting and it’s set to trigger at 6:30pm and the temp setting is set by putting in a specific temp, because ST doesn’t show my “evening” mode on my ecobee. The “evening” routine also turns on our 2 Cree bulbs.

I have one set for home that sets the ecobee to “home” setting when someone arrives.

And I have a “bed time” routine that’s set to turn off the lights, and drop the temp to “night” mode on my ecobee, it’s set to trigger at 10:30 pm.

This is the routine I think I’m having an issue with.

The evening routine fires perfectly however, at 10:30p, when the lights are schedule off and, the temp is supposed to go to night mode, here I am at 1am and the ecobee is still showing “holding at 71” (which is what it’s supposed to be) and the lights are still on when they should’ve turned off already.

I can trigger “bed time” manually by pushing the button BUT, it’s not triggering the lights A

We did run out for dinner, and the “away” mode must’ve triggered however, it seems like the “away” mode is still active and running.

Any ideas as to what’s keeping my “bed time” routine from happening?

Thanks all…


(Bill S.) #2

Can you post the rules for your bed time routine?


#3

I’m not sure exactly what you’re wanting or if there’s a way to “show” you the routine so I’ll just list it.

"Bed Time"
Turn off these lights or switches: Front Entry Lamp, Bonus Room Lamp
Change the mode to: Night (ecobee set for 69 degrees at night setting)
Automatically perform “Bed Time” at the configured time: At a certain time, that time is 10:30pm

In an attempt to figure this out, right now the 2 lamps we have in ST, are set to go on at 6:00pm in a routine all by themselves.

The other routine that precedes “Bed Time” is “Evening Temp”

Set thermostat to: 71 degrees
Automatically perform “Evening Temp” at…
The configured time: at a certain time (6:00pm)

The lights uised to be set to come on with this routine. Also, I’d set it up to “change mode to” for the thermostat but ST things isn’t showing the custom comfort setting I manually added in the ecobee schedule…

Is that what you were asking for?

Thanks


(Bill S.) #4

ST doesn’t support changing modes on the Ecobee using the standard device handler. So, when you say it changes the mode to Night, it’s changing the mode in ST, not on your Ecobee; You can only set temps.

With that said, do you have the routine setup only to run based upon a mode? You can check in "Automatically perform “Bed Time” when… and then Advanced Options > Don’t automatically do this if I am in one of these modes.

That’s the only thing I can think of in terms of why the routine isn’t firing automatically. You might want to try deleting the routine and re-creating it and see if that helps.