Ecobee 3 turn on and off

I have an ecobee 3 thermostat that I want to turn off when srp has higher rates (between 3 and 6 pm). I was able to turn the thermostat off at 3 no problem, but I not sure what to select to get it back on with the same settings and schedule before it turned off. There isn’t an “on” option. I tried “auto”, but it stayed off. I was going to try “resume” tomorrow, but I thought someone would probably know the correct option without me having to guess and check. (Some of the options are in the picture.)

For a little more info, I’m having the thermostat do a precool before 3. I’m also keeping the smart recovery and follow me features on. I just need to turn it off when the srp rates are higher.

Hi, you just need to set it back to ‘cool’… It was in cool mode before, right?

Thanks yvesracine,
Actually it was on auto before. With the auto setting it will switch between heat or cool. I could probably set it to cool and then change it every season, but I was hoping just to set it back to where it was.

I attached a screenshot of the ecobee setting.

Well, auto mode will switch between cool and heat depending on the ambient temperature… That’s the purpose of the auto mode.

If you want to exclusively cool your house, you need to use the cool mode, or change your heat/cool delta according to your needs.

Regards.

Yep, auto is what I have it on in ecobee. When I turn off the thermostat in smartthings, and I try to turn it back on with the “auto” setting (from smartthings) it didn’t turn back on. It sounds like you are saying “auto” was the correct thing to choose in smartthings, so maybe the signal just didn’t get there on first attempt.

Hi, if you’re using the ST stock device, I recommend to switch to My Ecobee device which is more resilient to any ST or ecobee outages.

Also, My Ecobee device exposes more features and you have some complimentary smartapps that you can use with it.

Refer to this thread:

Regards.

Thanks yvesracine. I wanted to keep it simple for now. So I was just trying to figure out if “auto” for smartthings is the “auto” for ecobee. Or if smartthings should be set to “resume” or “Auto Change Over Active” or something else for ecobee to return to “Auto”.

You could just push the temp with a temporary hold to a temperature that doesn’t require cooling. Then just have it resume. (That is what I do)

I actually have my “away” set points set to a temp that will not run the AC or Heat unless there are temperature extremes, and use presence in smartthings to trigger away mode. If anyone comes home OR if the next schedule temperature change occurs, then it resumes the schedule.

Thanks tweason,
I was still using the smart recovery feature for precooling, which helps it precool the right amount of time, but it also cuts into the off time if I just set a higher temperature. Maybe I’ll turn off the smart recovery and do that.

Calling “auto()” in the SmartThings stock DTH should work.

Try running Live Logging and test your app again - check the live logs for both the thermostat device and Ecobee Connect SmartApp, looking for any “error” or “warn” logged items.

If you’d like, you could try my Ecobee Suite - it’s free, and it gives you many other automation Helper apps, such as setting your thermostat to Away when your location Mode changes to Away, etc.

I have APS, not SRP, but I do something similar. However, I don’t turn the unit on/off, I just raise the set point so that it doesn’t really come on.

I have solar too, so I do the following.

My APS peak times are M-F 9:00 to 21:00.
My solar produces enough power for the ACs until around 15:00.

From 21:00 - 15:00 - My ACs are set to Auto with a cooling temp of 75 and a heating temp of 73.
From 15:00 - 21:00 - My ACs are set to Auto with a cooling temp of 85 and a heating temp of 73. The house doesn’t get up to 85 in that time frame, so the ACs for the most part are “off” from 15:00 to 21:00.

The only other thing I do is run a Webcore piston that checks the current cloud cover. If it’s over 65% I turn the ACs off as my solar may not be covering it. Luckily it’s mostly sunny in AZ where I live.

Edit
Sometimes on really hot days we’ll set the upstairs unit to 81 between 15:00 and 21:00. That unit is much newer and is efficient enough to keep my demand charge (the real killer with APS) below 6kw.

Thanks Barry,
I noticed something weird with smartthings. If I try to set up the routine while the ecobee is off, it no longer gives me any options for heat, cool, auto, etc. I’ll look at your ecobee suite soon.

That’s an interesting idea. I need to get into webcore. I just haven’t had time yet.

As far as setting the temperature higher, I was having the following problem. Right now I have smart recovery on. It basically makes sure you’re at the correct temperature at the beginning of any scheduled time. I thought this would help with precooling, as it would start cooling at just the right time. However, it also means during the time I want the AC off, it will start cooling in prep for 6pm. I can turn off smart recovery, and then come up with a webcore routine for calculating the time and temperature to precool, but I was hoping to ease into it with something simple.

I’ll try a few more simple things, and then go to webcore.

I don’t use smart recovery. My units cool the house down quickly once 21:00 rolls around.

On a bit of a tangent. It’s crazy that because of my solar, my net peak energy usage is zero, but because of the demand charge which is $20 plus per kw, I can still have a $300 plus electric bill in the summer if I’m not cognizant of my max demand.

One hour a month can make or break me.

Yep, just did a code review, and their DTH actually changes the list of supportedThermostatModes to be on “off” when you set it to off. And if it’s in Auto mode, you can’t change it to Heat or Cool either! It is not what they intended, but it is a definitely a bug in their code - you’ll never get it to work unless they fix the bug (in generateEvent(), if you want to report it to them). It won’t work from WebCoRE either, FWIW.

I am positive that neither of the third party Ecobee DTHs suffer this limitation…

I was on APS when I lived in Tempe. Their pricing is odd that way. At the time we didn’t do anything to save energy, and we’d have $450 bills in the summer. I had wondered if I set up some system where only AC or water heater or refrigerator could run at a time if it would help because of their peak usage pricing.

Barry,
That’s super helpful to know. I’ll have to give your DTH a try then.

I may as well submit the error for others. Where would I submit that?

support.smartthings.com

Tell them that in generateEvent() within the file ecobee-thermostat.groovy, they initialize the list of supportedThermostatModes to be ["off"], and then only add other modes if they are ever engaged. So once you turn it Off, the list is left to be only ["off"], which guarantees that you can’t turn the thermostat back on again.

The bug has been there a long time - they last updated that file 9 months ago…

2 Likes

Thanks Barry,
I submitted to their support site.

Hopefully this weekend I’ll have some time to try out your code.

Barry,
Thanks again for you help and your ecobee integration. I finally have it a shot today, and so far so good! I have my thermostat set to precool then I use your integration to turn the thermostat off and on during the higher electric rates.

Some day I hope to get around to calculating what the precool temperature should be and how long it should precool.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.