Echo won't permanently forget devices

It depends who owns the integration …

And so, it was the Amazon who fixed it.

If Hue disallowed access permission to Alexa, how did the Alexa service force Hue to give it access anyway?

Well that is a chicken and egg situation…Amazon went in and had to unlink my hue hub on the back end.

I have 4 sets of Hue lights set up in my house. I named them very simple, calling them Lamp, Mantle, Bar, and Table. I can command Alexa to turn on the Bar and the Table by saying Alexa turn bar on or table on and I can control those with no problems. The problem I am running into is, when I ask her to turn on the Lamp or the Mantle, she says she has found more than one device with that name. SO, I deleted all the groups under smart home and have no groups set up so its not that. If I go under Devices, alexa finds 13 devices and I see two labled Lamp and Mantle. One says Lamp Room Living room connected via Hue and the other says Lamp Color Light. Same with Mantle. If I set either of these to “forget” so that there is only one, alexa will work properly and turn them on or off by saying Alexa turn on lamp. It works…

My problem is, Alexa, without me telling her too, will after some time (as short as 15 minutes) will for some reason, research for devices and re-add the two I just told her to forget. This happens everyday… I tell her to forget one of the Lamps and Mantle, she works… the next day instead of 11 devices, she is back to 13 and cant tell which one is which so she wont turn them on. I do not know why she is looking for new devices when I dont tell her too or why she adds them back. Any idea what can be done about this. I called Alexa tech support, told them about it… they had me forget the two devices and power alexa down for 30 seconds, then restart… They were suppose to call me back two days later to see if it worked (it didnt, nor did they call me back to check). In about 15 minutes, alexa had reaquired the the two lamp and mantle I told her to forget. Is there a setting you can turn off to stop her from looking for new devices unless I tell her to look for the devices? Really annoying because I cant have her control these lights by command…

I have read above and some of it confuses me. Can anyone give me step by step on how to fix my problem. I dont have smartthings app or I really dont know what that is. All I use is the amazon alexa app and the hue app, yet it sees two lamp and mantle lights. I dont want to lose everything so it seems people on this forum know exactly how to fix it. I was just hoping that someone could help me with step by step of what I would need to do to fix this…

Thanks

Vortimous

I have this exact problem now with smartthings and the Echo. I just moved into a new house and need to relocate/rename old devices and add new ones. I just wanted to start from a clean slate - so removed everything from smartthings devices and from LIFX, deleted the Alexa app from smartthings, and did a discovery on Alexa. There they were.

I went thru all of my devices and disabled them in Alexa, did a discovery, and boom. They are back. This is very clearly am Amazon problem.

See the ones called disabled? They no longer exist anywhere on my network or in any of my apps - but they refuse to die in the Echo

Yup, Amazon also killed the option to forget all devices and scenes with their new update. Running discovery doesn’t remove devices associated with disabled skills, only adds new scenes/devices.

@uberrob run as fast as you can to a windows computer. They didn’t update that app, yet and you can still clean up all your devices and scenes

1 Like

I solved my problem by deleting the items in my Kasa app. Note: the item
has to be installed, and working before removing. IOW, you can’t simply
delete it from the controlling app if it isn’t installed. Once you do that,
then Alexa will not discover it.

If you no longer have the device, to install and delete, then there is
nothing you can do. Alexa will continue to discover that device.

Hope that’s clear enough.

Thanks Bobby - that did it. I was able to clean up my device inventory.

This should help … I had to reset due to a poor naming convention & had to disable roughly 15 invalid devices. THEN, new devices were used under disabled devices. I got fed up & called Amazon and got the answer – go to https://alexa.amazon.com/ and ‘forget all’ at the bottom of Smart Home / Devices. Then, rescan and it’ll only pick up whatever is configured in Hue. :crazy_face:

2 Likes

Toloughlin, this was AWESOME advice/info.
Thank you.

toloughlin - “THANK YOU!”. I’m buying your next beer/coffee/whatever. I’ve been trying/searching to clean up Alexa’s devices and names of devices for over a month. Unrelated to Hue, this solved a bunch of Alexa device naming issues in about 30 seconds.

I’ve tried this but don’t see the option to forget all. Am I doing something wrong? The link above takes me to the app if that’s correct?

You need to login from a computer, not a mobile device.

One thing I jut discovered with my Hue lights is that you have to be careful that you do not name an individual light the same as a room. That is what I did wrong. I had a light name ‘Bedroom’ in a room named ‘Bedroom’. In the Hue app I renamed the room ‘Bed’ and left the light with its original name of ‘Bedroom’.

The Echo discovers both rooms and lights and they all have to have unique names.

In the Hues app for the bridge, rename rooms so that they are different than any of your lights. Then in the PC web app for the Echo click on ‘Forget All’ and then rediscover. Now you can control the lights with the bulbs name with all of the cool colors and scenes.

Hi,

I had the same problem - but you can actually revoke your Alexa access to your Hue bridge using the web based CLI:

  1. Get the IP address of the bridge: https://www.meethue.com/api/nupnp # on your home network

  2. Login here: hue bridge ip/debug/clip.html

3a. in the URL: box just have /api
3b. in the Message Body box type: {“devicetype”:“my_hue_app#iphone peter”}
3c. Press the link button on the bridge
3d. Click “POST” back in the web browser.
3e. After you click POST, you should get a new authorized user. It’ll be a long string like, 8234a4617d04da72f3331aa551d2dc. Note this down and use it where I have put your auth code

  1. In URL box type: /api/your auth code/config/

  2. About 13 lines down, you’ll see the whitelist…all the apps that are authorized to access the bridge. Somewhere you’ll see “Echo” as a name

  3. Get that long alphanumeric string above it (it’ll look like: f6SEmYj6FMGSq5aRqaP4jPO6YaHbbddAzhBjo2qnD

  4. In the URL box type: /api/your auth code/config/whitelist/long_alphanumeric_hash_here

  5. Press DELETE. You should get a “success” message

I’m stuck at #2. I have tried numerous combinations of my ip address (putting <>, spaces, etc) with /debug/clip.html and nothing happens, just a google list of suggested websites. Very frustrating. I’m not a coder but I’m not illiterate either. Where the heck am I supposed to log in? Here? Where is here? I can’t find it!!! 3a says “just have /api” - do you mean just TYPE /api? Every keystroke matters and I am trying to follow along, but if you’re going to post this in 5 million different places on the Internet, please make it accurate and usable.