Echo Speak - how to add Fire Tablet?

Is “communications” enabled on the fire tablet?

Yes, Communications is Enabled in Settings,Alexa, Communications.

UPDATE… Amazon couldn’t figure out why my FireTablet gives the wrong city when I ask Alexa for the weather… their big idea is to ship me a new tablet. Doubtful that’s going to solve my problem but ok… new tablet schedule to be delivered in 3 days. We’ll see… but I think this is an Amazon Cloud issue. But receiving a new tablet will again allow to me to reset Echo Speaks with it and see if it will finally be recognized.

1 Like

Next UPDATE: New Amazon fire tablet arrived. To my surprise… this device now provides the correct weather information for my town when I ask Alexa. However, Echo Speaks also does not find this tablet. Does anyone have a 9th Generation 10" Amazon tablet that is recognized by Echo Speak? The only step left I can think of is to completely remove Echo Speak and do a full re-install.

UPDATE 3 - the very next day… the new tablet like the first one is now providing weather information for the wrong town. Bizarre! I think I’m just going to have to live with that.

Did anyone get this working? I’ve got 2 fire tablets, and Echo Speaks doesn’t list any of them after the latest software update (3.6.1.0). Before, they we’re listed as unsupported even when I had enabled tablets

1 Like

I have been trying for a couple of weeks to get my HD 10 to be recognized by ES. I have changed all kinds of options in ES and the Alexa app. I deregistered and re-registered the pad. Nothing works. The pad works in every other function including with the Alexa app and it is listed in the Alexa app as a pad. I just cannot get ES to recognize the pad and add it.

When I run a speak test or weather test, the screen on the pad shows an announcement screen or displays the weather. It does not go back to my ActionTiles screen. How do I keep these screens from coming up and just play the audio?

Are you running the Fully Kiosk Browser? If so, to into Kiosk Mode (Plus) and enable Disable Other Apps .

1 Like

I am still getting the notification screens when “Alexa” speaks through the tablet. They don’t go away (back to my ActionTiles screen) and are really hurting the “wife factor.”

I have the same issue but it never bothered me. The only time though I get those screens are when I ask for weather or timer, etc… but normal ST commands like turn on & off lights doesn’t produce any additional screens. I will say though I renamed the activate word for my Fire-tablet from “Alexa” to “Computer” which prevents it sometimes doing a command I meant for an actual Echo device and when I do ask the Fire-Tablet for the Weather or Timer… when I’m done and I want to show again ActionTiles… I simply say to the tablet… “Computer, open ActionTiles” and ActionTiles then gets displayed again.

1 Like

Sweet. I wonder if I could write a webcore piston to “open ActionTiles”? Thanks for the info. I’ll report back.

I’m not sure how webcore could work for that. Maybe another app could be used to ensure that ActionTiles is the always the “on-top” display as ActionTiles doesn’t actually close when an Alexa pop-up occurs. I bet such an app already exists… maybe even one of the KIOSK apps. Really wouldn’t work in my situation as I’ve also linked my Fire-Tablet to a in-wall bluetooth audio amplifier for my living room. When playing music, I like those Amazon screens to either show me the album cover or lyrics. But I bet an android app exists that could force which app is always displayed as the “on-top” display.


Initially this did not work. But I set it again, and it now seems to be working. Thanks.

1 Like

I am still not able to add my Fire HD 10 (9th generation) to ES. I reset the pad to default. I registered it. I turned on Alexa. That’s all. And it still will not show up in ES or my ST app.

Same here. I’ve given up at this point. Maybe one day either Amazon will make the Tablet be more like an echo device or Echo Speak will update the app to include it. Hopefully we won’t be waiting too long.

I just started setting up multiroom echo/Alexa devices, 4 echo dots and 4 fire tablets, the echos work together, the tablets will only work individually, after some researching amazon has disabled fire tablets from joining a group, hopefully that helps

I am having the same problem with my fire hd 10 9th gen. Did anyone get this working? Thanks

Echo Speaks was discontinued over a year ago because it was using too many system resources. So no models work at the present time in the smartthings environment. :disappointed_relieved:

If you search the forum you can find some of the alternatives people are now using.

Using Amazon Echo for announcements