Echo Speak - how to add Fire Tablet?

Just began using Echo Speaks and Webcore and loving it!!! However, I have a new Fire Tablet and a bunch of various Echo devices. Echo speaks finds all my echo devices except my new fire tablet. In the Echo speak app I do have in Device Detection preference ‘Auto Create’ & ‘Create Devices for Tablets’ turned on. And I do see the Fire Tablet when I login to Amazon’s web portal. But Echo Speaks doesn’t pickup the Tablet. Does Echo speak auto finds the Fire Tablet or is there a way I could add it manually?


In ES, go to Manage Devices and select Tap to Manage.

In Device Detection Preferences, select Tap to Configure.

Turn on Create Devices for Tablets.

Back your way out and reload ES.

Thanks for the reply Bry… I already had “Turn on Create Device for Tablets” and it didn’t work. After reading your comment, I turned it off and exited ES then when back into ES turned it back on, backed out of ES again then re-entered ES and still it doesn’t pickup my Fire-tablet. I even have “create other Alexa enabled devices” turned on as well… still no Fire-tablet. I doubled checked that it wasn’t in the “Don’t use these device list” and I even tried the “override Blocks and Create Ignored Device” option as well… all with no luck.

Is the Fire Tablet registered to your Amazon account that your Alexa devices are on? If you can control your SmartThings devices via Alexa on the tablets then it should be. If not, then you must register the tablet before EchoSpeaks can see it.

Hello rontalley… yup, the tablet is registered with my Amazon account. I can see it in my Amazon web portal. I’m using the tablet with Action Tiles and all works with ST even with the built-in Alexa I can turn things on and off with voice as well.

I’m wondering if I will need to remove ES and re-install but I’m not sure at the moment how much problems that is going to cause me with all the dependencies I have setup with it now with Webcore.

thanks for the suggestions though.

UPDATE… I still haven’t been able to get Echo Speaks to find my Amazon Fire tablet (9th Generation 10" model). I also found a weird problem with the tablet itself. When I ask the tablet to show me the weather via Alexa it always provides me weather for the wrong town. I own several Amazon devices and all of them provide the correct weather except this tablet. I’ve called Amazon and worked with their people. They even remote connected directly into the Tablet and couldn’t find any reason why it was giving me the wrong weather information. I can see the Fire-tablet and all my other Alexa devices in my Amazon portal so it’s bizarre. The last Amazon tech told me they had to open a ticket with developers and get back to me. I’m hoping this Amazon issue is related to the Echo speak problem I’m also having. BTW… the Amazon tech wanted me to remove Echo Speak as if it was somehow related to the problem. I didn’t do that as I seriously doubt that is the issue. This seems like an Amazon cloud problem to me.

I have the same problem.

I’m sorry you’re also having this issue but secretly I’m also happy because maybe it’s not just with my system but a Fire Tablet issue. This weekend I installed an in-wall bluetooth amplifier and have it paired with this fire tablet. The in-wall bluetooth amplifier is connected to a pair of in-wall speakers. It works great. But I noticed that if I open the Amazon music app on the tablet to select from recommended music it provides me a list of my echo devices… interestingly enough, the fire-tablet isn’t on the list. Sounding more and more to me this is an Amazon fire-tablet issue. Amazon still hasn’t gotten back to me on the open ticket. If they do… I’ll be sure to give an update here.

If you open the Alexa app and go to devices and select “Echo and Alexa”, does the fire tablet show up in the list?
(It is from the device screen here that you can see the device location that is used for weather.)

Yes, it appears there…

Is “communications” enabled on the fire tablet?

Yes, Communications is Enabled in Settings,Alexa, Communications.

UPDATE… Amazon couldn’t figure out why my FireTablet gives the wrong city when I ask Alexa for the weather… their big idea is to ship me a new tablet. Doubtful that’s going to solve my problem but ok… new tablet schedule to be delivered in 3 days. We’ll see… but I think this is an Amazon Cloud issue. But receiving a new tablet will again allow to me to reset Echo Speaks with it and see if it will finally be recognized.

1 Like

Next UPDATE: New Amazon fire tablet arrived. To my surprise… this device now provides the correct weather information for my town when I ask Alexa. However, Echo Speaks also does not find this tablet. Does anyone have a 9th Generation 10" Amazon tablet that is recognized by Echo Speak? The only step left I can think of is to completely remove Echo Speak and do a full re-install.

UPDATE 3 - the very next day… the new tablet like the first one is now providing weather information for the wrong town. Bizarre! I think I’m just going to have to live with that.

Did anyone get this working? I’ve got 2 fire tablets, and Echo Speaks doesn’t list any of them after the latest software update ( Before, they we’re listed as unsupported even when I had enabled tablets

1 Like

I have been trying for a couple of weeks to get my HD 10 to be recognized by ES. I have changed all kinds of options in ES and the Alexa app. I deregistered and re-registered the pad. Nothing works. The pad works in every other function including with the Alexa app and it is listed in the Alexa app as a pad. I just cannot get ES to recognize the pad and add it.

When I run a speak test or weather test, the screen on the pad shows an announcement screen or displays the weather. It does not go back to my ActionTiles screen. How do I keep these screens from coming up and just play the audio?

Are you running the Fully Kiosk Browser? If so, to into Kiosk Mode (Plus) and enable Disable Other Apps .

1 Like

I am still getting the notification screens when “Alexa” speaks through the tablet. They don’t go away (back to my ActionTiles screen) and are really hurting the “wife factor.”