Eaton Aspire Master and Accessory Association

I have the Eaton Aspire switches throughout my house so when I needed a 3way ELV dimmer, I went and purchased the RF9540N and RF9542Z at the recommendation of Eaton support. I did not know these were zwave until they arrived but I installed regardless as I would not be able to return the items. After I installed, the 9542 accessory would not work and after some research I realized it needed to be associated via zwave. I then go out and buy the smart things hub but I now find out the 9542 cannot be added via the new app. I called smart things support and they stated they could not help but pointed me to this forum stating someone here will be able to provide a solution, possibly using the classic app. I did read on the forum about a thing called a minimote but was not sure if I need this to get my switches working. At this point, I just want the 9542 to be able to control the light. If I am not able to control the light via the app, no big deal. Thanks!

We used to use the minimote, which is another device, But now you can just use the Z wave Tweaker, which is software, a device driver. You will temporarily assign your accessory switch to that driver, set all the associations, and then assign the switch back to the regular driver. The associations are stored in the firmware on the switch itself, so they will still be set.

It sounds harder than it is, it’s basically just copy and paste, and there are lots of people who will be glad to help you. Unfortunately, I’m not feeling very well today, so I’m going to leave it up to other people going forward. But you can find the tweaker in the following thread and ask questions there:

[BETA] Z-Wave Tweaker (See post #209 for new V3 app version)

And here’s the community FAQ on how to install custom code. You will need to be using the classic app for this, but it’s fine if you have both versions of the app. (The topic title is a clickable link)

Thank you for your help JDRoberts. I hope you feel better. I logged into the smartthings IDE on my PC and can see all of my devices but do not know what to cut and paste. As I am new to all of this, can someone please help me figure out how to add the 9542 to my smartthings hub.

Thank you!

Sorry folks, I was able to add z wave tweaker to my device handler in smartthings IDE but now stuck as to what I need to do next. I thought the tweaker would show up on my classic app but it does not. I still am not able to add the RF9542 as the app will not recognize it. Please help!!

Thanks.

Find the switch you want to control in the devices list in the IDE. Make note of its device ID.

Find the switch that you want to “tweak” in the devices list in the IDE (the accessory switch?). Click on it to open the device page. Make note of the “Type”. Then edit at the bottom. Set its device handler (“Type”) to Tweaker. Select “Update”.

Now goto your mobile app (classic) and look at the switches page. It should show the tweaker controls. Select the gear icon in the upper right. Enter the Association Group ID (likely in the instructions for the device) , Enter the device ID in the Group Members.

I think you want to set Command Class to Autodetect. Otherwise look for the 85 or 8E in you devices raw description.

Once you get things working you can set the switches device handler (“Type”) back to the original.

1 Like

Thank you for your help. My challenge is when I try to add the accessory switch, the switch itself is responding to the request to add as the led on the switch changes from blinking to a solid light but the switch does not show up my device list. I did the zwave exclusion and re-added three times but it still does not show up. Trying to figure out how I can get the switch to show up on the device list.
Thank You!

You may want to try two things.

  1. look in the manual for the switch and see if there is a factory reset that can be done.

  2. If it is a long way from the hub, remove it from the wall, wire to an extension cord and plug it in near the hub. Then try to pair it. If successful reinstall, and run a z wave repair on the hub.

Also I found this: https://www.eaton.com/content/dam/eaton/products/wiring-devices-and-connectivity/wiring-devices/z-wave-wireless-collection/z-wave-wireless-accessory-dimmer-spec-sheet.pdf
Once you get it paired it looks like Group 1 is where you want to associate your other switch. Also look at the configuration parameters. You can tweak those to your liking.

Have you figured this out yet? I have the same issue and it is becoming frustrating. I have tried on the new smartthings and classic version.

If you are using a custom DTH, this is probably the stale DTH problem.

FAQ: My lock/device does not pair or appears to pair but it won't show up in the mobile app or IDE - stale DTH

I do not have any custom DTH. I was going to set up the tweaker to sync the switches once I could see the accessory in my device list.

Is this topic dead, or still active? I’m struggling with the same or similar issue.

Jack

Which issue? There are several discussed in this thread, along with a couple of solutions.

Sorry, I can’t even find how to quote what I’m replying to. I’m not familiar with this forum’s software.

I should probably start a new topic, specific to my issues.

I accidentally bought an RF9617 (Z-Wave accessory switch) to use with an RF9640-N (Z-Wave Plus Universal Smart Dimmer). Eaton lists the correct accessory switch as the RF9642-Z, which includes a dimmer. I have NO need of the dimmer on the accessory switch, so is it possible to associate the RF9617 with the RF9640-N?

Let me know if I should start “my own” new topic.

Thanks.

I think it will work, it’s just an on/off accessory so you won’t get dimming from the accessory switch. But I just don’t know for sure if the Eaton master switch will accept the on/off command or if it expects a dim level command.

Before doing anything else, if it was me, I would contact Eaton support and ask them what will happen if you use that accessory with their dimming master switch. :thinking:

I already did that. I initially bought the CORRECT switch (the RF9642) and could not find out how to associate it with the RF9640-N. I spent a frustrating hour or more with their techs, and they told me to contact SmartThings, they don’t support it. I went as far as speaking to a manager to tell them “works with SmartThings” is inappropriate if they don’t support making it “work with SmartThings”. That’s when I returned all my “companion” switches. I used hard-wired toggles for the non-dimmable switches, but I found the dimmable one has no traveler wire and does not support hard-wired connections.

After realizing their switch was my only option, that’s when I went back and mistakenly bought the RF9617. Since I don’t care about having a second dimmer control, that’s why I’m asking if I can associate this switch with the master (RF9640-N). But Eaton does not support their product in any way that I can tell. It’s unfortunate, because the switches seem to be high quality.

So that’s correct, one dimmer (and automation) is enough.

I’m game to try it, but I’m lost on the instructions. I figured out what “IDE” is, and I’ve installed the Z-Wave Tweaker, but I’m still pretty lost. The Z-Wave Tweaker doc repeatedly refers to “tiles” but I can’t find anything in the mobile app that resembles them.

Jack

And since Z-Wave Tweaker broke my automations (that was expected), how do I remove it? I can’t now, because “DeviceType still in use by devices”. The Z-Wave Tweaker doc says:

Cleanup Tile:

Tap this tile when you have finished using the Z-Wave Tweaker. It will remove all collected data in preparation for reinstating the original device handler.

I don’t see any “Cleanup Tile” (or any tile, for that matter), or anything about Labs or Z-Wave Tweaker in my mobile app.

Jack

You are only intended to use the Tweaker for a moment in time while you reconfigure the device you assigned to it through the IDE.

As soon as you complete that configuration, you should manually reassign the device to its original DTH.

So if your Routines did stop working, it would only be for the brief period of time while you were reconfiguring that device and they would be restored once you went back to the original DTH.

You are correct that the “cleanup” process is no longer needed: that was used with a previous version of the app.

Speaking of which: are you using the version from post 209 in this thread? Not the original version? (See the topic title). There were several required revisions when the ST app received a major update.

Also, in your case you would only use the tweaker for the trigger device, in this case the accessory switch. Not the target (the master).

I

I got the code from SmartThings/devices/zwave-tweaker at master · codersaur/SmartThings · GitHub, not from post #209. It is:

  • Date: 2017-03-16
  • Version: 0.08

Since I thought the Tweaker would do its own cleanup, so I did not make note of the original DTHs that were assigned. Is there a way to retrieve that info? My mobile client has an “ORIGINAL SETTINGS” section, but it appears empty.

I have been ill for a couple of days. I intended to write a post for you explaining what the tweaker does for your specific devices, but that’s going to have to wait until I feel better.

I’m sure all this feels very technical and overwhelming. The fact is that smartthings gives us many fewer tools than a typical Z wave hub. Most of them just have a screen for each device which lets you quickly set it up to control another Z wave device. All you have to do is select the device to be controlled.

Smartthings doesn’t. They appear to have made a design decision back in 2013 that they would hide any protocol – specific features from the end-user so that a Zigbee device would look just like a Z wave device. That’s the whole reason you need a DTH to begin with: it’s a smartthings-specific construct that they’ve laid over the independent third-party specifications.

Over the years, several device manufacturers have become frustrated with this whole idea because it means that their certified devices which work just fine on most zwave hubs don’t work on smartthings without special code used only for smartthings, and smartthings keeps changing how that special code works so it has to keep being updated. So the manufacturers have two choices: they can hire somebody whose job it is to keep up with the smartthings-specific changes, as Zooz and Inovelli have, or they can throw up their hands and say “we are certified to the independent third-party specifications, and anything else is the responsibility of the hub manufacturer” as Fibaro has done. And from your description, it sounds like that may be the direction that Eaton is going as well.

It’s very frustrating for us as customers, but it is understandable from the manufacturers point of view. And it leaves us as a community trying to help each other.

Thanks,

Now I see there’s a later version – the scroll bar says it’s post #205 (not 209) but the actual html target is #209. But I found it anyway:

  • Author: David Lomas (codersaur)
  • Date: 2017-03-16
  • Version: 0.09

Since I have devices using the Tweaker, I can’t remove or update it.

“Technical” is not a problem. I’m a Unix Engineer by day.

Having to jump between multiple sources (Github, forum posts, etc.) and then decipher unfamiliar jargon (IDE, groovy, DTH, blah blah blah) is pretty challenging, though.

Thanks for your help. I hope you feel better soon. But if I can’t get this solved today, I’m considering returning these switches to Lowe’s and replacing them with the Leviton switches that use travelers. I wish I’d bought those in the first place. Fortunately, Lowe’s is pretty good about returns.

1 Like