[(duplicate thread)…]

I have an MCO Home MH-S513 touch panel switch which has worked fine for several years, but in the last week stopped working all together. It manually works but is dead with Smartthings. I removed/excluded it from the Smartthings network and included it and it created 4 devices. One for each button (switch) and 1 master switch. All looked good except it still doesn’t work. Smartthings knows when it is turned on and off (and reports this) but cannot perform any controls. When I look at the device on my phone using the Smarthings app I briefly see a message ‘This device hasn’t updated all of its status information yet. Check again later’. That was 72 hours ago and nothing has changed.

I’ve noticed on these forums that there are drivers for the 2 and 4 button switches, but not for the 3 button. The driver that has been installed is the generic Z-Wave Switch driver.

Any help on how to fix this is appreciated.

A post was merged into an existing topic: Post Requests for Zwave Edge Drivers Here (community-created)