DSCAlarm - LXXero - Envisalink 4

I’ve been trying to figure out where things are going wrong in my setup here. For several months all has been working well in my setup using the code from LXXero’s GitHub.

I have my alarmserver.py setup on a CentOS box in my network and I have the port (8111) forwarded into the alarmserver. When I start up the alarmserver.service, I can see it create the zones inside the SmartThings app on my phone and IDE. The logs inside the alarmserver.py also show where it is communicating with the Envisalink module connected to my DSC. If I open/close doors/windows, I see those updates reflect on the ST app as well.

My problem is when I try to arm the system or bypass a zone, it simply stamps in the alarmserver logs 'Incoming web connection from (‘xx.xx.xx.xx’, xxxxx) but no action is taken as requested from the ST app like it should.

Does anyone have any ideas as to why I could be seeing the incoming web connection stamp in the logs when I press a button on the ST app, but not have the action take place?

I’ve restarted everything, done tcpdump to validate that traffic is coming through and connections are being made. Everything is updating on the ST app with the current statuses, but it appears that the alarmserver is not passing on the command from the button presses inside the ST app and passing them on to the Envisalink module here.

I’m in the same boat. My setup worked flawlessly for about 2 years. I get the same alarmserver logs. I tried to get help from this community, but no one has responded. I gave up and no longer use the integration except for perimeter monitoring. Good luck!

1 Like

I’ve been having the exact same issue since ST updated our hubs to firmware 19.17 about two weeks ago.

I’m not sure the issue is with alarmserver. I think it’s the hub that is somehow missing a beat and not sending requested command to alarmserver. Thus, we see the event in ST cloud but the command never get logged in alarmserver.

If I’m not mistaking, the data flow vary between status updates and commands.

Status : EVL-4 -> alarmserver -> ST cloud ->App/WebCoRE/else
Commands: App/WebCore/else -> ST cloud -> HUB -> alarmserver -> EVL-4

Maybe @Xero would be interested to have a look into it, just in case.


I know @blacktirion was very involved recently too.

@blacktirion does your disarm commands goes thru consistently as of late?

1 Like

Thank you both for confirming things. I was up for several hours trying to figure out if I had something fail/change, but everything was looking fine over here. Hoping to see if @Xero answers on it.

I think kebel871 found the answer to this issue in the main thread, check that solution if you’re still having issues…