SmartThings Community

DSC -> EVL-3(4) -> Alarmserver -> Smartthings



Thanks for taking a look!

When I do that, (successfully login and chose the location) I get this:

My system is in the new app working fine.

Not having a code with the new hub, I’m pretty well stuck…

I guess one question is whether I need to use Classic app if all I want is to be able to use statuses as triggers?

I did fire up Alarmserver on my PC, and it did connect to my Envisalink, although I didn’t see anything in the new app.

As an aside, I did wake up the family when the alarm went off last night as I was playing with this. The system changed from armed STAY to AWAY when Alarmserver started up as I’ve seen mentioned before. I haven’t seen a permanent fix for this yet (Alarmserver apparently sends a *1 looking for bypasses, but when armed, this changes it to AWAY instead). Anyone have a reliable fix for this (ex. checking for arm status before sending)?

(Nathan Curtis) #1813

Is there more than one location listed? If so what happens when you choose the other one?


After the password, I get this asking for my location (I assume this is what you are saying?):

Then I get this, but there is no code for new hubs:

Is this a moot point if I only want DSC sensor status for triggers, or must I have the apps loaded (which apparently requires SmartThings Classic to load for the first time)? Is it possible to get the statuses from Alarmserver without loading the apps?

The new app is set up and works for everything else.


Well, I did get past the logging into the classic app problem. Even though I have an account and had been using the new app, I tried the option for a new user (instead of using my account info) in the classic app. It then said I’m already logged into my Samsung account on my phone (I happen to have a Samsung phone), and started up with my devices visible. Weird, but it works now.

I guess my fundamental question is whether the Stay/Away bug mentioned above has a workaround, as that is a showstopper (if Alarmserver is started while in stay mode, it changes it to away mode). I’ve had the alarm go off due to this already.

(Jordan) #1816

you can literally just comment out that one line in the code to stop it from doing that.

I will try to figure out a more proper update for it later, there was some other ideas here that have been come up with that might work as a better solution in the mean time.

(Jordan) #1817

OK i decided to merge in the updates from the alarmattribute branch - so anyone using that branch in the IDE should switch it back to master now. Also, I decided to remove the sending of *1 on startup, so hopefully that addresses the immediate issue. It does mean bypass statuses will only get sent when a change happens or when the EVL feels like sending it. Also, the “refresh” button will still do it, so i guess there’s that option, and that won’t happen automatically.


Thanks! I did comment those spots out in the meantime.


I’ve made some good progress using Alarmserver on a Raspberry Pi combined with webCoRE to automate lights, etc. based on alarm sensors. I haven’t been able to figure out how to do something like “Lock Door when alarm changes to Armed”. Is there a way to do so?


Hi think the only way to do it is by changing your mode from Home to Away. I dont use locks so im not entirely sure, but I think I remember reading something like that somewhere.


Thanks. The lock part is easy, where I’m having issues is how to set up an IF statement that can tell the state of the alarm (armed [either stay or away] or disarmed). I believe Alarmserver reports it in a way that can be used in an IF statement, but I haven’t had luck yet.

(Hendre) #1822

Not sure if I understand your question, but all you have to do is to test if the Panel switch attribute changes to ON?


So I finally had the Alarmserver working on my Rpi, but then it crashed and stopped communicating. I have tried to restart Alarmserver and now I am receiving a permission denied. Could anyone assist as to what is needed to fix this?

-bash: ./ Permission denied

(D Gjorgjievski) #1824

Regarding my problem that alarm server gets stuck, I totally redesigned my network and split the smartthings and rPi to separate VLAN to avoid any interference but it didn’t help.
So I quit going that direction but instead set a chron to restart the service every hour and disabled the *1 send on reconnect (I am not using bypassing that often, so I can live with it).
So now even if the alarm server hangs, after 1 hour everything is fine :slight_smile: (although my experience showed that at least 10 hours were passing before hang, but it was random, sometimes it would work for few days also).


make sure you are in the alarmserver directory and type python

(D Gjorgjievski) #1826

Dear Phillip,

Can you provide me little bit more details on how you solved the systemd requirement?
I had it all running on a rPi but from once in a while the SD card of the thing just dies, so i am thinking of more sustainable solution. Unfortunately it also happened yesterday

I am thinking also going in the Docker way, I started creating Ubuntu container but there alse I face issues with the systemd. Systemd requires to be run as PID 1 but it was one of the limitation that docker has.


(D Gjorgjievski) #1827

Dear Mark,

Can you please clarify if the latest changes from @Xero are implemented in your code?
Also do I need to change the existing smartapp (and devices) or I only need to install the server?
I would try avoiding changing the smartapp since I have quite some automations built in and I would try to avoid redoing everything once more


(Phillip) #1828

I have a DS214 which will not run Docker, so unfortunately I can’t help you from that standpoint. I got alarmserver working natively and then added it to the Task Scheduler in the synology GUI (which basically just adds it to the crontab for startup). If you decide to go that route, I would be happy to offer assistance.

(D Gjorgjievski) #1829

Thanks Phillip,

I would try docker first using chron on the Ubuntu container I created yesterday or use the docker container from @texasaggie97. It is easier to backup a docker container so in case something happens to my NAS I can reload it faster.
If I fail I’ll go your route

(Jordan) #1830

hey all, i’m still following the thread, but a lot of the issues being discussed seem more initscript/systemd related and more specific to the various methods you’re using to try to launch the service, so I’m not sure how much help I can be (or how much I want to get involved, hahaha!) but i will gladly help if there’s anything specific to alarmserver. I’d actually like to consider providing a minimal docker image, maybe something based on alpine or some other super-tiny distro, we don’t need a full ubuntu install for this by any means.

On that note - i’ve been looking into the new smartthings API and what it might take to migrate out of the old groovy IDE. It’s an absolutely huge undertaking and will involve rewriting the entire smartapp as either a Rest API or an AWS Lambda function. I’m still debating which - as I wasn’t really trying to setup and host some rest api on my own server, but could easily do that if i needed to. It’d likely require a ton of alarmserver changes too, but given that’s all python and what not - I’m much less concerned in that area. The smartapp and devices through the new API would be a huge, huge change, and i’m not even sure what new features we can tie into for alarm related stuff. I am sort of curious if anyone else is already working on something, I’d probably have to pick what language to even write said app in at this point, the new API means that’s pretty much my decision now, we could even try to do the whole thing in python just to keep it consistent? I’m open to other ideas though. The AWS Lambda function can be written in python, as well, so that’s possibly another win for this being the way to go, the real question is, am I ready to go jump into a full oauth-python-smartapp-thingy hahaha…its likely more hours and time than I even have right now, but it has to start somewhere as the groovy IDE will be deprecated at some point, so I’d like to throw some ideas out now.

(D Gjorgjievski) #1831

Well even the Ubuntu docker doesn’t use much resources. Mine uses about 1% CPU power and 15MB RAM.
However I am struggling to make the to start automatically. So far I can only start it from terminal
I tried to create chrontab with:
@reboot /bin/ &

and also ssh to the NAS and apply the below:

docker run -it ubuntu /bin/bash -c /
where is simple script running

but the thing does not start on reboot.
I would also like to add some watchdog to restart the application on hang.

Any help would be welcome