Does a Tuya soil monitor(QT-07S) pair and works with smartthings?

Just wondering if this Tuya soil moisture monitor(QT-07S) is able to be paired straight to smartthings without using a Tuya gateway and of course has edge drivers that work.

Want to make sure before purchasing it.
Thanks in advance

It probably will work with this driver.

1 Like

@w35l3y Thats connected straight to smartthings and not through a gateway.

Was it a question?

Driver is needed to pair the device straight to smartthings without any other gateway.

You answered my question.
No gateway needed.


I’ve done my best following through all the content, installing the edge driver, etc. I can’t get this working. I’m really not certain of all the settings that are required… the screens here look slightly different than the ones I see on my Android phone in Smartthings. Like which profile to select… I’ve tried Generic and “Humidity and Temperature sensor” along with setting generic data points to 3,5 and 1,2,3… I get no data back.
I’m pretty new (obviously) to this edge driver implementation stuff… could use a step by step procedure once the driver has been set.

Can you take a screen shot of the settings.
Mine in setting is set to profile normal using data points 5,3,15 8 if that helps.
These setting were set when paring the device.
Have you tried to delete the device and repair it?

From the profile you are, you should select the profile +battery.
Or simply remove and pair the device again, it should select the right profile automatically.
In the settings, keep manufacturer in blank or change it to _TZE200_myd45weu

1 Like

Thanks to you both… once I deleted the device and re-paired, it started working. At least I have values reporting for Temp, Humidity and Battery… I did change the data points and manufacturer as above but the data values didn’t change so I guess it defaulted to the right bits… now to figure how accurate they are and screw with the offsets I guess. I question both temp and humidity, showing 77F and 90%, when it’s 80F in the house and the soil is barely barely moist…

Seems to be working after the delete/re-pair

After some testing, comparing soil temp with my Thermapen, turns out the temp value is spot on! And leaving the probe open to the air after wiping it down well with a dry paper towel, it reports 0% humidity and in water it reports 100%… the range though of soil needing water and that which just got watered, is way up in the 85-95% window it seems, as in: if humidity <= 85% then water. Does that sound reasonable?

1 Like

@w35l3y Olá Wesley.
I have installed successfully your driver to work with this Soil Sensor (bought from AliExpress, as always :slight_smile: ).
However I’ve noticed that the 2 AA batteries run out quite fast. The first 2 ones lasted for 1 month or so, I have put a new pair and now that I am checking it more regularly, it seems that this device is sending status update many times per hour, even when there is no relevant change in temperature or humidity.
Is there a way to control how frequent those messages are sent? Can I set some threshold so that oit nly send updates when temp increases, for instance 2 degrees or humidity changes up/down 2%?

I have it installed in an external mini-garden so it gets sunlight in the morning, then shade in the afternoon and then night. Not sure is the “DP for Relative Humidity Measurement” and “DP for Temperature Measurement” are those thresholds but I am afraid not.

Obrigado pela sua ajuda, Wesley

I don’t know any way to make zigbee devices that use 0xEF00 cluster less chatty.

Please, let me know if you have any luck finding it.

That’s the only attribute I added, it is executed once every 5 minutes: