DLINK DCH-Z510 Siren Connection -- help needed

Hey there,

After consulting this community forum I went out about bought a DLINK DCH-Z510 Siren (UK). Unfortunately, I cannot get it to pair at all.

Does anyone have any ideas?

It should pair immediately as an Aeotec siren and then there is also a community created custom device type handler which a number of people are using:

If it’s not pairing at all, the most likely thing is that it thinks it belongs to a different network. This can happen even with a brand-new device, because it may have been paired with the test network at the factory.

The usual first step with Z wave device is to make sure that it is in fact on the exact same frequency as the hub that you have. For example, if the siren was manufactured to run on the US or Chinese Z wave frequency, it would not be able to pair to a UK frequency SmartThings hub. I assume you’ve already done that. That’s usually just the model number.

The next step is to do a “general exclude”. Any certified Z wave controller, including SmartThings, can issue this instruction and then there should be a button or something that you push on the device and the device will then clear its old network information. At that point it will be ready to pair to a new network, so you just do the regular pairing process.

There should be instructions for what you have to do with the device during exclusion in the user manual.

Here are the instructions for issuing the exclusion command:


1 Like


I had to exclude the device, but adding the special Device handler before actually pairing also prevented the product from pairing so had to remove that too.

1 Like

Are you using the tamper key to get it into pairing mode and then again while SmartThings is looking for the device.

If the above doesn’t work, you may need to be within 5-10 feet from the hub and you may have to unplug it for a little while and then plug it back in and try to add it again.

If you’re able to get it to connect, it’s most likely going to connect as a zwave switch so you’ll only be able to use the default sound.

The device looks a lot like the Zipato siren, which is often rebranded, and the zwave specs also look similar so the device handler below might allow you to at least change between a few of the sounds.

See post two above, it’s true it is a variant of the Phileo, but there is actually a specific device type handler already available for this device. :sunglasses:

Yes, and I’ve tried re adding the handler but to no avail :frowning:

I had the response open for a while before saving so I missed the first few responses and didn’t see there was a DTH written specifically for that device.

When you say “tried adding the handler” do you mean creating and publishing the custom device handler for that siren or going into the device’s settings from the IDE and manually changing the type field to the custom device handler?

1 Like

I’ve done both - neither worked for me. I couldn’t get the different sounds to activate so at the moment I’ve just reverted to the Aeon Siren which is doing the essential work for me.

If you can’t get the device handler to work that was written for that device, try the one I posted for the Zipato Siren.

It probably won’t work, but it’s worth trying because the zwave commands and configuration looks similar.

I had an issue with pairing when it was associating with the dth and the device ID not matching. Do a search you’ll find a post on it.

How did you get to pair the device ?

Install the custom dth, create a new device via the ide, and you should be good to go

I have successfully paired the device, when I change the device’s device handler to the Zipato Multisound Siren, it does sound the siren, (only 1 emergency sound). but when I change it back to the Dlink DCH-Z510’s device handler (DLINK DCH-Z510 Siren) nothing happens.

the log shows this:

debug Sending Insecure Command BasicGet()

debug Sending Insecure Command NotificationReport(event: 3, eventParameter: [], eventParametersLength: 0, notificationStatus: 0, notificationType: 10, reserved61: 0, sequence: false, v1AlarmLevel: 0, v1AlarmType: 0, zensorNetSourceNodeId: 0)

debug Sounding Siren With Emergency

any idea how this can be solved?

Hello. I am completely lost. I first created a Device manually using the ID found in the pairing mode. Then the Device simply would not work. So I deleted both the device and device handler , and I tried a couple of different DHs. It won´t pair anymore. I also troed the exclusion process described above.

what is the next step now, please?