SmartThings Community

Devices online, difficult to remove, impossible to re-add

Hi,

I have had a stable setup for a while, with 20+ devices, automation mainly via Webcore and RBoys apps. I am using a Hub v1. I have a Hub v2 but it’s always seemed so daunting to transfer all devices and automation to the new hub that I never did it.

Recently I noticed that a Centralite outlet that are less than 20 ft away from the Hub stopped reliably connecting and working. I removed it through the app, forcing a remove. After removing it, I was hoping to be able to re-add it, tried to reset it following the Centralite instructions (https://centralite.com/products/smart-outlet) but nothing seems to be happening, the app/hub can’t seem to see it. I replaced it with a Monoprice Z-Wave Plus Wall Socket Plug-in Receptacle with 2 USB and 1 AC Port (https://www.monoprice.com/product?p_id=15654) that had previously been connected to the Hub but I had removed. It can’t see that one either, no matter how much resetting of the device I do.

I am at a loss because this worked so well for so long. I’ve tried Z-wave network repairs but it doesn’t seem to do anything.

What advice do you have for me, what did I do wrong, how can I correct?

re-publish your custom device handlers

Wouldn’t that only apply if I am using a custom device handler for this device (which is the case here and I just updated it after receiving your message - but it didn’t help).

you need to go a general exclued and then put the outlets you wish to pair in/exclued mode to make sure they are properly exclued and ready to be re inculuded