Devices offline, no fix in sight. Smartthings has acknowledged the bug


#101

Humbug. I’m just getting started w/this and have had some SmartThings in the house for a couple of weeks now, and been slowing adding devices. Now I’m starting to see this unavailable issue. Yesterday the hub itself went offline for a bit. Now today I’ve got two devices (GE z-wave plus outlet and smartthings motion sensor) dropping in and out. Looking at the IDE they actually seem to be coming back, but then dropping out again. Sounds like I need to reset them, and turn off device health, to get things going again. Is this correct? Frankly if this continues I will probably punt on Smartthings altogether - this is supposed to make my life easier not more complicated!


#102

I have been using SmartThings for several weeks now. The only devices I have at the moment are several smart bulbs (all the same brand). They have been working flawlessly, now some are showing as unavailable even though I can still control them. I’ve reset the hub, tried turning things on/off, running routines, crashing the iOS app, etc. Nothing works. I am not going to re-pair the bulbs yet, because I hope this will remedy itself. Really annoying when everything is working fine and then you receive error messages for no reason.


(Mark) #103

This fixes a lot of z-wave problems.


#104

Now both devices are back. Of course no hint as to what might have happened to mark them offline in the first place. However, the outlet did seem to be genuinely having problems - not only could I not get to it thru SmartThings, but I couldn’t get to it thru Alexa either. Is device health actually causing the problem? Or was there some real issue, that has somehow magically fixed itself?


(Brad) #105

You were likely impacted by server issues which were resolved about an hour ago.


#106

Hmm. Timing sounds about right. Is there any way to tell when there are problems? Be nice to have it announced so the users aren’t sitting here scratching our heads about it. :smiley:


(jkp) #107

https://status.smartthings.com/


(Craig Harrison) #108

Thanks for the tip! Confirmed this works for leak sensors that randomly show offline with device health enabled. I used to go around and pull the battery as they would all go offline at the same time. Turning off device health and opening settings in ST app resolves it. Been going on for months. Maybe ST will work to resolve this at some point.


(Jeremy Kane) #109

They seemed to have closed any replies on the 19.19 firmware update. I had a great working system until this update. SmartThings sent a new hub to me so this has been two hubs with problems.

My Zwave devices just can’t stay online anymore. Most of them are GE In Wall Switches but those aren’t the only ones with problems. Some devices are close to the hub and just can’t stay online. I have tried repairing my Zwave network many times. I basically “started from scatch” with this new hub they sent and I can’t get the majority of Zwave devices to stay online. I swear it is due to the firmware update as I used to love Smartthings and things were working well for me prior to this update. Is anyone else having particular problems with Zwave devices?

I have been on the phone with support many times and they are friendly and try to help but I feel like I am fighting a losing battle these days. Its so frustrating to have a great system setup and then have it ruined without any real ability to bring it back up.

I am mostly posting this to see if there are others that started having problems with their Zwave devices in the last month. Thanks,


#110

All my xiaomi sensors went unavailable/offline after few hours of pairing…I tried remove and pair all the sensors again and same thing happen. But my hue lights are all working just fine… Can’t find an solution for this, can any body give me some suggestion?

I have tried:

  1. turn off other connected devices ( which is the hue only, I unplugged the hue bridge when I pair the xiaomi sensors)
  2. turn off device health

The above didn’t fix the problem.


(Will) #111

Pait them and leave them near the hub for a day or two until they stay online. They tend to have issues staying connected if they are being router through another device. Once they stay online for a day or two, they tend to stay online for a long time.


#112

I just started with Smartthings and got 1 GE In Wall Switch. The very next day I paired it went offline overnight. I turned off device health in the app and that helped for a while. Today I noticed that it shows offline in the app and there are no events in the log of it being turned on/off during the day. The only thing that fixed it is the youtube suggestion to go to the IDE in the cloud and then ‘update’ the device - that brought it back to online status. Link: https://www.youtube.com/watch?v=rQnXx9G-_yA. I find it crazy that a major bug like this exists and it’s not yet fixed.


(John C) #113

Yes. A Zooz ZEN-23 in-wall switch. For the second time in less than a year.

It is terribly frustrating, particularly when I was 1500 miles away & it was part of my security lighting at the other location.

In my case, Device Health was turned on (did I do it? did an app update do it? I thought I’d turned it off!) and the switch just fell off the network. It took a bit of local fiddling with rebooting the hub & Z-Wave Repair to get it working after we returned for the holidays. Doesn’t seem to have been the switch, from what I see.

Perhaps the problem is the robustness of the SmartThings ZWave implementation? Or the obviously broken Device Health feature? Or the particular (local, baked into the firmware) DTH?

We may never know…

Very frustrating. :confused:


(Jeremy Kane) #114

Could you let us know if it stays online after a few days, week, etc.? My experience is that they do not.

Thanks


#115

Here’s an update: I thought I fixed it remotely through the website, I didn’t. When I got home I realized that the switch is still unavailable. I tried repair, replace, remove - nothing worked. I had to cycle the breaker and then reset the switch (3 up followed by 3 down clicks) and then force remove the device from the app, and then add it back, even adding back didn’t happen right away, I had to click up the switch few times. Finally it did and it’s working for some time now. Unfortunately I only have 1 switch and cannot comment on whether it’s hub’s fault or switch’s. Does anyone know how to debug these scenarios? Are we the few unlucky ones? When I check Smartthings reviews they are mostly positive and people don’t have these problems. Same goes for this GE zwave plus switch - I don’t see people reporting any major issues with them. I’m puzzled…


#116

To add here: I didn’t have the health feature enabled in the app before the latest drop-off. When I just installed the switched couple of weeks back I did have the health monitoring on since it was turned on by default. The very next morning the app reported that the switch is unavailable. Surprisingly google home continued to work with the switch just fine. I disabled the health monitoring and the switch became available. So, I left the health monitoring off.


#117

Although I have no proof, it seems that this issue does not affect Zwave
plus switches.


(Jeremy Kane) #118

I’ll try and pay attention more to whether my device is Zwave or Zwave Plus. I hadn’t really considered the difference.

As to the positive reviews, I have had a SmartThings setup for a few years and the switches worked well. I hate to repeat myself but I really believe the recent firmware updates promising “z wave improvements”. Things went south immediately after and haven’t improved (even with a brand new hub).


#119

It does, mine is zwave plus switch


(John C) #120

This matches my experience, as well. Except that the same switch fell off the ZWave mesh the first time last spring. Prior to that, I had no issues.