Devices offline, no fix in sight. Smartthings has acknowledged the bug

For me - it is only Zigbee. It is the same 4 devices. they work fine for a week or so, then go offline and I have to simply pull the battery and reinsert and it works fine for another week or so. They all go offline at different times as well.

Zigbee issues for me as well. I was fine through 18.20 (beta) but the problems started once they updated me two weeks ago to 18.21, Every few days,I have to power off/on many zigbee lights to get them to work again.

yeah, my zigbee motion sensors are the main issues with devices offline

When did that start happening? I have around 12 Zigbee devices and for the past week or two they’ve been really bad as far as disconnecting goes. Sometimes all of them would be offline while Zwave were all online. Some of the Zigbee devices would then come back for a while on their own, then go offline again. ST support said this could suggest interference particularly from 2.4Ghz devices. The odd thing is that I was running these many of these devices for over a year with no problems whatsoever.

I agree that the issues seemed to have started with a recent update. I can’t say if it was 18.21 or not, but it was sometime around 1-2 weeks ago.

When I last looked at things last night most of my Zigbee devices were offline. However, to my surprise, this morning ALL of my Zigbee devices (and all devices in general) are back online without me having to do anything to bring them back. ST pushed what they said was a critical update to the hub firmware yesterday to everyone (I think). It said it resolved connectivity issues with the hub. I am not sure if they meant connectivity issues to the internet (which I didn’t seem to have) or connectivity issues to the devices. Perhaps it was the later, in which case it then took about 16 hours but things have settled down. Let’s hope things resolve themselves. ST did not mention to me two days ago that this was a known issue, but perhaps at the time they were not aware of it, assuming that is what this firmware primarily is designed to fix, which may be a big assumption at this point.

All - please report back here if your issues are improved now or improve over the next several hours with firmware 22.

Edit: In looking at the firmware 22 info it does not seem like the issue it corrects relates to device connectivity. You can read about 22 here: Hub v2 Firmware update 18.22 rolling out right now

I wonder then what has changed that overnight now has all my devices online, after several days of very significant nearly constant offline issues.

Guys - here’s a piston designed to send a notification if a device goes offline. It seems that it can take the hub quite some time to mark that the status has changed in either direction, such as going offline or coming back online, so if you test it by removing a battery for example, do not expect the alert right away. It would be good if the alert could be faster but I think that’s just a function of how the hub works (only checks / polls occasionally). Note that you do NOT need device health turned on to use this. In fact I turned mine off after several reports of it being buggy.

As a bonus, this piston also is designed to report when a device’s battery drops below 90%. I use 90% instead of something much lower because it seems the battery drain is exponential and in some cases once it drops below a seemingly high % a device may no longer be able to communicate with the hub. You can update the piston for whatever threshold you want to use of course.

Hey There, Just to confirm it is only my zigbee devices. Zwave devices unaffected. Yes, I turned device health off as well but still having a problem with some of the devices not reporting. These are devices which have been removed and re-paired after turning off device health. Hmmm.

Yes, my zigbee devices have started to drop off, and it was around the time of the recent hub firmware debacle. I think they said that the underlying zigbee radio firmware was updated, but they then rolled it back to avoid other issues. However, something isn’t the same as in the 17.x series as I never had a single drop-off until then.

1 Like

Never had a real problem (maybe occasionally) with this, but now it’s very bad and causes multiple devices to go “off-line” when they’re actually fine. Had to turn off device health to regain access to various devices. Please fix this known issue.

Want to also chime in… I started having the same issues several weeks back starting with two zwave locks. Support ask me to remove the locks and add back in. This caused other devices to become unavailable and unresponsive.

Luckily I saw this thread. I had to disable the health check, remove and add couple devices and repair zwave network. Things are stable again.

Wish support told me about this bug. Would have prevented alot of frustration.

1 Like

Like I tell all my friends: I LOVE Smartthings, and it works, most of the time.

Only issues are:

  1. This thread, loosing devices
  2. Their app is less than intuitive, to say the least.
  3. Modes are mostly useless (see 3-4 year old post from me somewhere on how to solve it, no response from Smartthings). You better not want any modes that could overlap (like AWAY and NANNY MODE, or HOME and MOVIE NIGHT mode)…
  4. Sometimes apps needs to be opened and closed in the app to work again, like they enter some non-functioning zombie state.
  5. Many apps are sort of useless in the real world. Like the ones that starts a timer and turns the light of if movement. GREAT, unless the lights were ALREADY on and should STAY on… Oh well, I coded my way out of all those, so that helped :slight_smile:
  6. Health checks. Why. No really… Why is this still live with these bugs.

That said, we do actually LOVE it, 98% of the time. IT’s just… it could be so much better.

Come on Samsung, pour a little love on us…

2 Likes

Thanks for the tip, I’m having this problem and after shutting off Device health the problem disappeared. It’s weird that I couldn’t control the devices from the app, but they continued to work for their automations.

Device health doesn’t seem to do much. Came home today and two devices had failed. It’s constant. So my suggestion is replace all ST devices with Xiaomi ones. Only one has ever failed. Once! I check them regularly . Shame but St devices are a liability to ur security.

My problem is somewhat different. I have Samsung SmartThings Skills enabled in Amazon Alexa. I have tried to discover devices again and again, tried to enable/disable but the 3 power outlets I have - Samsung are unresponsive in Alexa! I have switched off device health also, still nada.

It is interesting. I just noticed a Leviton z-wave plus dimmer went offline. I knew something was up with it since Alexa couldn’t access it and said that the dimmer was not responding, but it appeared online in the app. I was looking for possible solutions when I noticed it suddenly went offline. I tried the disable device health option and it appeared online, but would not respond to commands.

This is the first device that I have had this issue with, should I expect many more?

I have random devices still going offline so not sure what to expect. I reset and re-add then a few days later they go offline again. Wemo bulbs , Sylvania connected flex strips and garden spots right now. I have worked ith ST techs to move hub, disable health check and firmware updates on bulbs. hasn’t seemed to make a difference.

Humbug. I’m just getting started w/this and have had some SmartThings in the house for a couple of weeks now, and been slowing adding devices. Now I’m starting to see this unavailable issue. Yesterday the hub itself went offline for a bit. Now today I’ve got two devices (GE z-wave plus outlet and smartthings motion sensor) dropping in and out. Looking at the IDE they actually seem to be coming back, but then dropping out again. Sounds like I need to reset them, and turn off device health, to get things going again. Is this correct? Frankly if this continues I will probably punt on Smartthings altogether - this is supposed to make my life easier not more complicated!

I have been using SmartThings for several weeks now. The only devices I have at the moment are several smart bulbs (all the same brand). They have been working flawlessly, now some are showing as unavailable even though I can still control them. I’ve reset the hub, tried turning things on/off, running routines, crashing the iOS app, etc. Nothing works. I am not going to re-pair the bulbs yet, because I hope this will remedy itself. Really annoying when everything is working fine and then you receive error messages for no reason.

This fixes a lot of z-wave problems.

1 Like

Now both devices are back. Of course no hint as to what might have happened to mark them offline in the first place. However, the outlet did seem to be genuinely having problems - not only could I not get to it thru SmartThings, but I couldn’t get to it thru Alexa either. Is device health actually causing the problem? Or was there some real issue, that has somehow magically fixed itself?

You were likely impacted by server issues which were resolved about an hour ago.