Devices in Rooms not showing if not assigned a Hub

bug

(Mike Nestor) #1

So it was pointed out to me by @MichaelS that he couldn’t assign devices to rooms unless the device had a Hubset also. Since the Hubis Optional I find this counter intuitive. There’s not even an error message!

I looked and all of my rooms are empty as none of them had a Hub. When I setup my system they were all showing so this is definitely a new issue. Going into the IDE I can see the devices assigned to the rooms but it won’t show on my phone until I set the Hub.

As emailing support has resulted in copy-paste answers after waiting days I’m bringing this up here. Perhaps our community advocates can get this to the right people.

Edit: Replace Location with Hub. Dangit!


(I got a hair cut from Alexa) #2

I had locations all set on mine… the ones with no hub disappeared for me. After I set the hub they showed up again. Maybe both are required now. :wink:


(Mike Nestor) #3

Yes, I used the wrong word! Oops! Edited post… Don’t flame @N8XD! :slight_smile:


(Micheal ) #4

Let’s all ensure we open tickets on this…this is a big deal for service manager apps that don’t assign hubs by default.


(Mike Nestor) #5

Is it possible to assign a hub? I’d like to have my app do that if there’s only 1 hub.


(Micheal ) #6

No idea…I am looking it up right now…

Edit…I will need to figure out a way to utilize it, but here is the code from the documentation.

http://docs.smartthings.com/en/latest/ref-docs/hub-ref.html?highlight=hub


(Micheal ) #7

I sent you a pull request. In thinking through this it isn’t too much code. The ‘assumption’ is that when you add a switch/trigger it will be in the hub you are currently working on, which SHOULD be [0]. Therefore, you simply get the hubID and give that parameter instead of null.

I no longer have multiple hubs in my accounts, so I can’t test this completely. However, did learn something today…there is a virtual hub defined in each account :slightly_smiling: