Device Types / Monoprice Motion Sensors

^^^^ THIS! ^^^^^^^^^^^^^^^^^^^^

20 chars. lkzsjdfhgkauirgouisrkgjh

@sgnihttrams Looking through the reviews on Monoprice, there’s another guy that mentions he’s got one that won’t respond to motion for 1 minute. They recommend he unpair+pair it, and then offered a warranty replacement for him if that didn’t work. Knowing that a) it’s not everyone and b) that problem is device-local, I would opt for a replacement after exclude+include and see what you get. There’s no way to link directly to a review on their site, so here it is:

Pros: Easy to setup with the Wink Hub. Looks good. Easy to install. Easy to open.

Cons: Seems to rarely be able to actually detect motion, especially when motion occurs at a very close distance. I even tried to waive my hand in front a few times without success. With the wink hub, a “no motion” signal is not registered, only a motion signal.

I purchased two of these and tried one. It connects well, but doesn’t seem to work very well with the Wink hub. I was hoping to use it to detect motion in our basement stairs and automatically turn on and off the light. This isn’t working at all.

by Monoprice Administrator
Hi Bass,

Thank you for your review and truly sorry to hear about your experience with PID 10796. Have you tried unpairing and re-pairing the device to see if anything changes? To unpair the sensor, you would need to set the Z-Wave controller into “exclusion” mode and follow its instructions for removing a device. Then with the sensor within 1 meter of the controller, press and hold the program switch for about 1 second to exclude the sensor from the network.

To re-pair the sensor, you would set the Z-Wave controller into “inclusion” mode and follow its instructions for including a device. Again with the sensor within 1 meter of the controller, press and hold the program switch for about 1 second. The LED will stop flashing and glow steadily when pairing is complete.

Should the issue continue, I can assist you in setting up an RMA for a replacement to see if that will work better for you. We do offer a 30 day return policy as well as a one year warranty on this item. Obtaining a replacement would be of no additional cost to you. Please let me know if anything changes or if you would like to continue with a replacement. Hope this helps!

Gisselle B.
Tech Support

1 Like

Thank you for looking into this John. I do have a couple of Ecolink motion sensors and they acted exactly the same as the Monoprice now. Possibly caused by me moving from hub v1 to hub v2 and using the ST genetic device type. Tried a couple other device types without success.

1 Like

Hmm I’ve tried a bunch of device handlers and didn’t really find any of them worked for me reliable so I decided to write my own.

However in total honesty I do charge for some of my apps (some are available openly for everyone on this forum), this however is one of them, so if you have access to my server you can check out this device type. :smile:

Thanks for the work put into this device by the community!

I went ahead and added the custom device to my API. I then changed my existing Aeon device (Monoprice sensor) to the new device type from the top of this thread.

While it is reporting temperature and motion detection correctly (still a bit laggy, no jumper was inside, should there be?)…I also don’t get any battery status at all (just dashes) from my V2 ST hub.

I did go ahead and open the sensor for a few seconds, then close it again, with the battery intact, to see if this would fix anything. No luck.

Did I do something wrong or are there other avenues I might be able to take to get battery working?

Again, thank you.

Try leaving the battery out for 15 minutes.
I’ve seen comments on here from others that the longer time period will reset the battery and allow it to report.

I just got one of these, a second is on the way. I wanted them to replace two of my hall ST motion sensors, hoping the Pet settings might make things less…on…all the time.

They are the GoControl version that comes with two open/close sensors. I’ve used this DHT and set the timeout to 1 minutes, which seems crazy long after using the ST and Iris ones. Then I see the test jumpers set it to 10 seconds. But it doesn’t It’s still a minute delay. On top of that it’s SLOW to respond, like 4 seconds.

Is this typical? I can use these in the kids rooms as a basic “they aren’t there so shut their crap off” was just hoping they’d be usable for pet avoidance more so.

Battery and temp are working great right off the bat, so that’s nice! :wink:


This is the exact same behavior I found with them. Personally, I can’t stand them.


Thanks for the confirmation. experiment=failure :slight_smile:

I’ll be putting them in the kids rooms then as “Shut off stuff because they can’t” triggers.

Sorry if this is a newbie question, but after pasting in the code at my logged-in Developer console at New SmartApp code, I’m getting this error:

No signature of method: script1478579845094637088962.metadata() is applicable for argument types: (script1478579845094637088962$_run_closure2) values: [script1478579845094637088962$_run_closure2@274f7280] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

I’d love to get this working – anyone know what happened?

Paste the code as a new DTH, not smart app.

Make sure to create a device type/handler, not a SmartApp. :wink:

Thank you so very much, that did it. And because I had already configured the sensor, simply opening the enclosure to de-activate the tamper switch, then closing back up made the new value register (down to 1 minute delay).

Ok what am I doing wrong? I pasted the code above into a new Device Handler and published it. Then I went to My Devices on the api, added a new device. On the Smartthings app, the device shows up, but it’s not showing any readings. I even tried to leave the cover off of the motion sensor. Am I missing a step?

You don’t need to add a new device via the IDE, just edit your existing device and change the “Type” to the new DH you just created and published for yourself.

I’m a little confused… I looked at the code and saw “polling”, and I thought this gave the ability to change how frequently the device reported temperature. But when I install the DH all I see are three items that are adjustable (delay before reporting inactivity, temperature offset, and degrees in F or C). Am I missing something?