Device Offline - Internet disconnected

Newbee. I set up my ST hub last evening. Connected four Meross wall plugs and one Meross smart light. Set up a routine through Smart Lighting for the plugs and it all worked great. Lost internet connection today. Now, devices are offline on my ST app. I have the little frown face next to the device on the home screen. Router says connected but no color icon in the tile on the home screen. Tried to repair z-wave network. No luck. Green light on the Hub

Reset the router by unplugging. Tried repairing the z-wave. Still can not use the ST app to control devices. I CAN still control the devices using the Meross app.

Any suggestions are greatly appreciated.


click on the menu (3 bars in the upper left of the screen)
select Settings (the cog)
choose Linked Services
open Meross and go through the setup and click done

1 Like

Zwave repair won’t make any difference unless you have zwave devices, which it sounds like you don’t. The meross devices are on Wi-Fi and connect cloud to cloud.

Try reconnecting to the Meross integration in the smartthings app.

  1. on the Main app screen, click on the three horizontal lines icon in the upper left

  2. A little menu will pop up. Click on the gear icon in the top right.

  3. Now click on “linked services.” You should see Meross listed there

  4. walk-through reauthorizing the Meross integration and see if that helps


I don’t know what to say. I have struggled for over an hour trying all sorts of stuff.

Now, the ST hub is still grayed out but it says it is connected. And… the faces are still frowns but they are in color now and operable. I think they were outlet icons before. The light and the living room group (outlets) are all represented by proper colored icons.

Is there anything else I should do to get rid of the frowns?


1 Like

yes, it is grayed out for everyone after an app update this past spring.

OK, this is where a screenshot would help. I am unsure what the frowns are that you are referring to

You may be referring to the outlet icon. grey ones are off, darker with more colorful outlets are on

1 Like

Working on it

Dragged and dropped. Hope that comes through.


icon to reference that the device is an outlet.

that one shows the device is turned on. when it is a light gray color, it is off

1 Like

Thank you. That worked like a charm to regain control of the devices. Now, it still appears I have frowns that work, kinda oxymoronic if I do say so.

1 Like

and just a side note: you may need to update your meross now and again. some users are experiencing dropoffs with their meross devices. going through the setup reconnects the devices. It has been reported that Meross is aware of the issue and working to fix it


How do I change the icon?

It’s a socket. This is what a real one looks like from the smartthings brand. Pretty close. :wink:

You can’t change it. Who knows, maybe they will add that feature back. It use to be an option that was available in the Classic app.

1 Like

@Calvinsouth that requires a custom groovy dth, which as @jkp knows, is dying

I changed one of my already groovy devices by using the “oig.d.thermostat or plug or so and so

you can’t use custom device handlers for cloud-to-cloud integrations

1 Like

I’m an idiot. A socket does look like a frown face, doesn’t it? Beuller…Beuller…

Thank you…All!


It’s more obvious if you have some other devices in the list. if all you have are sockets, they do look like frowning faces. :slightly_frowning_face:

1 Like

I had to think about it for a few seconds when you said the frown face

my first thought was the frown face that popped up on the classic app

1 Like

I did for konnected