[Device Handler] Moes 2 and 3 gang Zigbee wall switch ( cluster EF00)

@Andrew4
Unfortunately, dimmers are not supported by my DTH.

Hi @ygerlovin,

Thank you for the advice. Regarding the toggle option in automation, my virtual switches are working as expected after using two separate rules.

I have installed the virtual things edge driver, and I’ve created some virtual switches for controlling the devices via Google Home. Something that I couldn’t manage was to make a rule that “refreshes” the status of the virtual switch if I manually press the button. It’s frustrating to see the device as “On” in the Google Home app if the lamp is off.

As you mentioned, I tried creating another two rules for refreshing the status, but somehow it is triggering the other first two rules for the virtual switches.

About the possibility of managing the backlight in routines, unfortunately, it’s not working. If I change the backlight mode from the multi-gang switch page, it works as expected. But when trying to create a rule, when I hit the save button, I get the following error: “There was a connection problem. Try it again later”. Please check the screenshot of the routine.

Hi @iwry

I’m pretty sure I tested it during development, but I will retest it again. Could be an issue with recent hub updates. What fw version do you have installed on your hub?

I would suggest first to test the backlight automation with virtual switch and see how it goes. I will also try to test it on my side

Regards

Hi @iwry,

Some updates.
I have 42.00007 installed on my hub.
I have 2 gangs Tuya module (not Moes), which is very similar to Moes switch.
I created a virtual switch “vSwitch Gang1” to control switch1 on Tuya module.
Then I created 4 routines:
Tuya switch1, vGang1 On - if switch1 on Tuya is On - turn vGang1 on
Tuya switch1, vGang1 Off - if switch1 on Tuya is Off - turn vGang1 off
vGang1, Tuya switch1 On - if vGang1 is on - turn on switch1 on Tuya
vGang1, Tuya switch1 Off - if vGang1 is on - turn on switch1 off Tuya

Tuya switch1, vGang1 On looks like this.


The IF statement is for switch1 (gang1).

4 routines for a single gang seems to be working fine, even though with a slight delay. One thing to mention, I always wait for the previous operation to complete, before sending a new command.
Could you please check that you are creating routines the same?

Thanks

1 Like

@ygerlovin

Thank you for sharing your setup. I was probably doing something wrong unconsciously because I did recreate the 4 rules and it is working now.

About the hub, I also have the version 42.00007 installed on my hub.

I tried using a virtual routine but I’m getting the same error. Please check the screenshot below.

Hi @iwry,

Thank you for testing.

Cool, I’m glad it works now.

I don’t have a touch panel connected right now, but I was able to reproduce the error with another my custom capability (power on state).
I probably doing something wrong when defining my capabilities.
I will keep you updated

1 Like

Another question, will the edge driver be compatible with the 3 gangs and 4 gangs switches?

I can test for the 3 gangs if needed. (My 4 gangs switch burned out today :sleepy:)

Another comment, not really sure if it is possible, it would be great if we could rename Switch1 and Switch2 on the main page.

Moes 3 gangs should be working, even though I never tested 3 gangs modules.

I think a change request for this was opened a couple of months ago. Not sure whether ST team is planning to implement this

1 Like

Hi @ygerlovin I have a few updates.

I’m getting an “Open” and “Closed” status on the virtual devices. This impacts on the security system of smartthings for example.

Also in Google Home I get the status open and closed instead of on and off. And when I hit button an error occurs. (With voice command it is working)

About the moes 3 gangs I could add the device and it was recognized as 3 gangs but buttons were not working. And now the device got disconnected. I will try again tomorrow and I’ll collect logs if it fails.

@iwry

This is the current behaviour of virtual switch. Virtual switch was designed to serve as routine trigger in Alexa ( in addition to other things) and Alexa does not allow this for regular switches. Hence a hiden contact sensor capability was added to vSwitch.
There is a feature request in virtual switch driver thread tor this

And there is ongoing discussion how to solve this

@iwry

To investigate the error I will need a log from both drivers