[Depricated] Lock Code Manager


(Trippy99) #753

I get this on my Kwikset 912, even after overnight wait. The codes work though. How did you know the code conflict caused this? I had a first code entered manually, too, before I tried to remote program the lock!


(Erik Thayer) #754

Trial and error. Experimentation. Science. Beer.

This isn’t normal. There’s either a weak connection with the hub, the lock isn’t securely paired, or the custom device type isn’t assigned to the lock. I’d re-check and make sure the custom device type is assigned to the lock first and work back to testing out the connection. If you unlock the door and there’s a message in the IDE straight away, then you know your connection is good.


#755

@ethayer you are a champion. Just installed the custom device handler and app. Love it already on my KwikSet 916s. Super easy, and super great. Thanks!


(Dj Anu) #756

Hi I have a shlage BE469 that I am trying to set the codes on. For some reason the first code I entered was set properly but afterwards I am unable to add a code in the second slot. The command is sent to the lock but I don’t see the code being entered on the lock slot after refresh…Any idea what might be happening ?

2016-01-09 6:12:19.307 PM PST
4 days ago APP_COMMAND updateCodes
2016-01-09 6:12:17.781 PM PST
4 days ago APP_COMMAND poll
2016-01-09 6:10:17.232 PM PST
4 days ago APP_COMMAND updateCodes
2016-01-09 6:10:16.604 PM PST
4 days ago APP_COMMAND poll
2016-01-09 6:08:16.376 PM PST
4 days ago APP_COMMAND updateCodes
2016-01-09 6:08:13.599 PM PST
4 days ago APP_COMMAND poll
2016-01-09 6:06:13.891 PM PST
4 days ago APP_COMMAND updateCodes
2016-01-09 6:06:11.567 PM PST
4 days ago APP_COMMAND poll
2016-01-09 6:04:11.821 PM PST
4 days ago APP_COMMAND updateCodes
2016-01-09 6:04:09.553 PM PST
4 days ago APP_COMMAND poll
2016-01-09 6:03:34.163 PM PST
4 days ago DEVICE codeReport 1 Front Door Lock code 1 is set
2016-01-09 6:02:08.033 PM PST
4 days ago APP_COMMAND updateCodes
2016-01-09 6:01:57.602 PM PST
4 days ago APP_COMMAND updateCodes


(Erik Thayer) #757

HrmmmMMMmm…

Are you using the custom device type?

Has it been doing this for 4 days!?! Wow.

Id try out a different code in slot 2 just to check if there’s something up with that code being set in another slot with a conflict or something whacko. Just for funzies, enter in some random and unique code and see if that works on slot 2… then if that works, you can then start troubleshooting from there.


(Michael K) #758

i honestly dont know for the kwikset locks. BUT i think the gist is since they are battery devices, for the schlages to function properly- pair- transmit- etc etc- they must “beam” which is a superset of zwave.

The locks can ‘beam’ directly to the hub but if it’s more than a few feet a way who knows since the locks are battery powered. One solution that owrks wonders is to install an AC device that supports beaming close to the lock to act as a repeater. Newer GE switches/dimmers/walwarts all do it (I’m sure there must be plenty of others). So an easy solution to greatly increase reliability is to install a gr zwave light switch at you front door light switch since it’s likely just a few feet away from the lock.

if i understand correctly the only device that needs the beaming ability is hte one directly talking to the lock. So you could put your hub 500 feet away connected with 20 old school devices in a line towards the lock and as long as you have the last one next to the lock a ‘beamer’ then it will do whatever translating needs to occur so the hub neednt bee right next door.


(Michael K) #759

search my posts above-

read the stuff around here

there’s something wonky with schlage locks not reacting well to the code needed for looks that reuse buttons that fubars the schlages under certain conditions. @ethayer gave me the fix - it’s like a one line change you need to disable that bit and then for me at least and my schlage it works perfect.


(Dj Anu) #760

Tried to add another code on a different slot. Still the same thing ? Code was not updated at all. Any idea ? I’ll probably try resetting the lock if nothing else works.


(Different Computers. So happy with Indigo.) #761

You mention you have the Lowes Iris Keypad working.

I’ve installed the device type, gotten it connected, also the 3400-X Keypad Manager smartApp, but the actual way this is supposed to be used escapes me.

  • The app appears to allow for only one code.
  • There’s no control over sounds.
  • There’s nothing configurable about the ON, OFF, PARTIAL, PANIC or * button.

But most confusingly, there are apparently four different routines that can be triggered by the keypad, yet only one code that can be input.

Could you or someone explain the thought behind the app?


(Ben Lebson) #762

It was a proof of concept app, not an end-all be-all solution. For a more robust app check out @ethayer’s Lock Code Manager that I’ve modified to work with keypads. This solution allows you to share codes between locks and keypads along with adding scheduling, one time use codes and all other features of the normal Lock Code Manager SmartApp.

And as always, if there is a gap in support that you feel needs filling, you can always create your own solution and share it with the masses.


#763

Great smart app. Having an issue with the schedule. Whenever I set a schedule I get the following error:
error java.lang.NullPointerException @ line 937
80240f5d-d709-4a36-b871-83f34234e43d 9:00:10 AM EST: debug scheduling access denial routine to run at 2016-01-16T20:58:00.000-0500
80240f5d-d709-4a36-b871-83f34234e43d 9:00:10 AM EST: debug scheduling access routine to run at 2016-01-16T08:58:00.000-0500


(James) #764

Hi Guys,
Newer to this type of stuff but I click create new smart App i delete preference and below after I make standard smart app. I copy and paste code and I get this error when I save groovy.lang.MissingMethodException: No signature of method: script14529704315911532890566.metadata() is applicable for argument types: (script14529704315911532890566$_run_closure1) values: [script14529704315911532890566$_run_closure1@72fe2f80]
Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure) @ line 16


(James) #765

Never mind was copying from wrong groove file


#766

I still have the problem where I can’t edit a user once I add them. It tries to load the individual user details but then gives an “unexpected error.” Every time I need to edit a user, I just delete the app and reinstall. I am using three Schlage locks with 8-digit codes and 3 users.


(Scott Alexander) #767

Scheduler issues bit me again this morning and didn’t enable code for a service company. Luckily I noticed and didn’t leave them standing out in the cold. @ethayer have you ever thought about having a temp sensor trigger the logic that then evaluates if its a certain time and if so enable/disable a code? Its a janky hack since it makes your evaluation logic fire every temp submission rather than only at the intended time. But I wonder if the increased processing would give SmartThings some impetus to fix the scheduler :smile:


(Erik Thayer) #768

Argh, I also had trouble with the scheduler this morning… though not as bad… just my outdoor lights didn’t turn off, no biggie… still, wish there was a better re-initializing process after scheduled maintenance. Seems nuts that there’s not.

Also wish there was a concept of multiple ‘Modes’ simultaneously. ‘Cold’ mode could be active while ‘Home’ mode, or ‘Away’ mode… while “Erik” could be home and the house could behave differently if it was just my Wife… makes routine automation way too complex to have a singular mode system IMO…

My Modes:

  • Away Day
  • Away Night
  • Home Day
  • Home Night
  • Emergency

All these routines:

  • Wife Arrived during Day
  • Wife Arrived At Night
  • I Arrived during Day
  • I Arrived at night
  • Good Morning! (sunrise with people home)
  • Good Night! (sunset with people home)
  • Goodbye at night (Everyone left at night)
  • Goodbye during day (Everyone left during the day)
  • Sunrise, While No one’s home
  • Sunset, While No one’s home

These modes are all used to automate what the locks and lights are doing in my home, as well as the garage door and warnings. Emergency mode kicks the other routines offline to account for possible emergency responders while a fire alarm is triggered.

Fun stuff if it worked right. Anyways… I got off-topic… locks.


(Erik Thayer) #769

I’m sorry that I missed your post. This is really strange.

What platform are you using? Windows Phone? iOS? Android?


#770

I am using Android.

20 characters…


(Dario Favoino) #771

Hi Erik

I’ve installed a Yale Keyless Connected Digital Lock, which is compatible with most UK latches (I’m based in London).

I have installed your User Lock Manager App and I think it’s great!

I have encountered the following issues though:

  • I’m not able to revoke access to any user I create
  • The only way to effectively disable a code is via the “burn after” option
  • I tried to use the schedule options both for times and days but none of them seems to work for me

I’d be very grateful if you could help me out with this. I’m using iOS.

Thank you very much in advance for your help!


(Dale C) #772

I just installed a Schlage deadbolt BE469 and wanted to try out your Lock Code Manager app. I copy the Raw code over into my IDE New SmartApp using the From Code tab. Unfortunately I am getting an error after I click the Create button. See below

No signature of method: script1453701495426562582541.metadata() is applicable for argument types: (script1453701495426562582541$_run_closure1) values: [script1453701495426562582541$_run_closure1@6f6db5e0] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

Not sure what I am doing wrong or what steps I need to do to correct it. Any help would be appreciated.