[Depricated] Lock Code Manager

Try to re-pair your lock with hub within a foot of the lock. That worked for me when i had this problem.

I just submitted a PR to add a per user notification when code is used. I don’t want to be notified when i use my code.

1 Like

I tried everything BUT that! Was getting ready to reset my locks, but I’ll give your suggestion a try…before I reset my locks. Sorry, what is a “PR”?

Hi Erik, 4.0.1 fixed the issue.
Thanks again for your prompt efforts

A Pull Request on github.com. Its how you submit code changes to a repository.

Got it. Thank you, still learning…

HA! One of my locks is NOW reporting the battery level! (and I didn’t do anything to it, but changed the device type yesterday)

1 Like

Man sounds like its about time I update and re-donate. Sounds like we’re getting some great enhancements to an already really nice app.

Finally, after a week, removing the battery, waiting, praying, cussing, cursing… we have a battery status of 100%. Unfortunately, I’m not sure which of the above methods worked…

Sounds like…it may not be “magic” but a back-end issue, if we all are starting to see the battery levels showing up mysteriously TODAY!

1 Like

Wow! That’s good to hear that they recommend it. I guess the pressure is on to keep improving!

It is pretty suspicious that everyone is getting battery updates today. Pretty suspicious indeed.

I thought you may like to know that. Anyway, I’m pretty sure now that is a back end issue, as my other lock is showing the battery level and I didn’t do anything to it in the past 7 days…

Ooh, I will try this tomorrow. Crossing my fingers.
Side note: lock stopped responding tonight so hopefully that will be fixed as well. At first I could get it to lock or unlock about half the time, but I’ve got a 0% response rate now.

That’s exactly what happens if the lock is to far away when you pair it. During the paring process not all transmission are received so some functions will not work.

I wish ST would/could detect a bad zwave paring and tell you to try again. But this may be a limitation of zwave and out of STs control.

1 Like

Thanks. It was actually good for a week and then fell to pieces rapidly last night. Hopefully reconnecting will do the trick

Re-paired the lock - fixed the spotty lock/unlock behaviour but battery status is still missing. I’ll give it some time again.

Does anyone here have a v2 hub and Android app? I couldn’t get an older version to run on my new hub, so I came here to get the latest. It ran one time. I set up 3 users, and one that would burn. (First time I’ve seen this option ever work, as the older version always crashed when I set that, and I had to completely uninstall the smartapp.) Pretty cool stuff.

Anyhow, when I attempt to install the latest ULM on the v2 hub via Android app, it gives the “unauthorized” error, (vague, I know,) any time I try to enter the specific user settings, any of them.

Switch location to my v1 hub, install same exact code, same exact lock type, same exact device-type, (I’ve tried yours and the stock one,) and it works perfectly fine. There’s something specific about the new hub, and it’s trying to query null variables of some kind.

Right now, Live Logging isn’t working very well. I can’t isolate the view to only show this app, which is very frustrating. I hope that’s fixed soon.

Seems to have an issue with this section of the code:

>  def allCodesDone() {
>   def i = 0
>   def codeComplete = true
>   locks.each { lock->
>     i++
>     if (state."lock${i}".error_loop == true) { #### THIS LINE FLAGS AN ERROR ####
>       codeComplete = false
>     }
>   }
>   return codeComplete
> }

I was able to get something out of the live logging:

645e151e-274f-4f24-80e8-df257bb98c73 5:47:35 PM: trace getPhrases(), state.welcomeIssue = null

Earlier, I just so happened to stumble on one that mentioned line 1245 and a null value. Not sure if all these errors are connected, but the results are the same.

FWIW, I just combed through and commented out anything relating to hello home phrases or scheduling, and now the crash is gone.

My Modes and Phrases have semicolons in them. I bet somehow the code is not expecting that, and that text is not sanitized.

If that’s the case: http://xkcd.com/327/


1 Like

I am running on v2 hub. Should I uogradecto latest version … is the source changed in github

I just got my V2 hub on Saturday. I haven’t had time to set it up yet. I’m hoping later in the week or this weekend I can get cracking on that.

I can debug after that…


Reading some recent posts… New user and was about to install on my V2 hub, is the consensus to wait at the moment?