SmartThings Community

[Depricated] Lock Code Manager


(Jay Morris) #1449

I’m fairly new to ST and have only used it in it’s most basic form. I’ve just added a Schlage Connect and was looking for a better way to manage lock codes and ended up here. I have a couple questions I hope someone can help answer.

  1. Will this work with the Schlage Connect (it looks like so based on some of the posts)?
  2. My main goal is to be able to add and remove codes for people and the days/times they can enter, get notifications when some are entered. Both of these are listed in the features, I just want to make sure these are easy to manage/enable.
  3. Are the original post instructions easy to follow for a ST beginner, are there any predictable surprises I can avoid with a little insight?

Just trying to make sure this is the right direction for me to go before heading down another smart home rabbit hole :slight_smile:

Thanks,
j


(ed) #1450

Hi.
Love the smart things hub and devices.
New user, and trying to update lock manager to the latest beta version to get the schedule function to allow scheduling of individual codes for a specific time frame. Bought a house that was a rental, that had this function using the nexia app, and converted to smart things. I installed the lock manager, but need to schedule codes for times.
I’m confused on how to update the prod code to the beta version.
I see the link zwave lock groovy updated 2 days ago. Where do I put this code?
Also, when I did the original config, I never had the reporting function available as a type, and only had z wave lock with codes.

Can someone put a step by step instruction to update?

Thanks

Ed


(Steve Robertson) #1451

Did you ever get Lock code manager working on your Kwikset 916? I have the same issue


#1452

Just noticed the following error showing up in the log file. Not sure what it means, i have not noticed any issues otherwise

a98a5636-ab04-4cb6-b054-0986dfc21d4c 8:01:46 PM: error java.lang.NullPointerException: Cannot set property ‘codes’ on null object @ line 251
a98a5636-ab04-4cb6-b054-0986dfc21d4c 8:01:45 PM: debug checking children for errors


(Erik Thayer) #1453

This is a [Lock Manager] error.

If possible, try to keep discussion about that app inside of that apps thread.

It’s possible you just need to go to the parent app’s home screen and then click ‘done.’


(Erik Thayer) #1454

I don’t have the 916 but I don’t think it would behave differently than the other locks.

Use the DTH and smart apps and you should be good to go. I don’t have a lot of free time right now to write a good tutorial on how to install these, but there are some around the community. Also, SmartThings support will help you get things installed if you contact them.

I am advising people starting to use the beta application instead of this one. It is more user friendly for people who are trying to find their way. This app should only be used for support of people who are still using the old app.



#1455

Has anyone else found that after installing this app (maybe the device handler) that I can’t lock the door with just the schlage button anymore? It seems I have to type in one of the codes or wait for the auto lock. Also, anyone else know if there’s a feature to change the autolock countdown?


(Dana ) #1456

This…


(Daniel) #1457

If you are using garyd9’s DTH, “Lock and Leave” is on the phone UI. You can enable or disable it from there. I think this is disabled by default when the DTH is installed.


#1458

I have a Schlage TouchScreen lock that I used with Wink prior to coming back to smart things. I have the device handler setup and the smart app and it works but there was a code already programmed in on the lock and the smartapp doesn’t register this. When I use the code to unlock the door, the smartapp history shows user 4 came in. How do I get the lock and smartapp to be in sync so it knows what codes are setup/available?

Thanks!


(Devin Cenatiempo) #1459

Each time I use the app, it is as if it is starting from scratch (its asking me to select locks). I would assume it would save my changes so I would be able to see all the users I just set up on subsequent app uses/logins.

Is this normal? or is this a bug? or did I do something wrong?

I have an iPhone SE, ST Hub2, Schlage Connect

Thanks you!


(Erik Thayer) #1460

This isn’t normal. Unfortunately I don’t have any advice for you other than to contact customer support

The app doesn’t use any logic to do “smart things” from users already programmed into the lock. Logically this doesn’t work out. You’ll have to program in those users into the app in order for the app to perform actions on them.

Use the new app. I am no longer offering support for this one.


(Gregory Watkins) #1461

Thank you I was able to get everything working properly.


(Matthew Desario) #1462

Erik:
Are you available for paid consulting? Please let me know as I’m not having success following the various instructions in this thread. I’m only looking to easily and quickly change the codes on 5 Kwiset 910/912/914 and 4 Shlage Z-Wave Locks via the SmartThings App for my house and my vacation home. I’ve been lurking for about 18 months, but run into an issue, get distracted, the version changes or (as happened a year ago with yours) a new developed product emerges. I’m happy to pay to get someone to baby-step me through how. I’ve tried reading the thread and it’s just beyond me…


(Robert) #1463

I’m on v 4.1.5 of the Lock Code Manager, have a Kwickset 910 Z-Wave lock, and the Z-Wave Lock Reporting Device Handler. I’ve setup “I’m Back” as the Global Hello Home Phrase and the User Hello Home Phrase. Also under Keypad Info I’ve set Disarm routine to be I’m Back. The I’m Back routine does not run when I enter my code to unlock the door. any idea what the issue might be? My main goal is to DISARM the security system when the door is unlocked. What is the best way to achieve this?
Thank you


(mike ricchino) #1464

I would try to use only the User hello phrase. I have 1 set up with my 910 and it has worked 100%.

for Global phrase i have had better luck with a CORE trigger instead.


(Kavy2) #1465

That was happening to me too. Each time I went to the app, I was getting there from the Marketplace. That was my error. After the initial set up, you go to Automation… Smart apps… to get to your app.


#1466

Hi this might have been answered before if so my apologies. Have anyone used the Yale YRD210 Zigbee here?


#1467

I use a Yale YRD240 ZigBee lock. In order to get this to work you will need to use my DTH found here.

Also I would recommend using the new Lock Manager App here.


#1468

Perfect thank you very much for your quick response I try this soon as I receive the door lock :slight_smile: