[Depricated] Lock Code Manager

Make sure you’re checking if the evt.value is “unlocked”

You should be able to access at least the following from the lock:

$evt.name, $evt.value, $evt.displayName, $evt.data

So if you wanted to see if the door got locked you’d do ( psuedo code because i’m tired lol )

if (evt.name == "lock") { 
    //Check if the value is unlocked
    if( evt.value == "unlocked"){
    if ( evt.data == "" ) {
       //got nothing from the lock so you can't display or notify any data
      //grab data.usedCode so you know which username to get
      Integer x = data.usedCode
      //retrieve the user name that for code slot stored in X...look through current smartapp code and you'll see an example to retreive

      //log.debug The username that unlocked the door

I can access evt.data in the unlocked state, no problem. but I want to
access it in the locked state. the present code doesn’t try to read
evt.data in the locked state and it appears the variable isn’t populated at
that time.

If what I posted earlier doesn’t work then your lock is probably not compatible. The pseudo code should look for the unlocked action. Meaning when a door is locked and gets unlocked. Not the other way around.

I have Kwikset 916’s and they are compatible.

You could also check out Rboy’s Lock Manager. It’s a small fee for access to his smart apps but they work pretty well. The lock code manager is worth the price of admission

Get Outlook for iOShttps://aka.ms/o0ukef

@jrivera I’m probably not communicating the issue well, sorry about that.
Let me try a different way. I agree with your statement: “The pseudo code
should look for the unlocked action. Meaning when a door is locked and gets
unlocked. Not the other way around.” I want to read evt.data “the other
way around” e.g. a person leaves the house and locks the door with a user
code – I want to know who locked the door, but if I check if evt.data
exists during that action, it does not.

Ah gotcha. I may have misunderstood as well. I’m out of town but if you message me on Friday I’ll look at our custom smart app to see if we have that feature or any code that may help you get to what you need.

Get Outlook for iOShttps://aka.ms/o0ukef

New zigbee lock code DTH


It should now be available under ‘Automations’, ‘SmartApps’ and not Marketplace.

Hi. I just put in two 914’s and it definitely has a one touch lock feature. Just press the lock button on the outside. I was here actually trying to see if there is a way to disable the feature. That would make it the perfect alarm arm/disarm.

interesting i didn’t know that. But I’ve been locking it with the combo so
I don’t think it matters for my question.

Not sure if it will help but on the schlage locks, you can disable lock & leave to turn that feature off.

When manually locking or unlocking, in the short time between states, I get a jammed message alert on the app. The lock shows unknown state in this short time. It then goes to the correct state of unlocked or locked. Perhaps a small timer/delay for the jammed message would resolve this? Please help, thanks.

I’m not sure if i’ve missed something but is there a way to see when users have used the lock, some kind of log perhaps?

There is a log, but it shows every event I.e. Every status update

Under user settings you can see how many times a code was used, and you can set notifications when codes are used

Any luck on this through trial and error? I am having the same issue and trying to determine if its an issue with my device type or something else. thanks

Today is the first time I’ve tested our lock with someone feeding our pets. It disarmed the system but when they left it did not arm the system. Am I missing something In the app to ensure that our system is armed when the door is locked? We have the kiwiset 916 and it’s been locking and unlocking wonderfully for us as we come and go with our presence but I can’t figure out how to have the system arm when the door is locked on the touchpad.

Thanks!strong text

Found it out, you can just use the default setting. My lock is on a detached garage, so sending the user codes over that distance was the issue. Dropped a repeater in half way and it worked well. Then just removed the repeated and all is good. My ZWAVE garage door monitor should be here Monday, which will act like a repeater and should boost the entire area.

Yo, just an update.

##Lock Code Manager Update##
Bad news: There won’t be one. I am no longer going to be providing code updates or support for this app. The code is old and clunky… And I don’t really have the time to provide support AND code. It would be awesome if you, as the community would support new users on this app has you have been. At least until…

Good news: I’m working on re-factoring it to work even better. I have a new app that’s stable for setting codes, but it’s lacking most of the features this app has. Once I get scheduling feature in the new app, I’ll release a beta. It will have fewer features than this app off the bat, but should catch up quickly, and will surpass ‘Lock Code Manager.’

##General Update:##

I initially stopped working on Lock Code Manager because ST had hinted at their own integrated system to be released ‘within weeks.’ That was almost two years ago and there’s still no integrated solution.

Since I stopped providing updates, my life has sucked. Lots of family loss and stress, so I just haven’t had time to work on a side project. I still don’t know if I have enough time, but I’m working through it.

I’m going to shoot for a beta next weekend. No promises. Most people will PROBABLY want to stay on this app for awhile, but for those who just want to set codes and schedule users, the new app will work.


Thanx for the updated info, Erik … and hang in there!

I’ll be trying your new app …

1 Like

The new app thread: [BETA!!!]

1 Like

I am finding that none of my lock codes are burning or erasing, even if I get rid of them in the app.

I have a cleaning lady who I want to supply a code for only once, and then have it burn… But it will not go away now… Even if I delete the code all together it is still working…

Am I missing something here?

Is anyone having same issues?

Is this app even supported by anyone anymore?