[DEPRECIATED] Jasco/GE Motion Dimmer Switch 26933

Your situation may be very helpful in figuring out why it isn’t working for some, but is for others. Can you also check the Raw Description for your 2 devices as well as what they initially paired as Name? These can be found in the IDE on the device description page.

Looks like it was a generic zwave multichannel device or similar naming:

So this is what i found, I played with the settings, and that didn’t seem to change anything. So I clicked on the Replace button at the bottom of the config screen. It ran for a while, i see that it timed out in the logs. But it removed the device from the network and i had to rejoin it. Everything started working fine again. So my suggestion to anyone playing around with the device handlers and notice things not responding is to remove the device and add it again. Especially if you don’t see any errors in the logs.

Hope that helps.

Awesome, the first time I paired the dimmer showed as a “Fibaro Dimmer”. After removing and repairing it shows up as a “Z-Wave Device Multichannel” device. Best part, after changing the device type to @mlebaugh’s latest “GE Motion Dimmer Switch 26933” I am getting motion events.

Off to work but I will continue testing on my other 26933 dimmers later tonight. @amb25s, thank you for the great suggestion to repair.

The newest version for the dimmer is in the initial post.

I added the zwave fingerprint and I also able to add button push events for the device thanks to the work for the regular GE plus switches that @nuttytree has done over here. I plan to try to merge in the association groups as in the other device handler soon.

Edited: motion reports only work when NOT associated with group 2 and 3

Btw, I think whether or not you get motion events has to do with the associations on the device – not sure if it’s related to secure pairing or not.

Using the Z-wave Tweaker DTH, when I print an association report after doing an association scan, I see this on one of my working motion switches:

Association Group #0: [id:0, maxNodesSupported:0, nodes:[]]
Association Group #1: [id:1, maxNodesSupported:5, multiChannel:true, name:Lifeline, nodes:[01]]
Association Group #2: [id:2, maxNodesSupported:5, multiChannel:true, name:Basic set, nodes:[]]
Association Group #3: [id:3, maxNodesSupported:5, multiChannel:true, name:Basic set, nodes:[]]

(notice that #2 and #3 are NOT associated with node 01, eg the hub)

And I see this on the non-motion reporting switch:

Association Group #0: [id:0, nodes:[]]
Association Group #1: [id:1, maxNodesSupported:5, multiChannel:true, name:Lifeline, nodes:[01]]
Association Group #2: [id:2, maxNodesSupported:5, multiChannel:true, name:Basic set, nodes:[01]]
Association Group #3: [id:3, maxNodesSupported:5, multiChannel:true, name:Basic set, nodes:[01]]

I believe you are correct. I noticed the same thing after looking at the dth for the other plus switches. I updated the version last night to associate with group 3, will also ensure they are in group 2 as well based on what you have here.

Strangely, I may have had the results backwards – that it only works when there is no association. Testing…

Ok – I was able to get motion reports working by removing association groups #2 and #3, and then power cycling the switch via the air-gap toggle on the front of the switch.

Here’s the code I used (this was run ad-hoc, not properly integrated in to the DTH):

// Make sure lifeline is associated - was missing on a dimmer:
sendHubCommand(new physicalgraph.device.HubAction(zwave.associationV1.associationSet(groupingIdentifier:1, nodeId:zwaveHubNodeId).format()))

// Make sure 2 and 3 are not associated:
sendHubCommand(new physicalgraph.device.HubAction(zwave.associationV1.associationRemove(groupingIdentifier:2, nodeId:zwaveHubNodeId).format()))
sendHubCommand(new physicalgraph.device.HubAction(zwave.associationV1.associationRemove(groupingIdentifier:3, nodeId:zwaveHubNodeId).format()))
1 Like

Nice work!

I don’t think that groups 2/3 are the issue though, I think group 1 seems to be the one that sends the motion. The other groups will be necessary for button pushes to be used as a trigger.

I just did some testing with what you provided. Here were the scenarios:

missing group 1: no Motion
group1: motion
group1&2: motion
group 1&2&3: motion

Awesome :slight_smile: I wonder if the association behavior is different between the dimmers and the switches. IIRC, the dimmer only worked upon adding group 1, and the switches were already associated with group 1 and only worked upon removal of 2 and 3.

That said, I could totally be wrong.

Thanks for writing this DTH!

1 Like

Interesting, I’ll check the switch as well. Once I get it sorted I’ll roll it into the DTH.

1 Like

Also, I noticed that when I press on/off in the app, the new dimmer state isn’t updated. I think for on & off the switch needs to poll again for status after the dimming operation is completed. Borrowing this from the Enhanced Dimmer Switch handler, it’s:

def on() {
    //zwave.basicV1.basicSet(value: 0xFF).format()
    delayBetween([zwave.basicV1.basicSet(value: 0xFF).format(), zwave.switchMultilevelV1.switchMultilevelGet().format()], 5000)
}

def off() {
	//zwave.basicV1.basicSet(value: 0x00).format()
    delayBetween ([zwave.basicV1.basicSet(value: 0x00).format(), zwave.switchMultilevelV1.switchMultilevelGet().format()], 5000)
}

Hi @mlebaugh. I just bought one of these switches and installed it today using the generic multi dimmer dth and then I saw this thread. I read through and saw you have been continually working on this and I wasn’t sure if the OP had the latest version of the DTH you are building or if there is a github repo I can sync from. I would be happy to test as well.

I haven’t done much work on this recently, but I just updated the OP with the most recent version I have. The last thing I did was correct the on/off as @funkzy pointed out and add the association feature from the regular ge zwave+ dimmer/switch as well.

Thanks. I will install it today and give it a try.

I saw this interesting use case of using this sensor as an independent motion sensor… wonder if that can be incorporated in the device handler : https://board.homeseer.com/showthread.php?t=187607

I’m not sure what you are referring to, the device handler does expose the motion sensor independent of the light.

There is no reason to have it as a separate device in smartthings. A device can have unlimited capabilities all in one device.

@mlebaugh I wanted to use the motion sensor on this light switch as an INDEPENDENT motion sensor and control other devices. Is that possible with the current device handler ? Thx in advance

@skhandu Yes.