[DEPRECIATED] Jasco/GE Motion Dimmer Switch 26933

The functionality of the ZEN24 is different than the one for the Motion Dimmer. We’ll be releasing a Zooz motion-activated switch (not a dimmer) later this spring, the model number is ZEN12 and it will have its own dedicated handler. Meanwhile, the ZEN24 has a handler created for it but since its only configuration option is to reverse up/down operation, it will probably not come useful to you. Is there anything in particular you’re looking to apply the handler for?

Sorry it took so long, had an issue I needed to take care of…

It’s:
zw:L type:1101 mfr:0063 prod:494D model:3034 ver:5.27 zwv:4.34 lib:03 cc:5E,72,5A,73,26,27,2B,2C,70,86,71,60,8E,85,59,7A,56 role:05 ff:8600 ui:8600 ep:[‘1101 5E,59,26’, ‘0701 5E,59,71’]

So it’s a v. 5.27

You now have me curious as to what I’m getting so I’m going to setup a test later. I can’t do it till this weekend though.

Modifying the default “on” brightness level depending on the time of day. If I tap “up” once on the ZEN24 in the middle of the night, it’d be nice to have it turn on at say 40% brightness, even if it was 100% brightness the last time it was used (before going to bed).

Looks like ours are identical.

Unfortunately, this can’t be accomplished with the current version of the switch. It will always go to the last brightness level when turned on manually. But we’ll keep it in mind for future releases!

Great, thanks. In the meantime, I’ve identified a workaround. When the goodnight routine executes, I proactively set the dim level to lower, so that when it is turned on in the middle of the night, it will already be at the desired dimming level.

2 Likes

Hello,

The description says

Occupancy only during certain hours, vacancy mode other times. (in a bedroom, occupancy during the day, vacancy or manual mode at night)

I would like to make the switch automatically change to manual mode at night… I can’t see an option for this in the settings. How can I use this feature?

Not sure if anyone can help me out with this…but I installed the 26933 last night, and confirmed correct operation prior to pairing it with the Hub v2. Once done, I added the Thing, and it was recognized as a Z-wave multi-channel device. I added it, and realized it only let me turn the light on or off, and adjust dimmer, just like any of my other GE dimmers. That’s when I went looking for the custom DTH, landing me here.

I added Mlebaugh’s code through the IDE, and confirmed that the handler exists in my Device Handlers…albeit green instead of blue, which I understand to be due to it not existing in any repositories…I think?

Anyway…I removed the device, and did the reset procedure (tap top button 10 times in 5 seconds), then attempted to add the switch again. For whatever reason, SmartThings will not recognize the switch at all now. It just times out no matter how many times I press the up button, or retry pairing. At this point, I figured I needed to manually exclude the device, so I went to the hub settings and put it in exclusion mode. When I press the top button on the switch, I immediately get the message that a device has been excluded…so I know the hub is seeing the event. At this point, I try to add the switch again, and still get no response while trying to pair.

I should also note: The status LED on the bottom of the 26933 does not seem to light up at all, whether I use the switch to turn the lights on or off. It’s the only GE zwave switch I have that doesn’t give me a blue status LED for some reason. Not sure if this is a setting, or if it’s an indicator of a defective switch.

Any idea why I would have this problem? Any help is greatly appreciated.

Never mind. I got it figured out. Had to power-cycle the Hub. Everything is working great. Love this DTH. Nice work Mlebaugh!

Hey all, sorry I’ve not replied in a while. Unfortunately I’ve moved on from smartthings. This means I’ve also got rid of my hub, so I won’t be able to continue any support for this DTH. However, the code is out there if someone wants to pick it up.

@mlebaugh, sorry to see you go. Great device handler! I’m not crazy about the feel of the physical switches on the device, but it sure is slick to have the integrated mains powered motion sensor. The supported customizations including occupancy/vacancy/manual and default level really make this nice for managing lighting automation behaviors throughout the day and night.

I made a small mod to allow managing the motion sensitivity programmatically via smartApps and can post if anyone is interested. No promises on timelines, but I may also be able to look at making further updates in @mlebaugh’s absence if there are any requested feature additions.

Hi @Darwin! I am very interested in your tweak, and would really appreciate you posting the update.

And thanks @mlebaugh for your work to date!

All,

I have been working with @Darwin and am taking ‘ownership’ of these DTHs. I have added the ability to programmically set the motion sensor, so that will be included in the release. I am also ensuring that I document everything in the wiki. I expect these to be done within the next few weeks. I agree…thanks to @mlebaugh for the great work on these.

2 Likes

Since I am re-writing some parts of the DTH, I wanted to get a sense from the community how they use them. One area I would like to change is the command structure. I assume some of you use WebCore for your automation with these commands. For example, you might issue the “Occupancy()” command to change the switch operations mode. What if I changed it to “occupancy()” (not capitalization). These interfaces are typically for other programmers to use in their code, but WebCore exposes them as well.

The lack of capitalization will help other programmers and myself when integrating the functionality directly into their apps (i.e Room Manager, Ask Alexa, etc).

Let me know if anyone is ‘married’ to the upper case version as I plan on changing it. If you upgrade your DTH you WILL need to probably change your WebCore apps, but that will be minor.

I do use WebCoRE to change the operations mode based on the mode of my house, but it will not be a big deal to change my one WebCoRE rule.

I am sure you will leave a note in the code to warn users to change their rules. :slight_smile:

Thanks for continuing to support this DH!!

1 Like

Good to know…I have some developers ready to support this DTH once I define the programming API. Lower case commands typically are ‘standard’ and are not usually exposed to the end user. However, with WebCoRE they are…but as you mentioned, this is easily changed and I will document the syntax change in the release notes.

I’m using mlebaugh’s device driver and webcore. I’m finding that when the switch is in Occupancy mode and gets triggered, it’s doing a button 1 press to turn on the light, and a button 2 press to turn off the light. see https://github.com/mlebaugh/smartthings/blob/master/devicetypes/mlebaugh/ge-motion-dimmer-switch-26933.src/ge-motion-dimmer-switch-26933.groovy (method at line 273). Does this sound correct? I’m trying to use webcore to turn off occupancy if button 1 is pressed and occupancy re-enabled if button 2 is pressed. With Occupancy mode triggering a button press, it messes things up:(. Any ideas?

In WebCoRE, have you tried to use the “switch” as a trigger with “physical interaction” and change the operations mode when the switch “changes to” on or off?

Just a suggestion, I have not tried it myself yet.

Thanks to the authors and supports of this device handler. Seems great. Quick question, browsing through the setting in the smartthings app and the comments here, I am still a little confused. I am trying to use this feature:

Turn on at a specific level during certain hours (In a bathroom, dim to 10% at night, otherwise 100%)

Can this be done in the settings somewhere or do I need to use webcore?

All,

I have taken ownership of this DTH and have release new versions. I recommend we deprecate this thread and use that one for support of the dimmer.

1 Like