[DEPRECATED] webCoRE Beta Milestone 2

I noticed this on iOS Safari today but chocked it up to an iOS 11 beta bug :slight_smile:

It’s from a normal piston where i output status in the dash.


I had absolutely no idea you could do that :wink:

1 Like

I’m trying to create an override in a motion light piston for my garage. I would really like to be able to capture whether a switch was pressed physically vs an app/routine/piston changing the state. It seems to register all commands as physical. Any Suggestions?

Hey @ady624, I’ve setup the following piston to test the orientation capability and am trying to set a string global variable:

The global variable isn’t changing…

Any ideas what I might be doing wrong? I’ve checked with my original CORE piston to ensure the right side is being selected.

WebCoRE has mysterious ways :slight_smile:

1 Like

is there a way to check if global variable exists and if it does perform a task else ignore it?

Exists or has something in it?

For the latter isEmpty(). Idk about an exists function

Hi @ady624
I’m still experiencing this issue. Any thoughts?

[DEPRECATED THREAD] webCoRE Beta Milestone 1

I’m moving my piston to a new hub by restoring my existing pistons to the new hub.

I have a few pistons which don’t have auto backup enabled, but when I click on the “enable backup” button, nothing appears to happen.

It this a bug or is there some trick to enabling backups on previously not backed up pistons?

It there some other way to move/copy the (non-backed up) pistons to another hub?

Make a duplicate of the non-backed up version then enable backup on that new copy. Not sure about move/copy to another hub.

1 Like

It seems as if using replace() using regex as listed in the Wiki doesn’t work right. The following piston


[red1Test] is [b green1go]!

instead of the expected

Test is go!

(I’m trying to remove the formatting from a string in order to send it via notification. It might be easier to add the regex replace directly to the code…)

EDIT: fixed the regex to replace(test, '/\[.*?\|(.*?)\]/', '$1') (tested on http://www.regexplanet.com/advanced/java/index.html) but now I get

java.lang.IndexOutOfBoundsException: No group 1

Shouldn’t .? be (.)?

? is the optional operator applying to the previous group. Should that not be a group? As in, have ( )

The .*? is the “non-greedy match” version of .* (shortest match rather than longest), not the optional operator.
Using replace(test, '/\[.*\|(.*)\]/', '$1') would result in go! as the first match would match from the first [ to the last |

EDIT: Figured it out. Seems like I need to double-escape things:

replace(test, '/\\[.*?\\|(.*?)\\]/', '$1')

works as expected!

Still begs the question though whether that could be added to the code directly… :wink:

I keep getting prompted to update this evening.

I check IDE and I have the latest version. I clear my browser cache, did hard clear/reset also, tried other browsers and a tablet and get the update on them as well.

any ideas?

UPDATE: it just went away. strange

Hi - I noticed twilio sms two-way setup in the source that is commented out.

I am wondering what this will be, as having a piston respond to an SMS message and performing a task and responding back would be very interesting.


I am having the same problem - I grabbed the updated code off github, pasted it into the IDE, saved and published, and all four webCoRE Smart Apps show they are 0.2 in the IDE, but on my phone the installed Smart App doesn’t seem to update no matter what - I signed out and back in, I removed the Smart App on the phone, signed out and back in, and, when none of that worked, I removed it on the device and deleted all four apps in the IDE, and then reinstalled them. But when I go to install in the mobile app, the version still hasn’t updated. It installs fine, but I still get the upgrade warning when the browser opens to set up pistons. Thoughts?

There is a github issue with ST again… I had to manually upload the code to github

In the works. Planning on getting dialogs where you can have an actual dialog with a piston


Ah, my install was a manual one, is there a special upgrade process for manual vs. github installs? I poked around in the wiki but didn’t see anything along those lines.