[DEPRECATED] webCoRE Beta Milestone 2

Yeah, I think there’s a problem with the latest version of Chrome, at least on my Android tablet. As soon as I updated Chrome, I started losing registration for the webCoRE dashboard. I had to switch over to Firefox. So far, Chrome under Windoze10 is working fine.

Not sure if this would be the right place to post this inquiry but…(maybe the right place is here for Google Helper?)…I wanted to avoid double posting.

Anyway, I would like to setup an automation where after my “good morning” routine (which switches my modes to Day Home) has been changed after someone walks in front of the stairway motion sensor.

I would like to create a piston where the same motion sensor triggers my Google Home to announce today’s weather conditions, and (if possible) providing information on traffic updates (not sure if this is feasible yet either). Anyway, a simple weather update would suffice.

How would one approach in designing the code to get this working?

thanks in advance.

As far as I know right now it is not possible to use Google Home as a ST’s speaker, or even trigger stuff on it on demand.
You might think it would be possible with IFTTT, but unfortunately Google Home support IFTTT only as the IF part, not the THAT part…

I am hoping the is the right place to post this.
It seems my Web CoRe has stoped working correctly in creating a piston. It started messing up after the latest update.
Basically, after I create a blank piston I am unable to add a new statement. The text will highlight but it won’t advance to the next step.


I have tried cleaning up and rebuilding date cache but no change.

Is there a fix for this? Or do I need to uninstall everything and start all over?

Are you using chrome? I’m having massive issues with chrome on my mobile.

Hi All–
I’m making a piston to respond to my thermostat’s temp up and temp down commands. Since it’s an IR up/down switch, the command has to be executed the number of times as i where “i = (originalSetpoint - NewSetPoint).”

The problem I’m running into is that I don’t know how to make originalSetpoint (which is based on the actual setpoint) remain a static number. So i keeps going to 0 before the repeat loop finishes its i={i-1} until i=0 executions of the command.

I tried all different types of variables as well as the “Capture Attributes” option (which I’m probably not comprehending nor sure of the syntax).

Thanks for any advice you may offer.

@ady624 - just wanted to see if the describeAttributes system is still in the roadmap?

One of my 5 webCore apps has become mostly unresponsive and displays this error message. What does deleting an instance do? and what could be causing 1/5 to not load?

@mkaplan2534,
This happened to me yesterday. Do not delete.

@ady624 told me to go to the smart app and in the settings clear cache and rebuild.

This resolved my issue.

1 Like

Hi @ady624 I know your busy and things are progressing extremely fast with webCoRE but is there a way yet to delete fuel stream data.
I’ve been doing some playing and have lots of entries that are no longer valid or just plain wrong!!!
Is there any way of deleting them yet?
Thanks.

Ady -

I believe I may have found a bug? Or perhaps I am doing something that should not be allowed? Here is how to reproduce what I did. Take any Condition statement and copy it to the clipboard - then attempt to paste that Condition into an else/if condition - of an existing if / then statement. For me, on Chrome, it just hangs on the “Add a new condition window”, and the only option is to hit cancel. Once you hit cancel, that else/if condition is blank and cannot be edited and seems to be corrupted. Manually typing in additional else/if conditions beyond that corrupted else/if condition put this error in the log “An error has occurred while subscribing: groovy.lang.MissingPropertyException: No such property: r for class: java.lang.Boolean” stops the piston from subscribing to any events at all.

There is no work on that yet and won’t be until the basic features are done. That will be a premium feature so he is holding off on spending time on it.

OK Thanks.

Thanks. Unfortunately I have been trying that for 2 days and it hasn’t fixed the issue.

Yep. Later after the holiday ill be home to try it on different browser.

Only discovered this smart app a week ago and loving it. Hate for my first post to be me reporting a problem I am having, but have spent some dedicated time trying to get this to work without success

I don’t seem to be able to get local web requests to work, I have created the worlds most simple piston for testing:

This is the piston and log output, the URL is actually http://192.168.0.112/sony

As you can see the piston response is NULL, however if I put that same URL in to a browser or Postman I get a JSON response back as you can see.

If I put in the URL of my Wemo smart plug, I also get NULL back. If I replace the IP with a non-existent IP, I still get NULL back and no error of any kind. However if I put in an external URL, for example http://www.mocky.io/v2/5185415ba171ea3a00704eed I get the response back in the log like you would expect.

Am I missing a really obvious step to get internal web requests working?

Thanks

Due to the way ST works local requests are relayed to the hub to execute - ST does not wait for any response from the hub - which explains the null. webCoRE would have to somehow subscribe to the hub LAN response and halt execution until that event happens. While that is possible, it is not yet implemented, sorry.

Thanks for the prompt reply!! So is there a way for me to see the response on the hub itself somewhere, a log maybe? Debugging local requests is kinda hard without the responses.

Thanks in advance

There is no way at the moment but maybe I can get the whole chain of events to work this weekend

Wow, that would be amazing!! I’ll have to buy you a beer…