[DEPRECATED] - Universal ZigBee Lock DTH with Lock Codes

yale
zigbeelocks
dth_locks
kwikset

#88

I remember 240 working and 360 not so I assumed 255 (as everything goes by hex). You can try 240.


(S H) #89

Actually it was 240 that I tried, and it would not allow me to enable Autolock after setting it at 240, even 181 doesn’t work. Only 180 or lower.


(www.rboyapps.com - Make your home your butler!) #90

Different locks have different maximum values, e.g. NexTouch have a max value of 127 seconds where as Keyfree goes upto 180 etc.


(S H) #91

That’ why I was hoping it is possible to write a smartapp based autolock, instead of depending on the built in hardware autolock function. Would it be possible to write a smartapp that triggers when a lock is unlocked, waits a certain amount of time (user changeable), checks if the door is locked (manually or otherwise), and if it remains unlocked after that time, then lock it? Does an app like that exists?

There is the Enhanced autolock in the marketplace but that requires a door sensor, which i don’t have nor plan on getting.


(Joel) #92

This is working perfectly for me. Awesome work.


#93

@superhuynh You should be able to do this with CoRE if you have not tried. The only downside over Autolock is that it will only work when the cloud/internet is available.


#94

I just started fiddling around with my smart things, and using webCoRE. I am using this handler for my Yale locks. I was wondering if there was a command in here that would let me trigger the tamper alarm for example if a contact sensor is opened. Thanks.


#95

The tamper alarm will activate when any alarm condition is sent by the lock (forced open, jammed, unit pried opened). Unfortunately I do not have a command in the DTH to trigger the alarm manually. I don’t know if it would be the best idea to do so as then you wouldn’t be able to determine if the alarm was set off by the lock or something else. As this DTH is just for the lock, I’d recommend some other tool for notification. Perhaps CoRE or WebCoRE.


#96

Version 1.6 released. Only major change is the additional support for the Yale YRD226 and YRD246 locks. Otherwise no upgrade is needed.


#97

Updated to 1.6a. Version 1.6 introduced a bug, 1.6a fixes it. If you are on 1.6 please update as soon as possible, otherwise this new version is optional.


(Alexander Ng) #98

What bug was introduced?


#99

There are multiple checks in the code to make sure you are not trying to set a code with a slot number greater than the max number of allowed codes. With the change in 1.6, it was possible that the max number of codes returned was a string (instead of an integer). This was throwing an exception.

This bug broke the updateCodes and setCode commands.


(Aaron Martinez) #100

Why does my lock keep sending update code commands seemingly more that two times every minute?
On top of that it’s not saving user codes. It keeps tellling me error controller failed to set user code?!


#101

Two quick things to check. Are you running the latest version of my DTH code, version 1.6a? There was a bug in version 1.6. Also please confirm that you have set your lock to use my DTH. The errors you are seeing usually mean one of those two things.


(Aaron Martinez) #102

Is the new version on github? Or do I need to install it from code? Because I have it all updated in the IDE from repo and the DTH is universal enhanced zigbee lock.


#103

The latest version is available in GitHub and the link above. Should say version 1.6a in the comments. If that all looks good try one force reconfigure. Also, what lock do you have?


(Aaron Martinez) #104

So then it’s updated. I have a kwikset 910.


#105

Sorry, I’ll have to ask one more dumb question. Your Kwikset 910 is ZigBee correct? I have not seen the error you are experiencing. Unfortunately, I do not own a Kwikset lock to test with. I know others are using Kwikset and this DTH successfully. If possible could you PM me with your live logs after creating (or updating) a code. I’d like to see where the disconnect is.

The error you are showing means the lock manager app is sending a code, but the lock itself is not reporting that it was set. Therefore, the manager keeps trying to send the command to set the lock code. I’ll also try some additional testing with the lock I have.

Also to note, it seems that there may be several users experiencing this issue based on comments in the Lock Manager App thread. They use a different DTH, but in any case we’ll get to the bottom of it.


(Aaron Martinez) #106

Yes it is a zigbee lock. I will DM you one I get home. Thanks so much!


(Dtm) #107

Was this ever resolved if I may ask?