[DEPRECATED] Universal Ecobee Suite, version 1.7.**


I recently switched from a pair of Nest Thermostats to Ecobee3 Lites (with six smart sensors). The improvement was dramatic. However, the best part was your circulation manager. It has significantly improved the comfort within our home. As I understand it, it uses the difference between the maximum and minimum of the selected sensors to control the circulation minutes (per hour). This is very nice, because the system will heat/cool based on the average temperature and circulate based on the differential. I would like to have the option to circulate based on the differential between comfort level and the minimum (for heating) and the differential between the maximum and the comfort level (for cooling). In this way, the circulation would be based on the comfort outliers. Is this possible?

On the surface, it appears as if either method will perform the same task. However, our HVAC system accompanies our wood stove. The wood stove makes the nearby rooms nicely warm and sometimes well above the comfort level. We like those rooms at that level. I want to ensure that the other rooms don’t fall too much below our comfort level. Basing the circulation on the low outliers for heating and the high outliers for cooling makes perfect sense to me.



Let me augment the above just a bit. I would like to every room in the house to be between the heating and cooling setpoints. This is my comfort range. I would like to use the circulation to minimize outliers of this range.


Have you actually set up and tried using Smart Circulation yet? I’m pretty sure that it will do what you want, without any changes.

See, if you configure temperature sensors in your “warm rooms” AND in your “cool rooms”, Smart Circulation will find the biggest delta between the highest and lowest 2 sensors, and then start increasing fanMinOnTime in hopes of reducing the delta between the highest and lowest 2 sensors (which can change - it’s always using the two with the biggest delta).

If you haven’t actually tried it, please do - you may be pleasantly surprised.

And if you have tried it, what is it that you observe that caused you to ask for this change?


I noticed a very troubling discrepancy. My Ecobee App states that a particular smart sensor is at 74°F, but the IDE (using your sweet) lists it at 67.9°F. The information is coming from the same sensor. How could this be. I checked the thermostats and other sensors. Many of them show a discrepancy of over 1°F, and a couple of them are different by over 3°F.



I have tried it. That is why I am asking for a change. You see, we have a wood stove in one of the rooms. The temperature in that room is often 76°F. A bedroom may be at 71°F while the comfort level is at 72°F. I want the fan to be keyed on the 1°F below the comfort range rather than the 5°F between rooms. The 76°F is within the comfort range. The 71°F is just barely outside the comfort range.


  1. What is your Ecobee Suite Manager / Polling Interval? Sensor data won’t update any faster than this, while the thermostat itself will display in near-real-time. I suggest running at a 1 minute polling frequency if you really need to have the most recent data.
  2. The Ecobee WebApp doesn’t always refresh itself, so you may need to reload the Thermostat page to get the current readings - otherwise it can be real out of date.
  3. Perhaps Ecobee Suite has lost its connection. Although rare, you may need to log into Ecobee and authorize again - even if Ecobee Suite Manager says that you are still connected.
  4. There might be a connection error or a code bug - please check Live Logging for Ecobee Suite Manager, Ecobee Suite Thermostat(s) and Ecobee Suite Sensors, looking for logged errors or warnings in any of them


How do I get the thermostat to show up as a separate sensor? As you know, the temperature that the thermostat provides within WebCore is the average temperature of the selected sensors. The suite preferences state that one can get a separate sensor for the thermostat that provides the temperature at that thermostat. I selected that option, but i don’t see the separate sensor. What am i missing?


Hi all. I have two questions here, so hopefully you can help.

  1. I have noticed that Exobee Suite Manager logs me off sometimes, where I need to reauthorize. Not sure if it’s random or not, but anything I can do prevent this? I have not upgraded to the latest version yet (I am on 1.7.4) so not sure if that will help. I have had the same issues with Ecobee in general, so not sure if there’s a conflict or if it is just an ecobee issue.

  2. I am really only using this for away and resume based on my phone as presence sensor. I am running webCoRE as well. If that’s all I’m using it for, do I really need to continue with Suite Manager? Especially if I’m having reauthorization issues? Wasn’t sure if it was worth it (for me personally).

I am pretty sure you have an Ecobee issue, not an Ecobee Suite issue. Ecobee Suite will auto-reconnect if it can; if it can’t, you may have an internal connectivity problem, or a cloud connectivity problem.

To help, I need to see the Live Logging for Ecobee Suite Manager when you have been disconnected…

That said:

  1. You should update your code - 1.7.4 is about 40 releases ago.
  2. If you still have issues, verify that you can access your thermostat using the Ecobee Web App
  3. PM me the Live Logs for ES Manager showing the errors

Thank you for getting back to me so quickly Barry. I think you’re right and may be an Ecobee issue.

Am I missing something, or can you not choose custom comfort settings anymore? I’ve been through all the Helpers, and can’t seem to be able to use them

You should be able to select custom schedules/programs (comfort settings) in any of the helpers that allow you to choose a program (e.g., Routines/Modes/Switches/Programs, etc.).

Which helper isn’t showing you your custom comfort settings?

I was trying to create custom setpoints. When temp is above a certain setpoint, activate a custom comfort setting. However, the only options it gives are Home, Away, sleep

That shouldn’t be - it gets the current list of Comfort Settings from the thermostat.

Could you please check your thermostat device in the IDE? Go to “My Devices”, then click on your ES thermostat device. The attribute programsList should contain ALL of the Comfort Settings (aka programs, aka climates, aka schedules :slight_smile: ). if not, try opening the settings page for your thermostat on your mobile device (SmartThings Classic), and then just save it again. If you refresh the thermostat device in your IDE, it should be updated to the complete list.

If not, please retry the above with Live Logging running in the IDE - hopefully we can catch an Error flagged by the ES Thermostat, ES Smart Modes…, or ES Manager…

I have your suite installed to manage my ecobee4. The main purpose I have is to use setHumiditySetpoint () to set insider humidifer settings based on outside temperature using a webcore piston.

I have two questions:

  1. If I set the humidity point this way, should the set value be reflected by the thermostat or ecobee app? Because when the piston runs, its log reflect it’s setting the correct value, but if I check humidifier settings in the thermostat or app, they do not reflect this value.
  2. The code show this value is a string so I’ve tried configuring the piston as a string and also an integer, but the results when the piston runs is the same as described above.


First, make sure that your humidifier is set to “manual” or “on” mode - humidity setpoints work differently in “auto” mode (where the thermostat tries to adjust the target based on the cold weather forecast).

The current ES Thermostat version displays the average humidity setpoint that the thermostat was targeting over the last 5 minutes, so 5 minutes (or so) after you change the setpoint, you should get the proper value. This is how “auto” works, and (generally) what the thermostat displays as well (no matter what the humidifierMode is, BTW).

If your humidifier is in on/manual mode, rest assured that you are in fact changing the setpoint, it just isn’t getting reported back by the current ES Thermostat they way you expect it to. This because I originally sought to match what the thermostat displayed, even if it isn’t quite right.

I will change this in the upcoming 1.8.00 release that I have currently under development - the ES Thermostat device will show the actual setpoint when the humidifierMode is on/manual/off, and the running-average setpoint when the humidifierMode is ‘auto’.

Also, 1.8.00 includes a new Smart Humidity Helper that gives you more control over calculating what your indoor humidity should be…stay tuned!

That’s great, thanks for the reply!

One followup question for you: The app let’s you set the humidity in steps fo 2% e.g. 32, 34, 36, etc

Do you know if the thermostat ignores an odd value I try to set like 39%?

Thanks again

The thermostat API accepts and sets odd-numbered setpoints the same way it does even numbered setpoints, and the API will report odd-number setpoints as well. As for what show in the Thermostat’s system menu, well it still insists on showing the decaying-average value, but eventually it does show an odd-numbered setpoint (in both manual and auto modes).

Correction - it appears that in manual/on mode, the thermostat will only report even-numbered setpoints. But the API still says it is an odd number, so I’m betting that the thermostat is working towards that odd number, even if it displays only a (rounded up/down) even number on the System Menu…

Im having issues with my SmartCirculation helpers running. they will run each time i go into them and click save, but they will not fire automatically when Ecobee goes into set Program. I have one set to 5 minutes min Program Sleep, then a second one set to 0 minutes Program Home. Used these last year and just paused for summer and i just now realized that they are not working after paused. I have deleted and redone the circulation helper but same results.

SuiteManger V 1.7.44 - Published
Smart Circulation v 1.7.13 Unpublished