[DEPRECATED THREAD] webCoRE design process

Is it possible to add a “recovery” button on the dashboard to try to recover from those “past due” events for that particular piston?

We’ll see. Let’s impose a $0.01 fee per recovery… we’ll get rich…


Doesn’t happen too often for me, but two days ago, my Approx. Hour Chime (my cuckoo clock piston) went 53 mins. past due before it chimed :unamused:

That’s no bueno. Did it go off again 7 minutes later? :smiley:

Yup :smile:

“Past Due” events should be outlawed … better yet, ST’s scheduler/scheduling/whatever-they-call-it-now should be fixed!

Maybe, as an enhancement to the “recovery” button, also have it send a nasty gram to ST to fix the scheduler, LOL … hmmm … nix this idea — don’t want Adrian to get on the bad side of ST :slight_smile:

1 Like

Anyone here with two hubs in two different locations?

v0.0.005.20170118 - ALPHA - Moved UI to homecloudhub.com and added support for pretty url (core.homecloudhub.com) and web+core:// handle

If the browser supports it, once you open the dashboard, it will create a link with core.homecloudhub.com - if successful (I don’t think it works on mobile Safari or Chrome/iOS, but it does on Chrome/Windows and Firefox/Windows) you can then open your dashboard(s) at https://core.homecloudhub.com :slight_smile: Also added a web+core:// handle which will allow nice short URLs for importing and sharing stuff.

I may move the whole UI to homecloudhub instead and use some AJAX component to communicate with ST. I’ll work on that more next week. A nicer URL is always welcome. And it exposes less info and less chances to share it by mistake. Even though it will have a password.

Hi @ady624
Just updated to the latest version of webCoRE and thought I’d have a play to familiarise myself.
I had already bookmarked the URL.
tried opening it in chrome and Firefox via my windows PC and all I get is a blank screen.
Any ideas whats going on?
Also post 257, are you saying we now use the new url (homecloud) that you posted?
Sorry if I am being particulary thick, but I really don’t know what you mean…sorry. :frowning:

The dashboard should open and work normally. Oauth enabled? Once you open it once on a desktop, it will setup a link with homecloudhub.com so you can open it from there without the long weird insecure url the dashboard uses

Yep. OAuth enabled. Was working OK a couple of days ago.
Was running webCoRE version 02 I think.
I bookmarked the url.
Just updated tonight via github.
Now just a blank screen.

EDIT: Here is my URL with some personal items of information amended to protect the innocent. :wink:

I got same thing as bobbles. It worked earlier when I updated (no short url though), I accessed it from an older bookmark.

Update to latest, is it 0.5?

Yes. Updated via github tonight.

def version() { return “v0.0.005.20170118” }

Clear the browser cache maybe? Github has latest

Tried that already in Chrome and Firefox. No joy I’m afraid.

Just tried on IE which has never been used for anything to do with ST. No joy. Blank screen.

In chrome, press f12, refresh and watch the console tab for errors