[DEPRECATED THREAD] webCoRE Beta Milestone 1

Ahhh I see how it works now :slight_smile:

Thanks, ill give it a shot!

Am I getting this ternary right? Doesn’t seem to work as expected, always returning as truth

([DEVICE :switch] = ‘on’ ? “[b,green|ON]” : “[b,red|OFF]”)

Also, I missed the fact that I doofed the equality comparitor.

1 Like

on represents a variable, whereas 'on' represents a string with the value on in it. Unless there’s a variable on that contains some value, you do need the quotes. He got the equality operator wrong, so using == should fix it.

1 Like

I’ve just had a thought. The wind speed is a variable, not an event. Which means if the wind speed goes above 20mph at say 12pm, it won’t turn it off.

1 Like

I have had issues with this piston not updating a global variable reliably in the global variable list. But what is strange is that I have the piston display the global variable as the custom piston state and it shows the correct value. It just does not update the value in the global variable list.

I have this piston doing essentially the same thing with no issues…

EDIT: logs included

6/15/2017, 8:04:28 PM +797ms
+1ms ╔Received event [DEVICE].illuminance = 0 with a delay of 145ms
+212ms ║RunTime Analysis CS > 20ms > PS > 74ms > PE > 118ms > CE
+223ms ║Runtime (33069 bytes) successfully initialized in 74ms (v0.2.0c0.20170614) (221ms)
+225ms ║╔Execution stage started
+241ms ║║Comparison 0 changes = true (1ms)
+243ms ║║Cancelling condition #4’s schedules…
+244ms ║║Condition #4 evaluated true (9ms)
+246ms ║║Cancelling condition #1’s schedules…
+247ms ║║Condition group #1 evaluated true (state changed) (12ms)
+251ms ║║Cancelling statement #2’s schedules…
+283ms ║║Calculating (decimal) 0.0 / (decimal) 40.0 >> (decimal) 0.0
+287ms ║║Calculating (decimal) 1.0 - (decimal) 0.0 >> (decimal) 1.0
+294ms ║║Calculating (decimal) 1.0 * (decimal) 100.0 >> (decimal) 100.0
+299ms ║║Executed virtual command setVariable (1ms)
+309ms ║║Calculating (string) + (string) 100 >> (string) 100
+314ms ║║Calculating (string) 100 + (string) % >> (string) 100%
+318ms ║║Executed virtual command setState (2ms)
+323ms ║╚Execution stage complete. (98ms)
+337ms ╚Event processed successfully (338ms)

I’ll sign up as soon as you roll this out - even with the basic features so far I’m sold on the idea of fuel streams!


I’m using Alarmserver to control my Security System and until yesterday, Dashboard showed the alarms condition (armed/disarmed), without me ever having configured anything. I’ve always wondered how webCore / ST Home Monitor pick up the condition of the alarm.
It has however stopped replicating the actual alarm condition yesterday and I have no idea where to start troubleshooting.
I suppose webCore picks up the alarm’s condition from the ST Home Monitor condition? Does anyone know how or where ST Monitor gets the condition of the alarm system? (I’m not using any of the ST Home Monitor function.)

1 Like

WOW!! Haven’t seen that you created webCoRE! I have used CoRE ever since I got my SmartThings V2. Just bought you a cop of coffe on PayPal. Keep up the good work!


I figured out what was up. I am running the Beta version of Chrome OS, in order to get Android apps on the Chromebook. When I reset it, I went through all the system updates, and that is where my problem came up.

I reinstalled the OS again, logged into WebCoRE BEFORE the updates were installed, and all is good. Then I installed all the updates, including the beta version. It still works OK. My guess is that a security setting in version 60 (which is what the beta is running) interferes with what ever security token webCoRE is saving. But when the token is installed before version 60 is installed, it remains validated. Does that make sense?

1 Like

How would one prepare for a migration to a new hub as far as webCoRE is concerned? Obviously, since all the devices will be moved to the new hub, these will have to be substituted, but apart from that, what do I need to do to transfer to the pistons to the new hub?

1 Like

Hi @Mbhforum, I’m trying to troubleshoot lag between motion reading as “active”, and my time-sensitive pistons firing. What exactly do you mean by moving pistons to a “separate instance”? Seems I get 8-10 feet into a room (or have 2 seconds lapse in a small room) before the lighting automation runs. Any advice on minimizing the lag? Thanks!

1 Like

At one point @ady624 recommended having multiple instances of WebCoRE to reduce lag time. This appears to no longer be needed.

1 Like

@ady624 has worked with SmartThings to reduce as much as he can. I think the only factor that is in your control is to limit the number of devices in the webCoRE piston itself.

1 Like

This was from back in May. Things have since changed with the addition of the storage app. But this should clear up what is bothering some people. Also please move any further discussion to the non deprecated thread. [DEPRECATED] webCoRE Beta Milestone 2

1 Like

Did anyone make any progress with this? I’m trying to use this template but webcore continues to say that “the piston is not subscribed to any events”. Can a piston subscribe to a boolean variable??

1 Like

Your question is best suited over here. Post over there with what you are trying to accomplish and what you currently have. A lot has changed since I did that sample.

1 Like

Ever fix that? I’m at the same spot and unable to find a resolution


This is ancient however I curious on the detail steps you did to fix this. I have the same issue with the wemo insight handler not being detected as a power meter under Core/WebCore.

did you do those in any order: reinstall handler, removed wemo connect, then installed wemo connect again?. I’d love to start working on my Wemo Insights and WebCore/Core.

You might get more traction if you post on WebCoRE forum.