[DEPRECATED Thread: visit community.webcore.co for assistance] webCoRE - Piston Design Help (ask your fellow members for assistance)

@alixjg try ‘changes’ instead of ‘on event’

So, back to the capture/restore discussion for a minute. I used to be doing this in CoRE and it worked fine there. But after discussing with @bangali and then @ady624 graciously adding the function to WebCore, I thought I had figured out doing it in WebCore too. Nope. At the risk of embarrassing myself, I tested the Piston below without success. The trigger happens and the three lights all go to 100% but after the 5-minute wait, the lights do not return to their former switch and level state.

I’m guessing I’m not doing the capture and/or restore properly, but I don’t know what to change. Any help would be appreciated.

First thing I’d try is add a second or two delay between store and the change of level. Maybe it went by too fast :slight_smile:

Ooooh nice, it cancels when the door closed :slight_smile:

1 Like

Trying to have the time announced hourly. I’m getting an announcement on time but not the correct time. If I set to announce on the hour it announces 1 minute before. If i use $time I hear the hour-colon-minute. I’d like to not hear colon. Only the hour followed by minute. I tried $hour, $minute. but it skips the hour and speak the minute.
What expression and time variable can I use to get a more natural sounding announcement?

Thanks in advance

Thanks, although I don’t feel like that will make a difference, since the trace seems to show it firing… but I’m trying this:

Again, it shows that it’s firing, no graphs as of yet.

Ding! Ding! We have a winner!
I ran a trace and the wait was cancelling after about 5 seconds. Once I added TCP Never cancel, it works great, even with multiple triggers.

Thanks Robin.

1 Like

Ok so I’ve been pulling my hair out on this one. I’m trying to get this to only display one decimal spot.

but here is what i get:

can someone help me with the coding?


decimal() does not take a size parameter. You need to use format():

format('%.1f', insideTemperature)

% means parameter, .1 above means one decimal place, f means float


Je suis désolé mais je ne peux pas…

1 Like

Ummmm… bleu?


WEE WEE jimma le pal

@ady624 ehh … just didn’t want you to get bored with the easy stuff :wink:

thank you.

Hi Bangali,

Thanks for the answer. I’ll give it a try in a few days. The latest version is still created in Core, and I tried that functionality there, but couldn’t come to a solution. I’ll give it a go with WebCore.

At least it looks as I’m looking in the right direction.

Kind regards,


Verstuurd vanaf mijn iPhone

I’ve been busting my brain (which admittedly does not contain much programming ability) to get time announcements working, without any luck. Problem is, there are so many aspects to it, I find it difficult to pinpoint the issue.
I want to use my Denon Heos speakers to do this and I’ve figured out that I have to use the Media Rendered Connect app to be able to use them. I got to a stage where I do get webCore to play the time announcement, but subsequent announcements, use the time of the initial announcement.
What might help, is if I could get answers to the following:
(a) Should we use the speakers as music players or TTS devices? Will it make a difference?
(b) What is the difference between the following webCore functions: Speak / Speak Text and Resume / Speak text and restore. (There seems to be a difference in the format of the message/date going to the speakers between the first one and the other two (apart from the obvious resume part).
© How do we get the message to update instead of repeating the announcement of the first message when the piston did the first announcement.

For what it’s worth, here is the piston I set up to investigate how to use the function - at least if announces the time sometimes, so it should help you with the variables to use:

@Pieter-Jan you are welcome. feel free to import and use this piston as the starting point.

@anon36505037 meant to ask … do these work with smartthings In the US?


I figured out flash doesn’t work on the Hue Device Handler so I switched to the stock one and it works fine. I found the Hue Advanced Connect also works so staying with that one incase anyone else has Hue bulbs too and was using the flash command.

Hi Bangali,

Maybe you can help me with this too.
I reinstalled webcore with gifthub, but now I don’t see it in my smartthings app under my apps.
I think I did all the right steps.

Any idea what can be wrong?

Many tnx,


Thank you, I got a little frustrated with this new task and was feeling quite inadequate but soon realized that I’m just uninformed. I started monitoring a MIT undergrad computer science course that has helped a lot. The info from the lectures and help from forum members has put me on the path of learning something that I wanted to for years. I can see already that coding these little scripts can get very addicting. Looking forward to learning more and utilizing that information.
Thanks again.