[DEPRECATED Thread: visit community.webcore.co for assistance] webCoRE - Piston Design Help (ask your fellow members for assistance)

well put :smiley:

heres my “hack” in webcore to get time in an usable format

time(((int(left($currentEventValue,2)) * 3600) + (int(right($currentEventValue,2)) * 60)) * 1000)

nice! :+1:

1 Like

Can someone please help me understand why this simple command for fading lights on 30 mins prior to sunset, and sending a push, never works?

It is currently running in a loop so I get a new push every 15 seconds and the lights never go past 0 or 1% in the fade.

It appears to be suddenly working for me. I also see that my honeywell is showing up as a full thermostat now.

It is not a dimmer switch just standard toggle GE/Jasco light switch.

@bigverm23 never tried fade myself but have you tried setting TCP to never cancel?

Sure wish someone could tell me why I can’t access Webcore Dashboard from an Android device. Gets old having to go into the computer to see if a piston ran or to make a minor change.

Hate to keep harping on this, but not hearing any answers.

There is no definitive answer as to what was changed in Chrome, a suggestion was to use Firefox to access the dashboard, for now.

1 Like

Then I believe you will be able to do what you are wanting to do

Well this has been a holiday weekend here in the US. So just take a break or use a computer. That is the main point of webcore

I was wondering if someone could help me. I have a piston on core which works as a vacation Lighting mode when I’m away from the house between certain times. It works great however I have moved it over to webcore and it seems to run each THEN action one after another rather than simultaneously. Here is the piston, have I

missed something out? I should also mention that I’ve tried changing between synchronous and asynchronous but it doesn’t have any effect. Thanks

Chris, you need to set the WITH blocks to asynchronous, not the IF statement. You can leave the first and last WITH blocks as is (synchronous method).

UPDATE:
Do the first WITH block too, LOL

I am in the US, I know very well it was a holiday weekend.
But I posted something on this well over a week ago. I wasn’t
Necessarily expecting a fix, but it would be nice if someone
Would have acknowledged the problem. The only responses
I saw was someone else having the same problem.

I’m not having any issues from an Android.
What browser are you using?

Here it is (I’ve made some more superficial changes, but it is essentially still the same as the one you had made):

/**
 *  On/Off Alarm Tile
 */
metadata {
	definition (name: "On/Off Button Tile", namespace: "Test", author: "Test") {
		capability "Actuator"
		capability "Switch"
		capability "Sensor"
        capability "Image Capture"
        attribute "alarm", "string"
	}

    preferences {
    input name: "timer", type: "time", title: "Alarm Time:", description: "Enter time", required: false
	}
	// simulator metadata
	simulator {
	}

	// UI tile definitions
	tiles {
		standardTile("button", "device.switch", width: 2, height: 2, canChangeIcon: true) {
			state "off", label: 'Off', action: "switch.on", icon: "st.Health & Wellness.health7", backgroundColor: "#ffffff", nextState: "on"
			state "on", label: 'On', action: "switch.off", icon: "st.Health & Wellness.health7", backgroundColor: "#00A0DC", nextState: "off"
		}
        valueTile("alarm", "device.alarm") {
			state "default", label:'Alarm: ${currentValue}'
		}
		main (["button", "alarm"])
		details (["button", "alarm"])
	}
}

def parse(String description) {
}

def updated() {
        def time = timer.substring(11,16)
        def tz = location.timeZone
        def schedTime = timeToday(timer, tz)

    if(timer) {
    		log.debug "Alarm time set to: $timer"
    		sendEvent("name":"image", "value":schedTime)
            sendEvent("name":"alarm", "value":time)
    } else {
    		log.debug "No alarm time is set"
    		}
}
def on() {
	sendEvent(name: "switch", value: "on")
}

def off() {
	sendEvent(name: "switch", value: "off")
}

It appears to be a Chrome issue. Chrome on Windows
Works fine. It used to work fine on Android, but something
Changed and it quit working.

I realize this is something that probably changed in the Android
Version of Chrome, but would appreciate the acknowledgement
Of the problem and it is or will be worked on.

Ah ok.
I use firefox for Android and that is working fine for me.
As for someone working on it I suppose it has to be decided if it’s a chrome or WebCoRE issue.
If it’s the former then there’s not much that can be done about it here.

If the first with is synchronous, all others will wait for it. It’s only the last that does not need to be async, though I would just make them all, what if I add more later lol

What is the problem with Chrome/Android?