[Deprecated] Thinking Cleaner 2.x (Roomba Control)

Sorry but I wouldn’t be able to answer that one. Not sure if anyone else would in this forum.

Thank You.

Please excuse any typos.

Sorry that this is an old thread but i was having the same issue. What i found was that when i connected the device via the Android app the last step screwed up everything and if i tried controlling it from the app. What i have done (and it’s been stable since)

  1. Use the app to reconnect roomba to wifi
  2. Right after it says its connected, before finishing with the app. I close the app and uninstall it
  3. Update the device in ST to ensure that the IP hasn’t changed.

This has worked for me.

1 Like

Interestingly I got a notification and email the other day that my Roomba undocked and docked… So I guess the thinkingcleaner servers still kinda work?

You’re right, the thinkingsync.com site is working again. Ever since it went down, I have been using the web interface on the local ip instead of their app, and the ST device handler has been fine so I didn’t notice. Someone must have swapped out the gerbil powering the site or something. I guess I might try setting up the app again…but I might just let a sleeping dog lie.

1 Like

Very odd, but after @TylerDurden comment I reconnected to wifi and it is staying connected…

Maybe worth reaching out to them again?

I may have just crashed the thinkingsync.com site… I clicked “Logs” and it timed out and now the site is unresponsive. (Sorry :frowning: )

I’ve actually moved on to the Xiaomi Roborock S50. No ST integration currently unless you set up a Pi as a middleman. But the robot maps the room and methodically cleans, and the app is nice. Works with Alexa too. Someone did some really cool work using the Pi integration where they could tell Google to clean a specific room and it would send the robot that house location and clean that area. (This can be done in the app manually.) I bought two, and the second one has a defect with the dock electronics. I’m dealing with the aliexpress seller now to send the unit back. (It’s a little challenging with the language barrier, etc.)

I gave the my old roomba to my parents. Hopefully the thinkingsync.com recovers soon.

EDIT: The site is accessible again.

I love my new Neato D3, with ST integration. I keep an eye on Amazon as randomly the price has dropped to around $200…

Roomba 985’s (980’s) are for sale in Costco @ $499!

New Roomba i7+, interesting features… It removes the waste from the machine into a bag, will allow it to clean by room if you want instead of entire floor…

2 Likes

About time! Been wanting this feature for years.

1 Like

EVERYONE KEEPS POSTING THIS EVERYWHERE!!! I NEED TO WALK AWAY!!! :smiley:

Now if they’ll only create something to empty the self emptying base…

Well… it seems like a setup for an inception type joke but honestly, the more I think about it, the more it could be cool if the base could then connect (or just directly connect anyway) to those whole home vacuum systems…

All I would want is someone to make a 3rd party bin to replace the disposable bags.
Cheap plastic. As long as I can rinse it out and let it air dry, that’s fine.

Disposable bags?

The tower will use disposable bags.
So the Roomba will pull in to dock, a vacuum sucks the dirt from the Roomba bin and puts it in a disposable bag in the tower unit. The official ones are 3/$15. I know some knockoffs will come and be cheap, but I’d rather just get a large bin I can dump and rinse out when needed.

1 Like

That’s not good!

I decided to dust off my thinking cleaner, reinstall on the Roomba 650 and play around with it.

Seems I can configure the TC locally through the web app, connect it to their cloud and control it pretty much like normal. I was even able to update my firmware over the air. One thing i’ve noticed is that it does seem to disconnect from tc.thinkingsync.com fairly often. (at least pre firmware update)

Is anyone successfully maintaining a connection to tc.thinkingsync.com with it? I figured I can fake an ST integration using IFTTT webhooks and trigger it with Alexa as well.