[DEPRECATED] Samsung TV support in SmartThings?

Which SmartApp? As far as I can tell, anything prior to 2015 probably isn’t running Tizen OS.

Installing smartapp from the IDE from the Smartthings labs category under templates, its called “Samsung TV (Connect)”. I had to find the device handler separately but it was in github if I remember correctly.

2 Likes

Yes I actually did a little more research on this tonight and got the SmartApp and the SmartDevice Type installed, it found my TV successfully (UN50F6400) although it took a minute or two of searching so you do have to be a little patient, then everything worked as expected.

Aren’t J series Tizen OS based?

Would it be possible to post some links to the code you were using? I am not seeing this in the US IDE.

Has anyone had any luck connecting 2014 Samsung H product series? :confused:

You need two parts, the first part being the Samsung TV (Connect) Smart App:

https://github.com/SmartThingsCommunity/SmartThingsPublic/blob/master/smartapps/smartthings/samsung-tv-connect.src/samsung-tv-connect.groovy

The second being the Samsung TV Device Type :

https://github.com/SmartThingsCommunity/SmartThingsPublic/blob/master/devicetypes/smartthings/samsung-smart-tv.src/samsung-smart-tv.groovy

Once you install those, go into the Samsung TV (Connect) app and let it search, it took longer to find my TV than you might at first thing it would so have some patience (mine took a minute or so), once it finds the TV you’ll find it in the ‘Market Place’ as an unconfigured device.

Note that the ST hub and the TV will probably need to be in the same subnet on your network for it to work and also make sure your TV is on at the time it is searching otherwise it can’t find it, personally with my TV, I tend to turn it on and make sure it can actually play something (YouTube, NetFlix, whatever), I feel sometimes the ‘networking’ on my TV can take a while to ‘wake up’.

3 Likes

What TVs will this work with?
I’ve got an ancient ES8000 )(ES is, what, 4 years ago?) and when I was installing my Samsung Multiroom Audio devices, it popped up and found two devices - my new HW-H750 soundbar and some other unidentified device. Kinda assumed it just appeared as two devices for whatever reason since they were consecutive IP addresses.

I’ve just thought to check the IP address on my TV and it’s one of the devices found! I tried to play the weather forecast through the TV though and got nothing, played it through the soundbar and it worked.

Honestly I’m not sure, mine is a 2013 TV and I think there was a big change in 2012 (to my ‘generation’ of SmartTV) and then another change late 2014 / early 2015 when they switched to Tizen OS which I don’t think is supported.

Best you can do is install it and give it a try, like I said, make sure your TV is on the same subnet as the ST hub, ‘pass some traffic’ through the TV first just to make sure and then let the SmartApp search but let it run a while!

Yes this is my issue. However I have parked this as my JS9000 is going back and I have had a change of heart and going with a LG OLED (65EG960V) instead. I suspect this will mean no native integration whatsoever ever and resigned myself to a zwave IR device.

Hi All

I’ve added the smartapp and device types and the ST hubs has found both my TVs! Unforuntatley, none of the controls actually do anything. Anyone else having this problem or know why it might be happening? Everything looks fine but none of the panels trigger any action with the TV.

Thanks
James

When you connect make sure the TV is on as it will ask you to confirm external control.
I’ve got it working with my D8000. Everything works except power on which I’m guessing is because the LAN port on the TV gets turned off when you turn the TV off. I must check that’s the case with the Samsung smart remote app

1 Like

just adding to this that I am struggling with a samsung ue32h4500ak.
it detects the TV which is great but actually triggering doesn’t seem to work…

Yep as mentioned by @HughB the first time you press a ‘button’ on the app for the TV, the TV should pop up with a message that asks if you want to allow the remote device, you need to accept this.

If you don’t get the message there was talk of a ‘remote management’ option somewhere in the menus being disabled which you might need to change.

What model is your TV?

Amazing, worked fine for me on my 32" tv.

Can you trigger an action on the TV from routines; such as reduce volume if after 23:00?

Also, anyone made any custom code to start any of the smart apps (launch netflix etc…).?

Cheers!

Possibly, you’d probably have to right a SmartApp to do this but the biggest potential issue I could see is that the hub/TV doesn’t take to well to quick button presses in the ST app for the TV remote, so you’d have to have some sort of delay in the app between each button press.

I moded the code to bring up the guide last night which works so far. From what I can tell the tizen tv’s will use the same commands so should work too. I can’t get an on command to work yet but will keep trying.
If you press lots of buttons the tv won’t respond quickly as they seem to get cued while the tv’s and hub perform ack/nack comms

As far as I have researched, it’s absolutely impossible to turn on the TV by any means other than an IR command. It would have been nice if it either supported Wake-On-LAN (AKA Magic Packet) or if it just left the NIC in a super lower power mode, enough to respond to an on command from apps such as this one or the official Samsung ‘Smart View’ app…

The (expensive) solution is to never use standby, and use a SmartThings compatible power socket to turn the TV on/off.
My D8000, and the new J ranges I use at work all return to last state when power applied from the socket - so they turn on if they were turned off at the wall once power is applied.

You may also have to stop the TV from going into power save - just sending a command every 59 minutes should do it, there must be a command that doesn’t interrupt viewing. A quick vol up/vol down would bring the volume display on screen, maybe something like pressing “green” would work?

2 Likes

Yes… that would technically work :smile:

Think it would probably work out cheaper to just get some sort of Z-Wave IR emitter or go the Harmony route.

I’ve got a UE32J5500 (2015) and it’s detected, but nothing works. Looking the in the logs, it says TV not found…

Not sure what’s going wrong