[DEPRECATED] [RELEASE] Blue Iris Fusion - Integrate SmartThings and Blue Iris!

You can turn on debugging within the app and view “Live Logging” in the API. I’d recommend reading through this whole thread, lots of good info on how to ensure it’s set up correctly. If that doesn’t work, post your specifics and we’ll get it fixed!

1 Like

I just saw a mode change from Away to Home, and the following in the live logging:

Looking in my ST app, there are a bunch of dots in the password field, but maybe it never got set? (or maybe it got wiped out at some point?). I’m going to try re-entering my Blue Iris password in there and see if it fixes that.

Edit: Yes, after a couple days since updating the password in my SmartApp install, it appears to be having no issues whatsoever. Changing between Home / Away / Night modes in Blue Iris perfectly!

1 Like

Hello how exactly do I install this smartapp.
when i go to smartapps and update from repo then I select the handlers iget a
Error
500: Internal Server Error
URI
/ide/app/doRepoUpdates
Reference Id
0e45df2c-0404-483f-8463-bcc95f85e2df
Date
Mon Apr 24 16:26:35 UTC 2017

Just read up a few posts, it’s explained. Be sure you add the BI Fusion and
the BI Fusion - trigger app as separate apps in the API, then on your phone
inside you’re only trying to install the BI Fusion app, not the trigger
app. It looks like you’re trying to install the Trigger app on your phone.

Hey guys, stumbled upon this thread ! read it, have a quick question, if i use Stunnel to pass 443 for my BI server, it will not work with this? as i will need to purchase an actual SSL Certificate if i want to be able to use this app?

If you want to use external login with Stunnel you’ll have to get a real
SSL from a CA. Letsencrypt.org let’s you set up free ones pretty simply, I
wrote a quick tutorial, I think in this thread somewhere. If you want it to
connect local only, then as long as you doing use https for LAN too within
BI you’ll be fine (you can have HTTPS via Stunnel on the WAN and http on
the LAN in BI)

HI FlyJMC! Great app, got it working today. I have a question though. I have mine setup when the door opens it will trigger the camera to record. Does it only capture snapshot when triggered cause that’s the only thing I see in my alerts and not video recording?

Sounds like a BI setting issue. The smartthings app will “trigger” the camera in BI, so BI will do whatever you have it set to do when a camera is triggered. I’d say you need to double check your recording settings for each profile and make sure you have the camera set to record video and not just create alert list images.

So I guess I’m trying to do the opposite of what this app does, I want motion triggers on my Blue Iris cameras to alert me on my smartthings app is that possible?

Yup, that’s the opposite of what BI Fusion does. I set up what you want though, there are a couple options out there, check out this post (and surrounding thread):

I made a virtual motion-switch for each camera in smartthings, then used a Maker channel and Smartthings IFTTT integration. So in Blue Iris, I have each camera set up to send an Alert to a different Maker channel url for motion on and motion off. Then in IFTTT I have motion on and motion off applets for each camera, and they either turn on or turn off the virtual camera device. It’s a bit round-about and cumbersome to set up, but the other smartapp options out there use oauth and a url that changes every time you go into that app’s settings, which was a nightmare. The BI Alert > Maker Trigger > IFTTT switch on/off > Smartthings virtual device for each camera has been going strong for 11 months now (thousands of triggers later…).

There are lots of alerting smartapps out there, I use Super Notifier to keep them all straight:

In the last month or so I noticed that BI Fusion no longer is able to change modes from Smartthings as it did before. I am unable to determine why, and am wondering how to restore the function. I don’t think it can trigger cameras anymore either. Has recent Blue Iris updates caused the problem possibly? Anyone else experience this, or just me? I tried reinstalling the app, reinstalling Blue Iris.

Never mind. I think I got it working now. It seems that having “admin” capitalized was preventing access to BI. I changed that and it works now.

i’m getting two results in using this with wan (couldn’t get lan working).

one success and one fail of the profile change. So the profile is changing, but getting two results. success + fail. Any idea what can cause this?

I get this as well (WAN). The profile does change, so this is more of annoyance than anything else.

True. Were you able to get LAN working?

I haven’t tried it, actually.

Do you mean you’re getting two notifications (success and another for failure) each time? But the BI profile is actually switching ok? If that’s the case, sounds like a bug, let me know.

RE: LAN not working, I’ve been only using LAN for several months now, with zero issues. The biggest things to check are to make sure you aren’t using stunnel for HTTPS on LAN, and to uncheck “secure only.”

I’m getting the success/fail notifications too. The profile does change. The success message comes first, followed immediately by a failure message.

A more serious bug has cropped up: it no longer holds the profile through a reboot. I tried both external and LAN connections, but it made no difference. This used to work fine… it only recently stopped working. It may have been about the same time I started noticing the success/fail message thing… perhaps something has changed on the Blue Iris side? I know he’s been playing around with the webserver components in the last few updates.

Scott

Well that second part may narrow it down, the fail message may be coming
because it isn’t getting the hold command through.

When you say it used to work fine, can you narrow that down at all? I
haven’t changed the code in a while, so if you can determine whether it
stopped working before you last updated it or if it was after that’ll let
me know if it is something I did or something changed in BI.

I know you said you couldn’t get it to work locally, but I’d recommend
setting that up in the meantime while I try to correct it. I use it locally
now and haven’t been having the issues you’ve had on WAN.

One other thought, go into your BI Fusion smart app settings and cycle the
"Local connection?" and “Make hold changes?” Toggles off then back on. I
changed how those work on the last update and if you didn’t check them
after updating it could cause problems.