[Deprecated] New TP-Link/Kasa Plug, Switch, and Bulb Integration

I managed to figure it out and got it working, just did what you said.

took me a while but the identifier I ended up having to use was - KL50(

complete with the ‘(’. I did try just the KL50 but it failed and I could see in the logs that it wasn’t recognising it, so I did some digging and found out that the ID had the extra ‘(’

anyway that is what I did.

if you are updating yours bear in mind that the bulb is a “TP-Link Smart Tunable White Bulb”

1 Like

That is what is in the current app code (I write the driver/app). the reason for the “(” in the identifier is that all others are 5 characters and it was simpler to just use the same five characters for the KL50/60.

Dave

I just want to say thank you so much for creating this! The new ‘official’ device handler does not show power readings on my hs110’s so it is completely useless. Your handler and app work perfectly!

2 Likes

Hey!
I may be completely incompetent but I can’t make this work with my HS110. How do I make it to show energy? And where do I find the guide?

Mattias

The link at the top contains the location of the drivers, application, and all available information. Numerous people have installed without major issue; however, I can not help at all without information.

I know this may be a long shot, but a week or so ago I noticed issues with this app and had some updated devices that weren’t showing in ST, so yesterday I tried to fix it.

Firstly, I’m using ST classic app. I did have the new ST app installed, but it would never login, so I uninstalled that yesterday.

Error: When i go to Automation -> SmartApps -> TP-Link SMartThings Manager, I get an error “Something’s Wrong - We can’t load your screen right now.”

Trying to correct it I tried removing it from web with no luck

  • My SmartApps -> TP-Link SmartThings Manager -> App Settings -> Delete, I get an error “This SmartApp can’t be deleted at this time because it is installed by one or more users”
  • Since i can’t get to it via the ST app to remove, i’m now stuck.

Then I scoured these forums and found that I could delete it via My Locations -> Home -> List SmartApps -> Edit -> Uninstall, however i get the error “There is an error uninstalling your SmartApp”

This also used to be able to be Paused but now it is grayed out.

If I look deeper into the logs of this device, it’s getting a ton of errors, all seemly the same ones:

I lastly tried to simply overwrite the code and re-publish it on the web, but that has done nothing too.

I’m at a loss, it’s like this app is broken completely and I have no means to correct it or get rid of it. I figured I’d post here given the errors in hopes Dave see its and might be able to help, if anyone has run into this or something like this please let me know. thanks.

What devices do you have and how many?

@Gutheinz - thanks for responding. I have a lot.

3x HS100
1x HS103
4 x HS300 Power Strips

The ones that are showing offline also show offline in the Kasa App, so it appears to be an issue with the HS300’s

Have a little trouble hopefully someone knows answer to you I am using 4 hs100 and 1 HS110 with my ST and I have set up everything following the instructions everything works fine only problem is everything duplicate twice I have tried to delete them but they keep coming back

Have you also installed (Linked) using the new Application. That is where the problem is coming from. You will have to remove the TP-Link connect from the new app or my app from the classic. You can not have both.

Yes. It appears to be the plugs. try unplugging/replugging the HS300s. Also, from home, go each devices settings page and see if you see a line “Remote Control”. This should not be there. Simply toggle off and try again. (The SmartThings integration requires the cloud, therefore no Remote Control).

1 Like

all new to this so it’s a learning curve thank you Dave appreciate your hard work one more question sorry can you tell me why I don’t have icon

No. In the classic app they just sometimes disappeared. It may be a link has been changed from where the image originated or it may be SmartThings. It does not impact functionality.

Dave

Thanks for your help Dave

1 Like

@gutheinz thank you, it was indeed the plugs that were non-responsive through TP-link, once I rebooted them I could utilize the Manager through the classic app. Thanks for your help pinpointing this issue. You’re the man now dog.

1 Like

Not sure if this has come up before, but of the 10 TP-Link devices I have in the kasa app, only 9 of them get added to the smartthings classic app. The classic app even finds the same 10 devices as the Kasa app, it’s just that after I choose add, only 9 of them come through.

Any ideas what could be wrong?

Second thought, I think it might be a “user error” :slight_smile:
Will have to find out when I get home.

What are the 10 devices? I will use this to validate the code can load the device (each TP-Link device type must be hard-coded into the app.

Do you have the correct driver?

Dave

Yup, definitely user error on my part :slight_smile:
That last device was a dimmer and I had forgotten to throw in the device handler for it.

It’s all sorted out; apologies for the omission :slight_smile:

let he who is perfect cast the first stone. Glad it worked out.
Dave

Hello

I’m writing to get an information about the new app from TP Link - Tapo.
Does anyone know when they will release an update to configure the Tapo device to work with SmartThings App?
Thanks all.