[Deprecated] New TP-Link/Kasa Plug, Switch, and Bulb Integration

Thanks for getting back to me.
So yeh I did the two things you suggest before putting my first message up. So the official one was uninstalled which was great. And I tried to remove your one, again before the message but that didn’t work just comes up with this when I try and remove it

Need error logs when you are trying to remove. Turn on live logging on the IDE and start again. The error log for the application only should be copied here.

image LJust ran the error logs and this is what I get on it:

A summary of your state:
You tried to remove devices via the phone application - and that failed for some. How many?
You tried to remove the Service Manager via the phone application - and that failed.
You also have some devices you can’t remove but have de-installed (unplugged, etc) (the errors in the log are devices that the Kasa cloud can not find).

I just tried on my devices and had no problems. Some other things to try:

  • Manually remove all of the devices from your rule-based app and other apps. This list is available on the “devices” page for the device.

  • Try uninstalling the device again.

  • Look at the new phone application and assure that the Kasa Account linkage has been removed. This can cause wierd things since the devices use the same identifier in the system (smart confusion).

After that, I am out of ideas.

The official TP-link can be added in the new Smartthings app. However, it does not work in Smartthings Classic. It also does not work in something like logitech harmony. Dave Gutheinz’s handler and smart app is still the only solution. Thank you Dave Gutheinz!

And I will continue to support these until the end of classic.

1 Like

Hi Gutheinz,
Is Kasa KL-60 supported in the integration using your device handler

Not currently. It is apparently very old.

  1. Can it be controled in the Kasa App?
  2. From the Kasa App, what firemware / software version displays?

Dave

I have been waiting to make the switch to the officially supported app. Today I made the jump. I have about 20 kasa controlled devices. I deleted them all from the classic app. I deleted all the tp-link smart apps, and device handlers. I then when into the new app and linked my kasa account to smarththings and it found the devices and it works great in the new app.

Went to the old app and it has all the new devices but I try to change the state from off to on and it switches for a second (light doesn’t change) and then it reverts back. In classic I clicked the add devices and it discovered all the kasa devices so I let it add them all and still same results.

I guess my question is. Are my results normal?

No app updates or firmware updates available for my kasa or smartthings.

Outside of my expertise. I continue to use my driver set. There is some discussion in another thread (do not know exact name) on the official integration problems. Search for Kasa and you should find it.

This is what left me to hunt down this thread. I installed Kasa devices for the first time last week and they worked in the new app but not in the old, also not in webcore so I decided to hunt down some device handlers which led me here.

What I did was left the devices as they were installed but went into the IDE and simply changed the device handler to the closest one that Dave has published in this thread. So for a colour bulb I chose his colour device handler and that worked well so I went ahead and did all the rest, now my devices work in both apps as well as in webcore.

That is good news.

Did you also install my app (your post indicates no). If not, then I am lind of confused since my drivers explicitly call the Parent with Method and Format to send commands to the Parent. Perhaps the Native installation uses the same Method as my App as well as the same method for handling return data. Very curious.

The reason webcore did not work with the new DHs is that the new integration does not use the exact same capabilities and attributes used in mine and you may have selected one that is not in the new app. Below is the list from the Color Bulbs with the likely items not covered identified

capability “Switch”
capability “Switch Level”
capability “refresh”
capability “Actuator” (This was required for Action Tiles to work in old integration)
capability “Health Check”
capability “Color Temperature”
command “setModeNormal” (these three are for Circadian Mode
command "setModeCircadian"
attribute “circadianMode”, "string"
capability “Color Control”
capability “Color Mode”

You might want to check if Webcore requires Capability Actuator and, if so, if the official TP-Link integration may be missing this.

I also use your smart app and when I go to add new devices they show up

You are using KL50 in your toilet (the filament bulbs)? This is not currently supported for installation - I will update today to include the new filament bulbs.

Dave

Added - Just added the Filament Bulbs to the products in the Smart App.

yeah using that in my bathroom, wife loves those bulbs, I am sure I will be buying more for the lounge and perhaps a few other places around the house.

I will go get the DH and use that rather than just a dimmable DH.

Cheers

ah you’ve not added a new DH, not that I can see anyway

1 Like

The bulbs only have level control and should work with the same DH as the 100 and 110 series bulbs:

TP-Link Soft White Bulb.groovy

If they do not, I need to know.

Yeah they do and it’s what I’ve been using for them for weeks now.

1 Like

Hey mate. I needed to add the bulbs back into SMT and decided to use your app for the whole process this time. (Last time I added via the new integration then swapped the DTHs to yours)

The KL130 bulb has added no problem but the KL50 shows up in the add device page but when I click save it doesn’t add it. I’m assuming it’s not finding the right DTH for the filament bulb.

Any ideas how I fix this?

The normal bulb DTH worked fine for it when I changed it manually last time.

Problem is the identifier for the bulb. I will need to modify the app but ( need to know the identifier.

In the IDE,

  1. select My Location then your location
  2. at the bottom is “Installed SmartApps List SmartApps” - select
  3. From the list (toward the bottom), select the TP-Link app.
  4. At the top is a section “devices” or something like that. Select the cell with the data and copy to this location.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.