[Deprecated] New TP-Link/Kasa Plug, Switch, and Bulb Integration

So I have been looking around the web and can’t seem to clearly find if tp-link kasa switches (HS200, and HS210) are supported by the hub now. I had bought the hub a few months ago and they were not but it seems like certain tp-link switches are now.

Both are supported in the official integration from SmartThings using the NEW phone app.

1 Like

Look at the top of this thread. The GitHub code is there for the “unofficial” integration still. It uses the classic app.

If you are installing in the NEW App, that app has it’s own installation routine (press “+” in the upper right corner.
Dave

1 Like

Done! Works perfect on Classic app, thx!

1 Like

So then my question is would I be able to connect them directly to the smarthub only and not to my network? Because that was the original intent of me having a hub to free up my wifi, but I know the tp-link kasa switches do not emit a radio signal like z wave or anything so they have to be connected to the internet in some form.

They must use you WAN. And they must be installed via the Kasa App (it sets up the LAN interface for the devices.

Finally, no SmartThings WiFi devices use local hub for processing. All must minimally go through the SmartThings Cloud.

Only Z-Wave and Zigbee Devices are not on your local LAN.

Installing the new app won’t interfere with the classic app, your devices, or your automatons. I’m actually using both for various things because they each have certain features the other doesn’t, such as location based Smart Home Monitoring activation/deactivation support in the classic app and more complex ifttt style routines in the new app. There are several other differences, so it might be worth it just to check it out. If you do decide to install the new app, you will have to reassign all your devices to their various rooms. Since you say you have “tons of devices,” it could take a little time to go through them all.

2 Likes

I don’t get it. I installed Kasa app. Connected my bulbs. Connected the Kasa account to SmartThings, but nothing shows up.

Your issue is apparently with the Official Integration, not this segment. Contact SUPPORT.

I figured it out. You need to go to settings > connected services > Kasa Smart, and it’ll add them. Terrible job from Samsung and TP-link. No documentation on any of this stuff.

2 Likes

So. I was able to make the integration with the new app. However they don’t work on the classic App. Do you know if there is a fix for that? Tnx!

None known. The Official integration only works with the new app.

1 Like

Please dont give up on this. Their native integration is terrible, I can not get it to work with my Harmony Hub, I had uninstalled yours, and switched to native and it does not work. I keep getting 'no connection" to the items in harmony hub. But everything does work fine in the smart things app. But the harmony hub is why I bought a smartthings.

I will support and maintain this integration as long as needed; however, I do not plan on adding features. It will remain deprecated to encourage people to try the Kasa-developed integration so that user input can cause them to fix the problems.

Dave

I know this is deprecated so I’m not sure how much effort you’re willing to put in, but I’m having an issue getting my HS300 to work using your SmartApp. I have a KP200 and KP400 that are working great, and your integration through the classic app is much better than the official integration through the new app, so thank you for the great work you do!

For the HS300, when I go through your SmartApp to install, all 6 outlets show up there. I check the boxes next to all of them or I’ve tried each one individually, but when I hit Save in the top right corner, it takes me back to the main automation screen and doesn’t actually add the device to my devices list. When I installed the HS300 yesterday and set it up in the Kasa app, it said that there was a firmware update, and without thinking, I ran it. Perhaps there’s something that they changed in the most recent firmware that isn’t playing well with your SmartApp? I’m really looking forward to the energy monitoring capability of this device, so I’m hoping this is something simple to fix. Thank you for your time!

Go to My Devices and make sure the driver davegut : TP-Link Smart Energy Monitor Plug is installed. This is different than the driver for the KP200/400 since the HS300 supports energy monitor functions.

That is my best guess. Otherwise, I will need the logs from while installing.

Dave

So simple. Thanks for your help, that was exactly the issue. I can’t believe I overlooked this.

I would say a senior moment, but I am the senior.

1 Like

Hi, I’m having a bit of a issue with this I think. So recently someone said that Kasa now works on ST (but have to install on the classic ST, which then would add it to the new ST). So I wanted to have a look so installed it and all, and seemed all fine, but when clicking on said plugs they would switch on and off in seconds. So was only half baked, so I then decided to uninstall and carry on using what u have done which has worked floor less for me.

But now I have have a couple of issues, one of my plugs is not working on a routine I had set up before hand. When I go on to ST and theory and update token it just does nothing on the screen. When I go add devices I get the devices but they are names something totally different. I click them and press save and I get a message that comes up an unexpected error has occurred. So it won’t save it. The is all the same error when I try initial installing.

So I then thought I’d start from scratch again and remove it all and start clean but when I try and remove it from my automations it also comes up with a error on the app.
So went on IDE to try it that way. I try to uninstall the device handler and it comes up saying device type still in use. So I go to the SmartApp and try that way and it says in stall by one on more users (is it, where that then). So I then try deleting each device and then it does but then it still shows up in device list.

So I’m so confused. They still work but some not working for automation I had before had. Just want to remove it now and start again from the begging so it all works how it use to.

Any help would be great.

Some ideas to check.

a. Make sure the new “official” Kasa integration is uninstalled/disabled.
b. Run the Smart App for this integration. At the bottom of the page, select “Uninstall”. Then re-install everything.

Any other ideas from other users? Somehow skenny16 has put his integration in a very unusual state.