[DEPRECATED] - Hive (Connect) V2.6 (British Gas Hive)

It should appear under marketplace tab in the My Apps section if it published successfully.

The problem it is not showing up … just the other 2 apps ? Just did the copy paste save publish.


Just a quick question from a potential Hive Connect newbie!

I currently have a British Gas Hive system (new version) with thermostat, hub and lightbulb.

I would like to get a Smartthings hub and use this connect app to ‘open’ things up!

Just wondering this though…

I currently have Google Assistant on my Android phone and can currently control my Hive lightbulbs with Assistant. I notice that there is no support for the thermostat yet from Hive!

Will I still be able to be able to control my Hive lightbulbs with Google Assistant. Will I potentially also be able to control my thermostat with Google Assistant.

I also have a Hive Signal Booster. Will this work with Smartthings?



Hi guys,

Great work on this, got a quick question if anyones tried it, after adding the API’s and the handlers, I added my bulbs directly into smartthings then changed the device type to yours within the IDE. This worked great as didn’t have heating at the time and was able to unplug the hive hub.

Since I’ve had the heating and the hive hubs been back on, the hubs been unreliable to say the least, does anyone know if it’s possible to put the thermostats into pairing mode, pick them up in smartthings and use the custom API to get rid of the crappy hive hub completely?


I’ve picked up a strange bug - the Smartthings App seems to be an hour behind what the boiler is actually doing in terms of whether it is heating, and its target temperature. For example, if at 17:00 my target temperature changes from 15º to 20º, the boiler will kick in at 17:00 and start heating, but the Smartapp will show it as idle until 18:00. It will also show 15º as the target temperature until 18:00. The thermostat temperature is correctly reported. Any ideas?

I had a similar problem some time ago and it was actually due to the timezone on the mobile phone. Regardless of timing showing correctly on your device, please check the timezone and the associated settings carefully.

Thanks for the reply.

My phone is set to “Use network-provided time zone”, which has correctly auto-selected “GMT +01:00 British Summer Time”. Perhaps the Smartthings App is working to GMT not BST somehow? Although surely everyone in the UK would have this problem if so.

Not sure if anyone as picked up on this … but just installed a Hive Active bulb which in the Hive app works great, Dim’s correctly etc.

But in the ST app I can switch it on and off but cannot dim… there just isnt the option available. I have updated the DH to the latest one for both Active and tunable but still not working.

Have I missed something ? Gave up on getting the Hive motion sensors workign with ST so would liek to fix this

Actually I triple checked and I have got the same identical bug you reported.

Hey, did you find a solution to this problem? I’m having the same issue


Hi there I did get it to work … it was one of the settings on the dashboard when I was publishing the app. For the life of me I can’t remember what I did exactly not it was not the code

Hi Alex. Thanks for all your work on this, it’s made things so much better for me as I was getting very frustrated with Hive and Smartthings. I have a colour Hive light bulb and I’d love to help. Can’t DM you as I’m too new! If you want you can dm me.

Hi does the thermostat connect direct to smartthings?

New updated Hive app here with added support for Hive Coloured bulbs. [RELEASE] - Hive (Connect) V3.0 (British Gas Hive)

FYI, In the past 3 years, I have built the ScheduleTstatZones smartapp which allows you to create zones inside your home for more targeted heating/cooling.

In the ScheduleTstatZones smartapp, you can configure your rooms/zones/schedules. You then associate your zone/room thermostats to your zones and schedule your zones during the day.

In your home, you don’t always want to heat/cool all your rooms. In the evenings or at night for instance, you may want to direct more heat to your bedrooms.

The smartapp lets you choose a master thermostat which controls other slave (zone/room) thermostats in terms of mode and setpoints. The thermostats need to follow the ST standard capabilities.

You can also define enter some delta temp adjustments to make some specific zoned rooms cooler or hotter. You can also use your room’s motion sensor to take into account if the room is occupied or not. The occupied threshold can be defined on a room by room basis for more flexibility.

There are many other features, refer to the ST community wiki for more details:


And the following ST community thread:

You can download the code at my store.



Hi @Alyc100

I have a new Hive Hub and thermostat and a new SmartThings hub. I’m expecting these to be supported by your integration. I’m having a bit of trouble and wondered if you could help please?

I have installed the smartapp and authenticated. It finds my receiver but when I attempt to add it I see the following exception in logs when I hit Save:

error physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘Hive Heating’ in namespace ‘alyc100’ not found.
20:37:31: info Adding Hive Heating device d1c07f20-16d2-4983-a73e-50c9df50cbca: Receiver 1 Hive Heating
20:37:31: info Body: [[id:d1c07f20-16d2-4983-a73e-50c9df50cbca, lastSeen:1510172563045, created:1510148273137, sortOrder:1, state:[schedule:[wednesday:[[start:390, value:[target:20]], [start:510, value:[target:7]], [start:720, value:[target:7]], [start:840, value:[target:7]], [start:990, value:[target:20]], [start:1320, value:[target:7]]], thursday:[[start:390, value:[target:20]], [start:510, value:[target:7]], [start:720, value:[target:7]], [start:840, value:[target:7]], [start:990, value:[target:20]], [start:1320, value:[target:7]]], monday:[[start:390, value:[target:20]], [start:510, value:[target:7]], [start:720, value:[target:7]], [start:840, value:[target:7]], [start:990, value:[target:20]], [start:1320, value:[target:7]]], sunday:[[start:390, value:[target:20]], [start:510, value:[target:7]], [start:720, value:[target:7]], [start:840, value:[target:7]], [start:990, value:[target:20]], [start:1320, value:[target:7]]], saturday:[[start:390, value:[target:20]], [start:510, value:[target:7]], [start:720, value:[target:7]], [start:840, value:[target:7]], [start:990, value:[target:20]], [start:1320, value:[target:7]]], friday:[[start:390, value:[target:20]], [start:510, value:[target:7]], [start:720, value:[target:7]], [start:840, value:[target:7]], [start:990, value:[target:20]], [start:1320, value:[target:7]]], tuesday:[[start:390, value:[target:20]], [start:510, value:[target:7]], [start:720, value:[target:7]], [start:840, value:[target:7]], [start:990, value:[target:20]], [start:1320, value:[target:7]]]], frostProtection:7, name:Receiver 1, target:18, boost:null, mode:MANUAL], parent:f74d601c-5ca7-446b-b8fa-827bc4ea069e, type:heating, props:[pmz:OK, holidayMode:[enabled:false, start:null, end:null, temperature:7], model:SLR1, maxEvents:6, previous:[mode:OFF], scheduleOverride:false, capabilities:[BOOST, HOLIDAY_MODE, OPTIMUM_START], zone:f74d601c-5ca7-446b-b8fa-827bc4ea069e, temperature:18.46, version:00105700, online:true]]]
20:37:31: debug Beginning API GET: https://beekeeper-uk.hivehome.com:443/1.0/products, [authorization:]
20:37:31: debug isLoggedIn state
20:37:31: info Status: 200

I’m brand new to this (though I am a developer so feel free to talk tech at me) - is this something you have seen before and could help with, please?

Many thanks for the great public service.

Are you sure you have the Hive Heating device handler installed and published? The device handlers need to be installed alongside the smart app

I couldn’t locate the handler in github so guessed you had built the support into a single codebase. As per your instructions, I tried:


Please could you point me to the right location? Thanks!

Try the links here [RELEASE] - Hive (Connect) V3.0 (British Gas Hive)

As this topic is old I can’t relabel this one as deprecated as I no longer have edit rights

Ah, amazing! I didn’t see the later version. All up and running now - thank you @Alyc100