[DEPRECATED] - Hive (Connect) V2.6 (British Gas Hive)

I still experience the same 1-way communication issue.

I will wait for some other users to have a try too and see if they are having the same behaviour with the App. If not, there must be something my end that’s causing it.

Are you using Hive 1 or 2?

I have the Hive 2 system.Is it possible that my iOS being 8.3 causing this?

Can you go into Live Logging on the Smartthings IDE, and press a control button to see if there is any red exception item being created when you press?

d8138b93-7f9e-46e3-ae55-2972ef673bd8 17:35:41 GMT: debug Calling put : https://api.prod.bgchprod.info:443/omnia/nodes/ : [nodes:[[attributes:[activeHeatCoolMode:[targetValue:OFF]]]]]

d8138b93-7f9e-46e3-ae55-2972ef673bd8 17:35:41 GMT: debug [uri:https://api.prod.bgchprod.info:443/omnia/nodes/, contentType:application/json, headers:[Cookie:null, Content-Type:application/*+json, Accept:application/vnd.alertme.zoo-6.2+json, X-AlertMe-Client:smartthings, X-Omnia-Access-Token:afb71e29-7542-4e8d-9ee7-93156ca88eb9], body:[nodes:[[attributes:[activeHeatCoolMode:[targetValue:OFF]]]]]]

d8138b93-7f9e-46e3-ae55-2972ef673bd8 17:35:41 GMT: error groovyx.net.http.HttpResponseException: Method Not Allowed @ line 366

Also out of interest, do you have the same control issues with the Hot Water device type i just published?

I have a Combi so I have the Hive 2 that does heating only!

:fearful:

All errors are on line 366, for every button and slider…

That helps thanks. I will look into it over the weekend. Have access to another family member’s account too that appears to have the same error.

Thanks.

I am looking forward to your reply!

I’ve just installed this on my Hive 1 and it appears to be working… I can set temp, it kicks in if needed, an d reports the current temperature (albeit in a really small font)

FYI, I thought the difference between Hive1 and Hive2 was just the thermostat, Hive1 owners were given the option of upgrading for £99 and it was a self-install, no other changes needed.

Edit: Unless I’ve misunderstood what Hive 1 and Hive 2 are - I thought 1 was the “current” model until a couple of months ago, and 2 was the new square sexy thermostat.

Thanks for the feedback. Need as much as possible to work out who the controls are working for.

Concerning Hive 2, that’s what I thought too. But trying to find out if there’s something behind the scenes that change when you upgrade as Hive 2 will support zoning.

Also the other account I have access to is Hive 1 and is not allowing control from smartthings so wondered if there was a connection.

Have you tried the hive hot water device?

Also do you have the screenshot of the small font issue? Not seeing that on my iOS smartthings app.

OK. I have managed to get this working with a Hive 1 account. There seems to be some inconsistency between accounts around responses from the API. Hopefully the way I check whether I have the right receiver device is more universal. Let me know if controls now work. There is also a 4 second delay built in when pressing a control and updating the status on the device. This is to ensure Hive has time to process.

https://github.com/alyc100/SmartThingsPublic/blob/master/devicetypes/alyc100/hive-active-heating.src/hive-active-heating.groovy

Can I just copy and paste this code over the last one or do I have to remove and start from scratch?
I was just about to update you on what does and doesn’t work but I might as well test this one first!

Copy and pasting over the old code should work fine. Make sure you save and publish ‘for me’.

OK, so on my Hive 1:

Setting Schedule, Manual or Off works. I can set this in SmartThings, and if I go into the Hive app (and click Refresh in the top right corner) it shows the correct mode.
However, there’s no indication in ST of what the current mode is - is this correct?
Setting temperature works in ST, it’s mirrored to the Hive app as expected when I hit refresh. I assume it would refresh itself after so many minutes if I wasn’t being impatient and wanting to see if it works.

I’ve adjusted the temperature in the Hive app, I’m just waiting to see if it updates in the ST device eventually.
EDIT: I’ve just noticed if I scroll down, there’s a refresh button. And yes, hitting this does reflect the correct temp set on the Hive via the app or my thermostat.

The small font is still there, I’ve attached a screenshot.

This looks like differences between iOS and Android smartthings app. There should be a status on the top panel like in my screenshot above.

Will work on an option for android users to display status using tiles. Need help with testing this though.

More than happy to help you test if you need an Android guinea pig.

Out of interest, would it be possible to implement Boost?
The way the Hive app does it seems quite simple, it sets to 22 degrees for an hour. That’s it. It does have a countdown so I guess it must send a command that says “You’re in boost mode” rather than just setting a high temperature but that would be really handy.

I can confirm that after the last release I no longer get an error when viewing the live logs, and the controls do work!
(Active Heating 2, Heating Only Thermostat, Combi boiler)

The only thing I notice is that my Hive Schedule has a 7 degree setting with a snowflake symbol for the antifreeze-off time, and I always get 1 degree on your app. Refresh doesn’t alter the number 1 to a 7. Having said that, if I make that number to a 6.5 or 7.5 on the thermostat, I do get the correct number on the app.

It seems that the number 7 appears as 1?

Thanks for the feedback. That’s great news on the controls. The 1 degree value is coming from the Hive API when in frost protect mode. Looking into what can be done for this.

Yes, there is a boost command available on the API and it’s next on my TODO list.

1 Like