[DEPRECATED] - Hive (Connect) V2.6 (British Gas Hive)

Just wanted to say thank you Alex. I have just installed Hive 2 and then used your code from github to link to ST …works a treat.

Haven’t tried the new App yet as I was a little confused on how to do it and I wasn’t sure if it would screw up my existing setup.

Might try during the xmas break. Once again thanks

1 Like

Hello, I’ve installed everything as expected, but it never really worked. By that I mean it would say the heating is off, but when you check the Hive app, it would still be on. So i thought I’d check the SmartApp settings for Hive Connect and noticed “null” in the devices list. I now can’t save anything with an error saying “null is not allowed” - what can I do to remove null from my devices list please?

Here is the live log for adding the null device…

d7af57a5-8ae0-40bf-8d8a-a5bff5442dfb  12:09:04 PM: error grails.validation.ValidationException: Validation Error(s) occurred during save():
- Field error in object 'physicalgraph.device.Device' on field 'name': rejected value [null]; codes [physicalgraph.device.Device.name.nullable.error.physicalgraph.device.Device.name,physicalgraph.device.Device.name.nullable.error.name,physicalgraph.device.Device.name.nullable.error.java.lang.String,physicalgraph.device.Device.name.nullable.error,device.name.nullable.error.physicalgraph.device.Device.name,device.name.nullable.error.name,device.name.nullable.error.java.lang.String,device.name.nullable.error,physicalgraph.device.Device.name.nullable.physicalgraph.device.Device.name,physicalgraph.device.Device.name.nullable.name,physicalgraph.device.Device.name.nullable.java.lang.String,physicalgraph.device.Device.name.nullable,device.name.nullable.physicalgraph.device.Device.name,device.name.nullable.name,device.name.nullable.java.lang.String,device.name.nullable,nullable.physicalgraph.device.Device.name,nullable.name,nullable.java.lang.String,nullable]; arguments [name,class physicalgraph.device.Device]; default message [{0} cannot be null]
@ line 1046
d7af57a5-8ae0-40bf-8d8a-a5bff5442dfb  12:09:04 PM: debug getChildDevices(false), children=1
d7af57a5-8ae0-40bf-8d8a-a5bff5442dfb  12:09:04 PM: info Adding Hive Heating device 465ec8e3-f370-43ec-93e1-148fb1bdc0df: null
d7af57a5-8ae0-40bf-8d8a-a5bff5442dfb  12:09:04 PM: debug Identified: Receiver Hive Heating
d7af57a5-8ae0-40bf-8d8a-a5bff5442dfb  12:09:04 PM: debug Found Device: Receiver
d7af57a5-8ae0-40bf-8d8a-a5bff5442dfb  12:09:04 PM: debug Identified: Warm White Light Hive Light Dimmable
d7af57a5-8ae0-40bf-8d8a-a5bff5442dfb  12:09:04 PM: info Body: [nodes:[[createdOn:1482245978294, id:1c7797a7-e44a-4b13-9e4f-1e1bb3316328, lastSeen:1483099708005, parentNodeId:8958c308-a33e-437e-b237-9831de542f49, ownerId:e72b66ad-ee3e-4fbb-a420-a8a8c2e0449d, userId:e72b66ad-ee3e-4fbb-a420-a8a8c2e0449d, name:Warm White Light, links:[:], attributes:[zigBeeNeighbourTable:[reportChangedTime:1483097468466, reportedValue:[[relationship:NONE, deviceType:DEVICE, neighbourAddress:::21e:5e09:20d:537a, LQI:16], [relationship:NONE, deviceType:COORDINATOR, neighbourAddress:::21c:2bff:fe09:f534, LQI:30]], reportReceivedTime:1483097468466, displayValue:[[relationship:NONE, deviceType:DEVICE, neighbourAddress:::21e:5e09:20d:537a, LQI:16], [relationship:NONE, deviceType:COORDINATOR, neighbourAddress:::21c:2bff:fe09:f534, LQI:30]]], lastSeen:[reportChangedTime:1483098663076, reportedValue:2016-12-30T11:50:28.782+0000, reportReceivedTime:1483098663076, displayValue:2016-12-30T11:50:28.782+0000], model:[reportChangedTime:1482245978244, reportedValue:FWBulb01, reportReceivedTime:1483098663076,...[TRUNCATED]
d7af57a5-8ae0-40bf-8d8a-a5bff5442dfb  12:09:04 PM: debug Beginning API GET: https://api-prod.bgchprod.info:443/omnia/nodes, [Cookie:null, Content-Type:application/*+json, Accept:application/vnd.alertme.zoo-6.2+json, X-AlertMe-Client:Hive Web Dashboard, X-Omnia-Access-Token:BP1oCvcDIJRVT0ceI2O6otC4wzs48Y81]

Thanks

Hi All.

I’m new to ST after getting a starter kit for Christmas.

I have a Hive bulb, but no Hive hub. I can see the bulb in ST, and it works if I set it to be a Zigbee Dimmer.

I have added the code above for the hub and also the bulb into IDE. However, if I edit the bulb to Hive Active Light, I can no longer control it.

Any ideas? Do I have to have a Hive Hub to control the bulb?

James

Hi I have done the code but I can’t seem to find it in the app?

How did you get it to log you in. I am having the same problem

@Alyc100 just wanted to say huge thank you for the Nest DTH code. I’d been humming and harring over nest V hive for a few weeks and after reading this thread and looking at the work you’d done finally decided to order hive. Installed it all on new year’s Eve without any issues at all and delighted with it so far.

Also installed Google sheets logging, (Log events to Google Sheets [see post 154 for current Github repo and v1.1]) if anyone is interested, and have all temperatures, set points and Hive status being logged to a spreadsheet so in a couple of weeks when I have some good data I can really start to make Smartthings earn it’s keep :blush:

Without this community, and people like you Alex, Smartthings would really be dumb things :+1:

2 Likes

@Alyc100, Thanks for creating Hive compatibility for Smarthings. I just got my smarthings and successfully installed hive connect smart app and hive hot water device handler as per the instructions. Once I logged in with my hive credentials from the smartthings app, I am able to see the Hive heating device, but it is always set to IDLE. I get the grey with current room temperature shown. None of the buttons work. Can you please help me fix this issue?

I have resolved my problem. Strangely my hub seemed to lost connection to the internet. I have done multiple restarts and it didn’t gain connectivity. I restarted my modem and router and then started the hub and magically, it started working. Now I can control Hive heating from smartthings.

I’m glad you managed to resolve the issue.

Just want to re ask an old question, does anyone know why the hive thermostat doesn’t translate over to Alexa as a smart device. Plugs and lights do fine, but the thermostats don’t unfortunately, any pointers? Thanks all.

I’m not seeing this option in the SmartThings app? Am I looking in the wrong place?

Needs to be added via the SmartThings IDE and not the mobile app. Login here --> https://graph-eu01-euwest1.api.smartthings.com

I’m trying to add the hive heating code and I get an error

No signature of method: script14838226073561686356828.metadata() is applicable for argument types: (script14838226073561686356828$_run_closure2) values: [script14838226073561686356828$_run_closure2@6a59c8c4]
Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

Did you work this problem out?

No luck as yet. Are you having the same problem?

Yes I’m unable to to add the code for the heating and the hot water.

Hi there. Just to cover this possibility off, make sure you’re reading the installation guide carefully and make sure your putting the Hive(Connect) code under as a new ‘My SmartApps’ and the Hive Heating and Hive Hot Water code as a new ‘My Device Handlers’ within the SmartThings web IDE.

That’s the problem cheers for that, my mistake

I’d like to know as well, it used to work before the Hive ‘Skill’ came out - but the actual Skill doesnt work for me.

I’m going to look at making another simulated thermostat and link the two together so Alexa picks up the fake and the fake Updates Hive…not a clue if that’ll work yet

Kraeg

@Alyc100 Any plans to add readings from the British Gas smart meter (zigbee)? Many thanks