SmartThings Community

[DEPRECATED] Free Ecobee Suite, Version 1.2.*


(Ricci Hoffer) #21

I just updated this morning and now the thermostat reading is blank on the thermostats device page and the arrows to change the temp no longer work. Updated all from Github. All the other buttons seem to work on the Device page.

![Screenshot_2017-08-14-11-53-58|312x500]


(Barry) #22

What version where you running prior?

The updated DTH won’t let you make many changes when in certain situations - like while the thermostat is Off (as it appears to be from the screenshot).I suspect that the DTH is not in sync with the DTH (it says its Off, but also in a Temperature Hold - that shouldn’t happen).

I suggest you try hitting “Resume” to resume the default program. Then try hitting Refresh, wait until the Bee icon reappears and then immediately hit it again - this should reset everything back to the known condition.

Once you get back to the colored multiTile, try the temp buttons again. If they still don’t work, try the sliders.

Let me know how the above works out…I’ll standby for your updates…


(Ricci Hoffer) #23

Thanks, that worked to sync everything back up. The temp hold is gone, temp reading and arrows are working with no errors in the logs. I was up to date until I went out of town on the 4th.


(Barry) #24

Most excellent - glad to hear you are back on-line…


(Fernando Fuentes) #25

@storageanarchy Thank you for this awesome app. Working ok so far here.
Question: Under My Home The EcoTherm and Sensor Show no icons, Just default gray. Is this normal?
Also the "Out: 0 " I imagine that’s outside temperature? Its stuck in 0. No idea why.
Ideas?

Thanks for your help!


(Barry) #26

Glad you like it!

Icons: It appears that something recently changed in SmartThings and the default icon for a temperature device isn’t being displayed. You can solve this by selecting an icon for each of the devices (the deefault thermometer is un the Weather section). I don’t set this as the default in the code because it forces the temperature to be displayed in Small Font when you set the thermostat as the favorite device in a room.

Out 0: This is possibly because you did not set a location zip code for your thermostat. You can set this in the Ecobee WebApp (Settings/Location). This is usually prompted for at the initial setup.

Please let me know if the above addresses your issues…


(Fernando Fuentes) #27

@storageanarchy, Thanks for your reply. I guess I was not been patiance… Eventually the outside temp updated. About the icons though… They wont update. No matter what icon I choose, Once I hit done the app wont update the icon.


(Jeff DeWolfe) #28

I’m seeing an error on my setup. I just updated the Connect app to 1.2.4, it was at 1.2.3. When looking at the thermostat in SmartThings, it doesn’t show the last poll time. The error from the console is:

9:25:32 AM: error java.lang.NullPointerException: Cannot invoke method contains() on null object @ line 887
9:25:23 AM: trace Ecobee Thermostat version 1.2.3 updated

Let me know if I can provide any other details!

Thanks,
Jeff


(Barry) #29

Thanks for the report…

Quick fix - replace line 887 in Ecobee Thermostat to:

 if (currentProgram?.contains('acation')) updateModeButtons() 	// turn the mode buttons back on if we just exited a Vacation Hold

(add ? at end of currentProgram)

Let me know if that solves it for you…


(Barry) #30

UPDATE: Ecobee (Connect) v1.2.5 & Ecobee Thermostat v1.2.4

Changes:

  • Ecobee (Connect): Cleaned up and optimized OAuth initialization error handling, with clearer Live Logging information.

  • Ecobee Thermostat: Fixed a bug that could throw an error when programs/climates change (especially during initial install).

Both are minor updates that shouldn’t effect anyone already running; these issues should only occur during initial installation.


(Jeff DeWolfe) #31

That fixed it, thank you!


(Fernando Fuentes) #32

The update fix the icon issue as well.
BUT I have my Sensor listed separate, It cant get an icon update and has the same issue as before :slight_smile:
Thanks in advance!
This app is amazing!


(Barry) #34

UPDATE: Ecobee Thermostat v1.2.5 & Ecobee Sensor v1.2.1

Changes:

  • Reinstated the default icon for both Thermostat and Sensor devices (sorry - my bad, I had accidentally disabled it in the production version while I was trying to debug something).

(Scott) #35

Great job. Really like the look of this app. I don’t have anything else to test with but unfortunately I don’t think it works that well with the SI’s that I have.


(Barry) #36

???

Can you describe what doesn’t work for me?

Although it looks different than the SI UI, the API is the same and the operation should not be impacted.


(Scott) #37

Hey, sorry that was a less than hopeful post on my part. I was getting a lot of 0’s and blank icons. I’ve since spent some more time reading this thread and it may just have been a patience thing. I’ll set it up and give it another shot tomorrow.


(Tim) #38

Hmm… the device handlers don’t show when adding from repo but the smart apps do… ???
Smart app:

Handler:


(Barry) #39

Works for me on the original shard (https://graph.api.smartthings.com/ide/devices), but not on https://graph-na04-useast2.api.smartthings.com/ide/devices .

Send a report to SmartThings support…


(Tim) #40

Thanks for verifying. I will contact support.


(Jacob Trocano) #41

storageanarchy im trying to setup open contacts and im currently getting this error java.lang.NullPointerException: Cannot invoke method LOG() on null object @ line 378

any suggestions on what i might be doing wrong?