SmartThings Community

[DEPRECATED] Free Ecobee Suite, Version 1.2.*


(Barry) #94

@surge919 -

Ecobee Thermostat version 1.2.8 just posted to the GitHub will fix the issue.

FYI, the error did not effect the changing of the temperature setpoints, only the immediate update of the current setpoint, which will be automatically corrected on the next update from the Ecobee Cloud.

Thanks @ffuentes, my family, friends, neighbors and our property survived the storm well…


#95

Is there a way to include additional non-ecobee motion/thermostat sensors or only ecobee sensors are allowed?


(Barry) #96

At present, my implementation does not allow you to incorporate non-Ecobee sensors into the Ecobee heating/cooling setpoint targets.

While not impossible, it requires replicating much of the logic already built into the thermostat to figure out what the target temperature at the thermostat needs to be in order to get all the registered sensors to average out to a specific target. And since there is no way to control the actual temperature displayed on the thermostat (which is currently the current average of the dependent sensors), any solution will introduce inconsistencies between what is displayed on the thermostat, within SmartThings, and the actual temperatures being averaged.

Since Yves’ My Ecobee Device does already provide this option (with all its warts), I’m not planning to invest to do the same. It would probably require minimal edits to my Ecobee Suite to allow his automation SmartApp to control my thermostat devices, but that’s probably not something he would like for anyone to actually do (although he has posted the SmartApps as “free”, while his My Ecobee Device requires a mandatory ‘contribution’ to get access to it).


#97

I’ve updated and I’m no longer seeing that error. thx

A couple of more questions

I don’t know when it happened, but I noticed that when I attempt to set the temp using the main arrows, it returns the following:

12:27:48 AM: warn setTemperature(): this mode: mode does not allow raiseSetpoint

Has it always done this?

And I don’t know if it’s related, but normally I would set my thermostat to Auto mode and set a range… ie: 74 to 68
I would then be able to change the temp via Google Home by saying, “Hey Google, set the bedroom to 72 degrees”

It worked fine since day 1, but I just noticed within the last few days (I was out of town for about 3 weeks) that it no longer works.

Google Home (and Google Assistant - from the phone) now responds with “The Eco Therm: Bedroom can’t be set to that temperature”

Any ideas?

thanks


(Barry) #98

@surge919 -

If your thermostat is is Auto mode, and you aren’t using SmartAuto (set in Ecobee (Connect) Preferences), then we don’t know which temperature you are trying to change (heating or cooling).

If you enable Smart Auto, then it will change the cooling setpoint if the requested setpoint is below the current temperature, and it will increase the heating setpoint if the request is higher than the current temperature. Thus I think you’ll get what you want if you enable Smart Auto in Preferences.


(Barry) #99

UPDATE: Ecobee Thermostat v1.2.9, Ecobee Sensor v1.2.2 & Ecobee (Connect) 1.2.6

Changes:

  • Repaired addSensorToProgram() and deleteSensorFromProgram()
  • Added icons for new hold modes to Sensor device
  • Added ‘Wakeup’ as synonym for ‘Awake’ program

These updated files can be installed on top of the previous version.


#100

I lost power for a few days after Hurricane Irma and when it came back, seemed to take care of my issues. However, now they’re back. It seems like the app can’t or won’t make changes to the thermostat. It reads things fine, but I can’t change the temp manually or through routines. For example, when I leave and the Goodbye routine runs, the ST mode is changed to Away and thermostat is set to 85. The latter doesn’t happen though. I can’t change anything from the app itself, just view the current settings. I’ve tried logging in and out of Ecobee Connect multiple times and it shows that it’s connected to ST in the log, but just refuses to make any changes.


(Barry) #101

Bummer!

Let’s see if we can’t track down the problem.

Let’s start with versions: what are the version numbers of ALL you SmartApps and Devices? You can find the version at the bottom of each SmartApp and at the top of preferences for the devices

Thanks!
Barry


#102

Ok, see below for the ones I’m using:

SmartApps-
Ecobee Connect: 1.2.6
Smart Circulation: 1.2.0
Open Contacts: 1.2.2

Device Handlers-
Ecobee Thermostat: 1.2.9
Ecobee Sensor: 1.2.2

Thanks!


(Barry) #103

OK, so is your thermostat perhaps in a Hold or a Vacation when you are trying to adjust the temperature?

If so, I may have been over-aggressive in prohibiting changes while in a Hold…for at least certain cases, I guess I should clear the old hold and create a new one…let me look at that.

Meanwhile, if you hit “resume” first, you can then change the setpoints.


(Barry) #104

UPDATE: Ecobee Thermostat v1.2.10 & Ecobee (Connect) 1.2.7

Changes:

  • Allow changing setpoints and Holds on top of currently running Hold: or Auto programs (resumes current program, then sets a new Hold)
  • Fixed error message in thermostat device

These updated files can be installed on top of the previous version.
[/quote]


#105

It’s definitely not in vacation mode but on the Ecobee itself it’s in a hold. I don’t use the built-in Ecobee programs. In ST in the app it has Hold: Temp and in the settings for hold type and hourly hold it’s the default: Ecobee Connect settings which is hold until I change. I don’t see a setting for the hourly hold. Here’s a screenshot of the thermostat settings in ST:


(Barry) #106

Get the latest version of Ecobee (Connect) that I just posted - that should solve the problem. Installing the thermostat device is optional - just fixed the error message…


(John) #107

Thank you! For quite awhile now I have had to use the Ecobee app to make slight temperature changes because the slider in ST stopped working for me. I just blamed it on my setup.


(Barry) #108

Nope - it was my fault. Sorry for the added level of hassle you had to deal with…


(John) #109

No need for an apology! Your Ecobee app has made managing my thermostat and home environment a pleasure.


#110

That fixed it! Working great now. Thanks!


(Jon Paterson) #111

I am also having the problem with Google home being unable to set temperature - I have also enabled smart auto temp as requested. The version I see in GitHub is 1.2.7 - where can I find the 1.2.8 version?

Second question - is it possible to remove / change the “ecothem” text prior to the name of the thermostat?


(Barry) #112

1.2.7 is the latest release.

You can change the name of the devices to anything you would like in SmartThings using the gear icon.

If you can give me a little more detail about the problem you are having, and the version of both Ecobee (Connect) and the Ecobee Thermostat devices, I will take a look.


(Jon Paterson) #113

HI Barry, the problem I have is exactly the same as Surge919 has - Google Home cannot set temperatures.

I am pulling from Github so:
Connect is 1.2.7
Device handlers:
sensor is 1.2.2
Thermostat is 1.2.10