SmartThings Community

[DEPRECATED] Free Ecobee Suite, Version 1.2.*


(Jeff DeWolfe) #28

I’m seeing an error on my setup. I just updated the Connect app to 1.2.4, it was at 1.2.3. When looking at the thermostat in SmartThings, it doesn’t show the last poll time. The error from the console is:

9:25:32 AM: error java.lang.NullPointerException: Cannot invoke method contains() on null object @ line 887
9:25:23 AM: trace Ecobee Thermostat version 1.2.3 updated

Let me know if I can provide any other details!

Thanks,
Jeff


(Barry) #29

Thanks for the report…

Quick fix - replace line 887 in Ecobee Thermostat to:

 if (currentProgram?.contains('acation')) updateModeButtons() 	// turn the mode buttons back on if we just exited a Vacation Hold

(add ? at end of currentProgram)

Let me know if that solves it for you…


(Barry) #30

UPDATE: Ecobee (Connect) v1.2.5 & Ecobee Thermostat v1.2.4

Changes:

  • Ecobee (Connect): Cleaned up and optimized OAuth initialization error handling, with clearer Live Logging information.

  • Ecobee Thermostat: Fixed a bug that could throw an error when programs/climates change (especially during initial install).

Both are minor updates that shouldn’t effect anyone already running; these issues should only occur during initial installation.


(Jeff DeWolfe) #31

That fixed it, thank you!


(Fernando Fuentes) #32

The update fix the icon issue as well.
BUT I have my Sensor listed separate, It cant get an icon update and has the same issue as before :slight_smile:
Thanks in advance!
This app is amazing!


(Barry) #34

UPDATE: Ecobee Thermostat v1.2.5 & Ecobee Sensor v1.2.1

Changes:

  • Reinstated the default icon for both Thermostat and Sensor devices (sorry - my bad, I had accidentally disabled it in the production version while I was trying to debug something).

(Scott) #35

Great job. Really like the look of this app. I don’t have anything else to test with but unfortunately I don’t think it works that well with the SI’s that I have.


(Barry) #36

???

Can you describe what doesn’t work for me?

Although it looks different than the SI UI, the API is the same and the operation should not be impacted.


(Scott) #37

Hey, sorry that was a less than hopeful post on my part. I was getting a lot of 0’s and blank icons. I’ve since spent some more time reading this thread and it may just have been a patience thing. I’ll set it up and give it another shot tomorrow.


(Tim) #38

Hmm… the device handlers don’t show when adding from repo but the smart apps do… ???
Smart app:

Handler:


(Barry) #39

Works for me on the original shard (https://graph.api.smartthings.com/ide/devices), but not on https://graph-na04-useast2.api.smartthings.com/ide/devices .

Send a report to SmartThings support…


(Tim) #40

Thanks for verifying. I will contact support.


(Jacob Trocano) #41

storageanarchy im trying to setup open contacts and im currently getting this error java.lang.NullPointerException: Cannot invoke method LOG() on null object @ line 378

any suggestions on what i might be doing wrong?


(Barry) #42

I can’t reproduce it, but can you tell me what you where configuring (switch or contact, etc.)?

also, if you move line 379 to be before line 378, you should get the actual error logged in Live Logging for the device - that might help understand what’s going on…


(Barry) #43

Are you perchance trying to create this directly from the ST MarketPlace/SmartApps?

All of the Helper SmartApps in this suite MUST be created from within Ecobee (Connect), because they operate as children to that app. You can’t create them outside of Ecobee (Connect).

Thanks!
Barry


(Fernando Fuentes) #44

@storageanarchy,

I moved from using a nest to an ecobee… I am having a bit of a hard time trying to do some things that I use to do easily with the nest… IE: How can I just turn on the Fan for 2hrs? Or how can I tell the ecobee that if is over 82F in my house to turn on and keep the AC at 78 even when away…?

TIA!


(Barry) #45

Using my Ecobee Suite, set the default hold time to 2 Hours (in Ecobee (Connect) or in the Device Handler). Then click the fan button to “On”. This will create a 2-hour hold with the fan on.

Not sure what you want here - why don’t you just set the Away program to 78?

Or if you want to wait until the temperature hits 82 before cooling to 78, you can set the Cooling Delta to 4+ degrees (you have to set this on the thermostat preferences), and the cooling temperature to 78. This will wait until the temp hits 82, then cool to 78, and turn off again, until the temp hits 82 again.


(Jeff DeWolfe) #46

Mine did the same, so I manually copied/pasted all of the code in. Let me know if support helps you out!


(Tim) #47

@chevyman142000 Will do!


(Tim) #48

@chevyman142000 not looking very promising…

Hello Tim,

Thank you for reaching out to us here at SmartThings. Sorry you are having some trouble on your end.

One of my Leads checked into this as we don’t usually provide support on Custom Integrations & Custom Device Handlers and I apologize.

That said, they checked both shards and it worked.

You could try deleting/unlinking Repo and you may have luck that way.

Also, I am sure you are familiar with it but perhaps check our Community for a lot of great help and tips on Custom things.

Please do reach back out if you have other questions or concerns and we will do our best to assist.

Kindest regards

So it would seem they are punting here. Bummer, because I can’t manage copy and pasting code especially with fresh development that is getting frequent updates <(sigh)>.