SmartThings Community

[DEPRECATED] Free Ecobee Suite, Version 1.2.*


(Barry) #99

UPDATE: Ecobee Thermostat v1.2.9, Ecobee Sensor v1.2.2 & Ecobee (Connect) 1.2.6

Changes:

  • Repaired addSensorToProgram() and deleteSensorFromProgram()
  • Added icons for new hold modes to Sensor device
  • Added ‘Wakeup’ as synonym for ‘Awake’ program

These updated files can be installed on top of the previous version.


#100

I lost power for a few days after Hurricane Irma and when it came back, seemed to take care of my issues. However, now they’re back. It seems like the app can’t or won’t make changes to the thermostat. It reads things fine, but I can’t change the temp manually or through routines. For example, when I leave and the Goodbye routine runs, the ST mode is changed to Away and thermostat is set to 85. The latter doesn’t happen though. I can’t change anything from the app itself, just view the current settings. I’ve tried logging in and out of Ecobee Connect multiple times and it shows that it’s connected to ST in the log, but just refuses to make any changes.


(Barry) #101

Bummer!

Let’s see if we can’t track down the problem.

Let’s start with versions: what are the version numbers of ALL you SmartApps and Devices? You can find the version at the bottom of each SmartApp and at the top of preferences for the devices

Thanks!
Barry


#102

Ok, see below for the ones I’m using:

SmartApps-
Ecobee Connect: 1.2.6
Smart Circulation: 1.2.0
Open Contacts: 1.2.2

Device Handlers-
Ecobee Thermostat: 1.2.9
Ecobee Sensor: 1.2.2

Thanks!


(Barry) #103

OK, so is your thermostat perhaps in a Hold or a Vacation when you are trying to adjust the temperature?

If so, I may have been over-aggressive in prohibiting changes while in a Hold…for at least certain cases, I guess I should clear the old hold and create a new one…let me look at that.

Meanwhile, if you hit “resume” first, you can then change the setpoints.


(Barry) #104

UPDATE: Ecobee Thermostat v1.2.10 & Ecobee (Connect) 1.2.7

Changes:

  • Allow changing setpoints and Holds on top of currently running Hold: or Auto programs (resumes current program, then sets a new Hold)
  • Fixed error message in thermostat device

These updated files can be installed on top of the previous version.
[/quote]


#105

It’s definitely not in vacation mode but on the Ecobee itself it’s in a hold. I don’t use the built-in Ecobee programs. In ST in the app it has Hold: Temp and in the settings for hold type and hourly hold it’s the default: Ecobee Connect settings which is hold until I change. I don’t see a setting for the hourly hold. Here’s a screenshot of the thermostat settings in ST:


(Barry) #106

Get the latest version of Ecobee (Connect) that I just posted - that should solve the problem. Installing the thermostat device is optional - just fixed the error message…


(John) #107

Thank you! For quite awhile now I have had to use the Ecobee app to make slight temperature changes because the slider in ST stopped working for me. I just blamed it on my setup.


(Barry) #108

Nope - it was my fault. Sorry for the added level of hassle you had to deal with…


(John) #109

No need for an apology! Your Ecobee app has made managing my thermostat and home environment a pleasure.


#110

That fixed it! Working great now. Thanks!


(Jon Paterson) #111

I am also having the problem with Google home being unable to set temperature - I have also enabled smart auto temp as requested. The version I see in GitHub is 1.2.7 - where can I find the 1.2.8 version?

Second question - is it possible to remove / change the “ecothem” text prior to the name of the thermostat?


(Barry) #112

1.2.7 is the latest release.

You can change the name of the devices to anything you would like in SmartThings using the gear icon.

If you can give me a little more detail about the problem you are having, and the version of both Ecobee (Connect) and the Ecobee Thermostat devices, I will take a look.


(Jon Paterson) #113

HI Barry, the problem I have is exactly the same as Surge919 has - Google Home cannot set temperatures.

I am pulling from Github so:
Connect is 1.2.7
Device handlers:
sensor is 1.2.2
Thermostat is 1.2.10


(Barry) #114

Please check that the version of the SmatApps and devices are the same as reports when you run the smartapp or click the gear for device settings.

And what specifically is the voice command you are giving to Google? How recently did this problem show up?

(I have to apologize, I don’t use Google - I’m an Alexa user. So anything you can get me from log files - ideally the device logs while you have set the Loggin level to 5 - will help).

Thanks!


#115

I have the 1.2.7 Connect and 1.2.2 DH. I just noticed that my ecobee sensors seem to be stuck at 80+ degrees when reporting to ST, the ecobee app reports much lower temps.


(Barry) #116

Re-login to the Ecobee servers, and they should get updated correctly.


(John) #117

@storageanarchy I’ve been running your DTH and apps for 8 months or so and just started having a problem with mode changes. I’m using the mode handler and have a home-day mode in ST that is paired with a home-day mode in Ecobee. In Ecobee Connect I have those mapped out as well.

This morning my mode changed to home-day from morning and the sleep mode is stuck on in my thermostat. I tried changing the mode to home-day again but I can’t get out of sleep mode.

Any ideas?


(Barry) #118

Same suggestion - re-login to Ecobee account from Ecobee (Connect) - even if it says you are already connected. I noticed some glitch yesterday that messed up the states being sent by Ecobee. Logging in again fixed it for me.

Let me know if that doesn’t work.

Thanks!
Barry