[DEPRECATED] Ecobee DTH and Helper SmartApps

iOS or Android?

What (if anything) shows up in Live Logging for Ecobee Routines when you get this error?

Thanks!
Barry

Also, are you sure you installed my updated versions of Everything??

Thanks!
Barry

I had a similar issue. My current climate never showed correctly after using resume program.

This seems to have fixed it for me. Thanks!

I will remove everything and try again. I did that to make sure all was your code, or at least I think. Now I did have to use manual code for the smart apps as I didnt see either (connect and routines) I saw the other child apps listed in the gitub. I did use github for the handlers though.

Android btw.

SOunds like you need to double-check your SmartApps integration with my GitHub - maybe a typo in the name or branch…my SmartApps should definitely show up in the IDE if configured correctly…

If you installed v1.0.6 of ecobee Thermostat, please update to v1.0.6a - a minor typo caused a silent failure…

Resume is now working as it should for me as well as the value shown in CoRE for the t-stat’s temp sensor shows with 1 decimal place.

Thanks for the fixes.

1 Like

I just updated Ecobee (Connect) version 1.0.11 to automatically create a vacation template if one does not already exist.

This should fix the issues with climates/programs not showing properly after resumeProgram.

1 Like

Removed everything again and reinstalled, everything is working now. I did see the SmartApps in the GitHub today. Thanks.

1 Like

Awesome, glad to hear it is working for you!

Recent updates:

  • Improved reliability of Health Check to not mark Thermostat or Sensors off-line if the data hasn’t changed in a while. Changes to ecobee-connect.groovy, ecobee-thermostat.groovy and ecobee-sensor.groovy

  • Added new Smart Vents Helper SmartApp (ecobee-smart-vents.groovy). This will open and close 1 or more SmartThings-controlled HVAC vents (e.g. EcoNet or Keene) when the room temperature is above/below the cooling/heating setpoints, either manually specified or as specified by the controlling thermostat. Will average multiple temperature sensors, implements minimal vent closure percentage, and will close the vent(s) if any specified (optional) windows/contact sensors are opened.

Hi Barry,

Just a question: Would be possible to have external Temperature / humidity sensors working together with Ecobee? I mean not the official external Ecobee sensors. would be? thanks!!

While possible, my DTH does not currently support this functionality. I may add support for this in the future.

Thanks! I think that will be great if you have the chance to add it. Anyway thank you for your great work with the app!

Barry,

Thanks for continuing development on the Ecobee Integration. I just deleted the old Stryker version from my IDE and installed your updated version. When the SmartApp attempts to conduct a thermostat mode change, I am getting the following error in LiveLogs:

6:46:32 PM: error java.lang.IllegalArgumentException: The JSON input text should neither be null nor empty. @ line 1159

And the thermostat does not change mode. Any thoughts?

Thank you again.

CS

The error seems to indicate a code mismatch - I think maybe you are running (uniintentially) mixed code.

Please double check that you have installed ALL of my updated code modules - Ecobee (Connect), Ecobee Thermostat and Ecobee Sensor.

If that doesn’t solve it, you may need to delete everything, uninstall both the devices and the SmartApp, and start all over. Most seem to be able to avoid that, so please let me know if this solves your problem…

Thanks,
Barry

Thanks Barry,

Will try tomorrow night and report back.

Cs

Barry,

I deleted everything and started over and it works great now. Thanks!

1 Like

Ok. So, as a person waiting on my new keen home vents, I’m interested in the smart vent helper smart app. The thing is, even though I have the smartapp installed, it isn’t showing up within the ecobee connect smart app as an available option for helpers.

Did you also update Ecobee (Connect) SmartApp? Both must be installed in order to the Smart Vents to show up…