[DEPRECATED] Ecobee DTH and Helper SmartApps

Current thread is over here.

I’m having trouble setting this up. I’ve connected to ecobee via smartthings app but when i go to save it comes back error saving page(via android) and an unexpected error(via ios).
I’m in ireland and not sure if this could be an issue.
The live logging is showing this.
491d054e-515b-4745-b381-a39e96eac683 7:43:47 PM: error java.lang.NullPointerException: Cannot invoke method format() on null object
491d054e-515b-4745-b381-a39e96eac683 7:37:30 PM: error java.lang.NullPointerException: Cannot invoke method format() on null object
491d054e-515b-4745-b381-a39e96eac683 7:36:48 PM: error java.lang.NullPointerException: Cannot invoke method format() on null object

Could you perhaps PM me the details of where in the installation steps this is happening, and for which smartapp or dth you are seeing these logged errors? The more details you can provide, the better.

Thanks!

@storageanarchy
Hi, I’m currently using your DTH and Ecobee(Connect) SmartApp. I also setup a Routine Handler SmartApp that is supposed to Resume Program when the Goodbye routine runs.
I am also using the Ecobee’s Smart Home/Away functionality.

If someone is home during a normally scheduled Ecobee Away period, then the Ecobee sets itself to Home because of Smart Home/Away. When that person leaves and the Goodbye routine runs, I would expect the Resume Program to set the mode to Away. However, the Ecobee stays in Home mode, and in the Notifications I see

“I was asked to Resume Program on EcoTherm: My ecobee, but there is no Hold currently active”

Am I using the Routine Handler correctly? Should I instead force Away instead of Resume Program?

Yes, I suggest you specify the program you want (Away). If the thermostat is already in a hold (of any sort), changing the program will first resume the scheduled program, and then set the newly requested hold (unless the resume gets you back to the requested hold).

Hopefully that makes sense…

Hi Barry, so I had setup a Smart Circulation App, went into and changed the min and max circulation time to 55 min. It gave an error when I attempted to save. After that it give me a something’s wrong within Smartthings when trying to access the app. Only option is to retry which doesn’t do anything. However that Smart Circulation setting is now continually being used… Is there another way to delete it other than in the app? Using Android Smartthings App, and Ecobee Connect version 1.2.12

Hmm…yopu might try using a max of 55 and a min of 54.

But if you delete the Circulation Helper app, you can reset the circulation time at the thermostat (or via the Ecobee app/web site).

When you say "The first step is to ensure that you delete any existing Ecobee related devices and SmartApps that you may have from other sources. " Does the actual Ecobee association with ST need to be deleted or can I just change the Original DTH to the New DTH.

If you are using the SmartThings-supplied version, unfortunately you will have to completely remove the devices and the Ecobee (Connect) smartapp before installing my Suite.

The ST version Ecobee (Connect) does not work with the version of the DTH in my Suite.

Note that also you will need to install ALL of the SmartApps and both DTHs provided in my Suite in your IDE for this to work.

Thanks!
Barry

1 Like

Barry, how do I delete it easily? I can’t delete it in the app.

Ryan

Barry, i’m using your version of ecobee, but I can’t delete the bad circulation instance as something is corrupted as I cant access it in the smartthings app. Do I need to start over and delete everything or can i delete just the smart circulation app only?

Ryan

First, thank you for writing this app – it looks like what I need!

My goal is to use auto circulate to run the blower motor on the furnace if the temp differential exceeds 4 degrees. Once the temp differential drops below 3 degrees, I want to stop running the blower motor.

To test I am using a threshold of 2.5 degrees to start the blower motor. The delta right now is at least 5 degrees.

I don’t think it is working as expected. Here are my settings:

  1. All sensors are included (4 total)
  2. Temp delta = 2.5 degrees (I assume this is “F” since my thermostat is set to “F”, not “C”)
  3. Min fan time = 0
  4. Max fan time = 55
  5. Mins per adjustment = 20
  6. Time adjustment freq = 5
  7. Only when mode is heat, auto or cool
  8. Only when thermostat program is (I chose my 3 daytime settings)

Any suggestions would be greatly appreciated!

I am new to this stuff - is there an easy way for me to access diagnostic logs?

Marc

If you created it using the app (the only way you SHOULD create instances of the helper apps), you should be able to delete it from the app.

If not, try from the IDE. Select Locations from the main IDE screen, then SmartApps from the table. From there, Click Edit, and scroll down to delete the helper smartApp.

Thanks!
Barry

Marc,

It may take a few minutes before the ecobee decides to run the fan after the app changes the “minimum fan on time” - it will try to spread the time equally across the hour. And note that whatever time the fan runs while heating will count towards this total fan on time per hear.

You can check the thermostat status screen to see what the setting is and if it is changing.

Barry, thank you very much for the quick response.

It does look like I wasn’t being patient enough as the fan is now set to a minimum of 55 mins/hour.

The spread between the high & low temp is still pretty high – it will be interesting to see if this approach can actually help with the situation.

Question: If the temperatures start to converge, will the app decrease to minimum run time to 0 on the ECOBEE?

Marc

Yes, it will decrease the time once the temp delta gets below the setting you choose, and it will return to 0.

They may not converge, however.

You may need to consider adding smart vents to the rooms that are warmest, and then have those close when the temp is right, forcing more heat to the other rooms.

Hi Barry, thanks for all the info.

Alas, they are not converging. I’ve closed off the vent in that room, which solves one problem (room gets too hot during morning warm up) but creates another problem (running the blower motor doesn’t circulate the air from that room in a meaningful way).

The problem isn’t as bad as it used to be with the ecobee and remote sensors. The worse-case delta has decreased from 10 degrees to 5 degrees, and virtually no difference during the morning warm up.

I may pick up a few smart vents to see if that will improve it further.

Marc

Let me know how it goes. I’ve been testing a version of the Smart Vents helper that closes the vent when the room is too warm, but opens it when the HVAC is in Fan Only. Might be just what you need.

FWIW, I use the Econet vents, but the Keene’s are reportedly very good as well.

Hi,

I’m having a problem with the routines helper app. I set it so when my ST mode changes to Away, the Ecobee changes to Away and same with Home. It seems to set the Ecobee to Away & hold when the mode changes to Away but when the mode changes to Home, the Ecobee resumes schedule instead of changing to home and holding.

Any suggestions? Not sure how to troubleshoot this.