[DEPRECATED] Ecobee DTH and Helper SmartApps

I’m almost positive it is your DTH. It’s the same name as the stock DTH, but it is at the bottom of my list with all my other custom DTH’s.

You definitely aren’t using my version of Ecobee (Connect). If you were, you would see the screen as shown in the screenshots earlier in this thread, and there would be a version number at the bottom of the Ecobee (Connect) setup page. (If it is there, please tell me what version it displays).

You should double-check that you have installed, saved and Publish/For Me all 8 of the SmartApps and both of the Ecobee device handlers…it appears something is missing.


Here’s the version i have

FWIW, at this point, you will probably have to delete the current Ecobee Thermostat device, and the current Ecobee (Connect) smartapp, and then start all over.

Note that this DTH is not installed directly - instead, you must first install all of the DTH and SmartApps into your IDE as described above. Then, start Ecobee (Connect) from Marketing/SmartApps/My Apps. You then sign in to your Ecobee account, and exit Ecobee (Connect). Then re-enter it from Automation/SmartApps, and then select your Thermostats, Sensors and set any preferences you wish to use. Ecobee (Connect) will create the necessary devices and begin populating them with data.

Then, go back into Ecobee (Connect) and go into the Helper SmartApps tab to create the Contacts and Switches helper. From there, you should be good to go…

@storageanarchy Your README references posting issues to Github, but it looks like you have Issues turned off on your repository.

I’m trying to install the Ecobee (Connect) smartapp, but when I “Tap for ecobee Credentials”, nothing happens. In live logging, I see the following error:

java.lang.RuntimeException: Unexpected status code 400 from global /clients/null with status text @ line 237

I’m running Ecobee (Connect) version 1.1.9. I was previously using the stock ecobee integration, but I removed all of the ecobee devices (thermostat and sensors) and uninstalled the existing Ecobee (Connect) app (or at least I attempted to - during removal I got an error, but it no longer shows up in my smartapps list).

Thanks for all of your work on this!

First thing to check: did you enable OAuth for Ecobee (Connect)?

You should also double-check in the IDE that the old instance of Ecobee (Connect) is in fact deletes, along with all of the old instances of the Device handlers (thermostat and sensors).

Do you mean make sure I did the hard-to-miss step from the instructions in bold text that says:

NOTE: This is a commonly missed set of steps, but failing to enable OAuth will generate cryptic errors later when you try to use the SmartApp. So please don’t skip these steps.

… oops, I knew it would be something obvious (though it’s doubly bad since there’s a specific note about it being commonly skipped!). Since I already “knew” how to install via Github integration, I just skimmed right over that section. Enabling OAuth allowed me to enter my credentials and complete installation.

Thanks for your help, and thanks again for all of your work on this great project - it is awesome!

Main ecobee Sensor icon shows offline?

Also why is it cooling to 85 when inside temp is already 76. Shouldn’t it be off/idle?

Any ideas @storageanarchy?


Redid an ecobee reconnect and that fixed it.

Seemed connection dropped :confused: but good to go.

I see the same thing from time to time, caused by some mysterious loss of synchrony with the Ecobee Cloud. I don’t know if I’ll every actually catch it, but thankfully it’s simple to resolve. Just wish it didn’t require manual intervention…

Any Live Logging traces you may have when this occurs (or even better, just before) would be helpful…


It’s my pleasure - and glad that it was the “simple fix” problem :O)

It’s been a while since I actually went into a sensor device on Smartthings. Are the icons supposed to be very small. I thought I remembered them being full size. For me the Current Setting icon is full size, and then three smaller icons for home, away, and sleep, and then a small icon for refresh. it not "bad, but it a bit hard to read.

These are intentionally small, as they are intended as indicators - they will display solid when the sensor is included in the respective programs (home, away, night), and you can press each to add/remove from the respective programs.

Sorry for the slow response! There is no note with the temperature units or version number on the setup process of the connect app. Either that or I’m looking in the wrong place. This is where you select your main thermostat and sensors, yes?

That means that you are not running MY version of Ecobee (Connect) and/or Ecobee Thermostat. Please be sure that you have installed ALL of the components of my version (and ideally deleted all of the existing/current ones you are using). There are 2 device handlers and 8 SmartApps…



Hi Barry,

All of my smart apps and device types have your name and Github handle next to them, which I assume means they’re all yours. The API also shows that all of my smart apps are synced to the current version in the Github.

OK, but have you published them all?

The following should appear on the Thermostat Selection page of Ecobee (Connect):


The temperature units (F or C) is determined by your Location settings automatically. Please update your Hub settings (under My Locations) to change the units used.

The current value is (F or C).

If this doesn’t appear, then something is wrong – perhaps you have published to the wrong Shard?

Double-check the version number of Ecobee (Connect) – it should appear at the very bottom of the main setup page…can you tell me what that says. Please?



I had the correct DTH and SmartApps, the problem ended up being me manually changing the DTH from the IDE. That apparently messes with the whole setup.

Please note that version 1.2.0 has been released on August 5, 2017. Please visit this thread for more information:

@BARRY, is the Ecobee Connect project still being updated? I wanted to test the app with an Ecobee Lite. Thanks thanks.