[DEPRECATED] EchoSistant Version 4.0 ~ Evolved

I’m also getting the below message at the test step - same observation as @Graffix3001

I’ve enabled Debug Logging in the App settings, but nothing appears in the IDE Log after I click “Ask Echosistant…”

(Can confirm that the Live logging is capturing Echosistant events though, because I just called my list of devices and it shows fine)

_ “response”: {_
_ “outputSpeech”: {_
_ “type”: “PlainText”,_
_ “text”: “There was an error. If this continues to happen, please reach out for help”_
_ },_
_ “card”: {_
_ “content”: “There was an error. If this continues to happen, please reach out for help”,_
_ “title”: “Lambda Error”,_
_ “type”: “Simple”_
_ },_
_ “shouldEndSession”: true_
_ },_
_ “sessionAttributes”: {}_

Can you please post the EchoSistant logs after your test? I assume that it might be a default value that hasn’t been activated…but that’s just a guess without some logs…

That’s the issue…I know you asked @Graffix3001 to do the same…but running the test results in nothing being displayed in the Live Log in the IDE


Great job Bobby and Jason!

1 Like

Where are you located? Could you please post the link of your ide? Both of you may be on a different shard…@Graffix3001

Wiki Troubleshooting…
Step 1 - Log into the ST IDE at https://graph.api.smartthings.com/ (your log in page may be different if you are on a different shard)


My IDE is at:


All that has appeared on my IDE for Echosistant so far (and that’s not in response to running the test…but noticed it sometime after) is as follows:

Ok, could you please go into Lambda code and update line line 30, to reflect your API path correctly?

var url=‘https://graph.api.smartthings.com:443/api/smartapps/installations/’ + STappID + ‘/’ ;


var url=‘https://graph-eu01-euwest1.api.smartthings.com:443/api/smartapps/installations/’ + STappID + ‘/’ ;

1 Like

Yep - that fixed it. I’ll carry on working through…I hope all the rest goes smoothly so that I don’t have to bother you again.


1 Like

I’m stuck at the Service Simulator of the HallBath Profile. I’ve recreated and check the steps up to this point and I get the same error.

One unrelated (or not) point.
when I created the main and child apps. I published the main and not the children, but when I updated from Repo, I hit the Publish box and hit update which publish the rest of them. was there a better way to do this. could this have caused problem?

Do you have a profile created in the app called HallBath?

I believe it doesn’t actually ask you to create a profile in the app until after this step in the instructions, but I ran into the same problem and then realized I had not yet created my profile.

1 Like

I saw that.

i tried with and without creating a Profile in the App. I’m also confused based on recent post it I have to add that Profile name to the LIST_OF_PROFILES in the Main Intent Skill

No LIST_OF_PROFILES slot exists in the new version. The Wiki is being updated. @bamarayne

To test a Profile, two things must happen. A Profile skill must be built and a counterpart Messaging and Control Profile matching the intent name (not the invocation phrase) must be created.

Sorry for the confusion! The Wiki document is a monster but is catching up fast…

I deleted the custom slot LIST_OF_PROFILES and created a Profile in the app to turn on a switch called HallBath and the intent name is the same.

I’m still getting same error in Service Simulator

That shouldn’t be a problem. The reason one may not want to publish both is so you don’t see the Add-on app under your SmartApps tab. IF you are using secodary accounts, it is recommended that you publish the Child apps or otherwise attempting to open a non-published add-on will throw an error…

Here is how I set up one of my Profiles…

My intent name is Gabriel

My Messaging and Control Profile is also named Gabriel

RULE OF THUMB with Profiles…

To run actions selected under “Select Location and Device Actions” a speaker OR a phone number must be selected on the “Send These Message Type”.

—because too many have had problems with this, next update will have the two sections hidden until a selection is made…

To control a Group (turn lights on/off, TV on/off)…devices MUST be selected on the “Create Groups and Select Devices”

To TEST a Profile, either a speaker/phone must be selected and an Action created OR a light switch must be selected under “Create Groups and Select Devices”…OR BOTH

Hope this helps!

On the Main intent, I get an error:

I have no profiles set up in the system (yet). Some of my device names have an apostrophe in them, though I’ve tried both with and without the apostrophe in the list of devices.

I’m struggling. Help?

I’m stuck at the Service Simulator with an “There was an error.” response. Suggestions? Or just go through the process again and make sure I didn’t do something wrong?

This clarifies the wiki, but that’s what I have in skill and App.

I understand that this was to test functionality, but in the future, do I created the Profile in the App and then create the skill in Developer’s Console.

What you typed in for the test would be sent as a voice message. That does not work from the main intent. You must have a profile configured and you send test messages from that profile.

Try this in the main…

Turn on xxxxx light

 "response": {
    "outputSpeech": {
      "type": "PlainText",
      "text": "Sorry, I heard that you were looking to on the livingroomlamps but Echosistant wasn't able to take any actions ,  would you like to try again? "
    "card": {
      "content": "Sorry, I heard that you were looking to on the livingroomlamps but Echosistant wasn't able to take any actions ,  would you like to try again? ",
      "title": "EchoSistant Try Again",
      "type": "Simple"
    "shouldEndSession": false
  "sessionAttributes": {}